Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

Can't install AMD Firepro drivers windows 10

I have a Dell precision m4800, lots of space on my HD, 16GB of ram, I7 gen 4, with some version I cannot determine of the AMD Firepro card. I had good AMD drivers installed using their software..but..

One day, when playing GTA V...the computer made an odd sound and the screen froze. Upon rebooting, I had a blank screen.

I went into safe-mode, disabled the amd stuff and worked, but game-play sucked...kept pausing or "hanging up." and the graphics were not as good at all..though load times were much faster oddly.

I'm trying to install the latest AMD drivers for this card.  The normal "auto detect" software does not work, when I try to install it just tells me there is  problem and can't download it...  When I first got this computer, I downloaded and installed the drivers without issue... now ever if it detects the video card (it does rarely) it crashes 70% of the way through the download.

I ran a program to fully delete the old AMD drivers, but now it only loads windows basic drivers and video games cannot be played. When trying to install the AMD drivers again, the AMD software finally would seem to detect the card, but only gets about 70% of the way through..then crashed my computer...locks it up.

1. How do I tell EXACTLY what version of this video card I have ? All the websites are lame and stupid and assume you can just find this in your device manager, which I assure's not there.

2. I ran a program that's suppose to uninstall all graphics drivers, but it did not solve the problem. How can I fix this? I'm STUCK with windows basic drivers and I'm getting like 5 frames a second in GTAV...unplayable.

3 Replies

Have you tried downloading GPU-Z and use the 'Lookup' button to show card model.

From what i found on dell site it seems you have a M5100 Mobility Pro (confirm or not with gpu-z).

If so manual download/save/install driver from amd site.


Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

That did not work. I found the card, downloaded the exact driver..  but at 39% it locks up windows solid. Waited 30 minutes..nothing.  Upon reboot...blank screen. Now I gotta go back into safe mode and enable the basic drivers again..sigh.

What is the problem here? The only thing I can report is that even though I was supposedly downloading the correct driver for this card, it still seemed to force an auto-detect upon install...and the card listed I did not recognize.

At this point, I have to assume there was a Windows 10 update that has caused the drivers to be broken.  AMD obviously won't address this since it's old.

Do I have any options?


Is there any way I can get the actual drivers for my card instead of a program that always auto-detects when it's supposed to be a direct driver? (why would AMD do that? Mind BOGGLING!)

I am in shocked disbelief that I cannot install any video drivers. AMD software keeps forcing auto-detect and it always detects wrong. 

Anyone know where I can download TRUE stand-alone drivers for this card without any auto-detect?