Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Application (Civilization V) has been blocked from accessing graphics hardware

I get this error: Application (Civilization V) has been blocked from accessing graphics hardware. I have tried many attempted fixes and nothing works. I have a Radeon R9 270 (I think) with 2GB of DDR5VRAM. I use a Ryzen 1500x CPU, and 16 GB of DDR4 RAM. I have tried underclocking the GPU and I have tried searching for other/new drivers nothing seems to help. Interestingly windows update gives me a driver for R9 370 and AMD support gives me a r9 200 series driver. I can play the game a few turns before it spits out that error then crashes. On rare occasion it crashes to a blank screen where my keyboard isn't even getting power? I then have to hard reset my desktop to restart my computer. Oh and I also tried the TDR delay method I have found on other fourms. I have also since turned down my graphics settings in game all the way (I shouldn't need to do this for a game this old!) and still get the error. I need help!

0 Replies