cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Vuudrasil
Journeyman III

AMD Radeon RX 5700 XT install not working

Hello,

I recently tried to update my graphics driver as I am not able to load games, open device manager, event viewer, adobe acrobat, installers, or some other processes/applications. After I downloaded the driver update in the AMD Radeon Software, and pressed install it immediately closed the installer. 

I currently have Radeon 21.11.1 and am trying to update to 21.12.1.

I built my computer a year ago and for the most part it has been running fine. I am wondering if anyone has any insight or knowledge on how I can fix this. I can provide more information if needed as I do not know what else may be relevant.

I appreciate any help,

Vuudrasil

0 Likes
8 Replies
ThunderBeaver
Miniboss

I have no experience with the 5000 series GPU's so take my advice with a grain of salt.

Try doing a factory reset install but install the display drivers only. This should tell you whether its a driver or adrenalin package issue. I've had trouble with adrenaline back when they introduced Global Wattman. Settings at the time on my 2 HD 7890's worked great until global Wattman which kept shutting down my PC and the only error message I received was Adrenaline software has shutdown for an unknown reason. Same message was in the event history. You could try a 3rd party GPU tuner like MSI afterburner.    

0 Likes

I would do that, but the problem makes it so I cant install anything

0 Likes

One other solution I just remembered when I had the very same problem with a new GPU.

If you have an older GPU this has always worked for me.

Uninstall current GPU software manually.

Power down PC unplug power cable and make sure PSU switch is in the open/off position

Hold down power power button for 10 to 15 seconds (helps to reduce risk of any static discharge from remaining charges built up on PC hardware).

Remove 5700X and install old GPU. Power PC back on go to AMD and download new 5700x driver but DO NOT INSTALL.

Shut down PC and disconnect power cable. Remove old card replace with 5700x power PC back on and find the 5700x Radeon driver folder and install. 

If this work around doesn't work you may need to upgrade your .NET framework through windows update. Your CPU chipset drivers and check your MOBO manufacturer website for BIOS compatibility downloads. It could be as simple as your BIOS only recognizing PCIE 3.0 and not up to 4.0. 

0 Likes
M_RAFFAY
Adept I

Try uninstalling the previous drivers and then install

Try installing with ANTIVIRUS DISABLED or WINDOWS DEFENDER REAL TIME PROTECTION DISABLED

That should work 

ALWAYS HAPPY TO HELP
0 Likes

You may have a corrupt OS , have you tried SFC and/or DISM (Tutorials can be found on the web) ?

 

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..
0 Likes

Like Command Prompt (Run as Administrator)

Then type in sfc /scannow then press enter this will check for any corrupt or missing OS files on your system.

Honestly with Windows 10 every time a large update or new version comes out I run this command prompt and find missing files around half the time and corrupted files around 30% of the time.

I have also found it a necessity to clear the windows update catch manually since windows 10 does not store old updates in temp folders which generally would be automatically deleted after 30 days. This update catch can really slow down your system and in some cases like I experienced software conflicts.

 

0 Likes

First of all i would like to know what version windows and which driver you downloaded

Second of all i noticed already very weird behaviour of AMD driver software which often makes its own installer map but can not access the files itself as it has no rights

The trick i use is depending if you have a second drive or not

When amd starts to install i let it install the files then when shows the real install screen and wants to acutually install the driver i close the program by simply kill the proces 

I make a new map with the name i prefer like 21_10_1  on my other drive which in my case are 14 choices to make so to make it easy i choose the D drive which is a USB backup drive which can house the amd map easily

Then i go into the silly install map and click till i see the installer and move one step back and then copy and paste the whole map over to that newly made map on the D drive

Then i right click on the map and give the map my user rights to full access

The reason is that if you leave it where it is installed most of the time on the C:  drive it gets somehow locked out by windows

I tried before giving it rights but it still kept giving weird behaviours, i do not want to install from scratch my machine because i have so many programs that it would take me months to get it back working as i want it again.

Anyway after that i moved the folder over and gave it my user rights 

I can install without issues, i kinda got the idea that AMD messed up one or the other previous installs as it never installs normal anymore.

So depending on what version windows your running i would not advise the latest drivers at all with the 5700XT

AMD never really releases new drivers for older hardware with functional improvements for these cards

What they do is make a massive package and say that this is new while it only contains better drivers for the latest 2 generations i never saw any real improvements for pfffeww 2,5 years now for the 5700 series if not longer

And worse is i am actually considering to go back even further with the crappy drivers they released the one i am using is 21.10.1 and that suddenly is also no longer stable so i am going to dig deeper in the paste to find a driver which is REALLY stable.

It is kinda weird that all of a sudden this driver version suddenly became so crappy sadly the old installer was damaged so i had to download it new from AMD and poof the problems started all over again

So now once every 3 to 6 days the drivers crash without any usefull info.

 I have been sending endless crash reports but decided to stop as i am certain it useless as the new win11 drivers are ABOLUTE not compatible with win 10.

The moment i install them and the screen popped up it crashed so i rebooted and the machine hand for a long time and started rebooting like an idiot .... so after that disaster W11 drivers never are going on my system ever.

If you do run W11 the above mentioned rights trick can be the solution maybe you can simply suffice with just giving the installer map rights but for me ends in the same thing never worked 

I am sure it has todo with the loads of securiy patches M$ released which often do more harm than good, i simply do no longer want to dig to find out which one is the now the culpritt anymore as it almost becomes a constant job todo when you update windows. 

W11 is not coming in my system for as long as possible because i do not need another crappy user interface update

It simply nothing more than those who tried to proof me that it actually had been improvement could not find anything usefull nor proof at all that it is a better OS untill now. All is asumption because M$ says it is better.

 

 

0 Likes

Like ubronan is saying, try right click and run as Administrator, or take control of the file, you can find guides online for how to make yourself the owner of the file.

0 Likes