cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

AMD Radeon PRO W6800 no display

Hello, I'm in need of help regarding the troubleshooting of my "Radeon PRO W6800 32GB".

My GPU is currently unable to display anything on the screen, despite it seemingly running. The fan is spinning, the GPU produces heat and is even detected by GPUZ on Windows:

Capture.PNG 

Although it being detected, a lot of information seems to not be detected, indicating more than just a simple display port issue. 

I deleted my driver with DDU and reinstalled them, but it didn't change anything and the Radeon Pro software give the pa-300 error code.

Interestingly, the GPU seems to be able to mine bitcoin on Linux, even if that's not what I'm using it for it proves that the GPU itself is not completely dead.

If anybody has an educated guess on what might be the issue, he is very welcome to share it.

0 Likes
35 Replies

Just looking at your GPU-Z it indicates that the AMD driver is not installed correctly or is corrupted.

At the bottom of GPU-Z you should have at least enabled API's "OpenCL, Vulkan, Direct Computer, and possibly Ray Tracing if the GPU card supports that feature.

Here is a older GPU-Z for the same W6800 GPU card with the AMD Driver installed correctly:

Screenshot 2023-11-05 191707.png

In the past that error PA-300 was caused due to Windows Update installing a different AMD driver after installing the new AMD driver. So make sure that Windows Update didn't install a different AMD Driver after you installed the new AMD driver.

Also it is possibly your professional GPU card vBIOS might have been altered for Mining purposes thus you might need to find the original GPU Pro vBIOS and update your vBIOS to see if that fixes your issue. Unless of course it isn't a used GPU Pro card and was purchased brand new.

You didn't mention if you are using Windows or Linux as your Main Operating System.

Otherwise for AMD Moderator of Professional GPU cards @fsadough you will need to give a detail description of your PC hardware and software and what you are using it for.

NOTE: Here is the latest Windows and Linux AMD driver for your W6800 Professional GPU card: https://www.amd.com/en/support/professional-graphics/amd-radeon-pro/amd-radeon-pro-w6000-series/amd-...

Also when using DDU make sure you have the internet disconnected and deleting the AMD Driver installation folder at C:\AMD BEFORE installing the driver again.

I tried to reinstall the driver with DDU and the network unplugged, after, I flashed the vbios using amdvbflash utility, sadly, the issue remains.

Here is my pc hardware and software:

  • OS: Windows 10 64bit
  • CPU: AMD Ryzen 3600
  • RAM: Corsair Vengeance LPX DDR4 2x8GB 2666MHz
  • MB: MSI B450 Tomahawk
  • Storage: Samsung 970 EVO Plus
  • PSU: 750w 80+Gold

This is my home computer, so I don't have particular usage for it.

@fsadough  will probably reply sometime start next week. He might be able to advise on how to resolve your issue with your Professional GPU card.

Did you try to install the AMD Pro driver or the AMD Adrenaline driver?

Try install a previous AMD driver in case the latest might have issues with your PC from here: https://www.amd.com/en/support/previous-drivers/professional-graphics/amd-radeon-pro/amd-radeon-pro-...

By the way, after doing all that from your last reply is GPU-Z still showing the same missing data as before?

  • What is your monitor's make and model?
  • How are you connecting your W6800 to the monitor?
  • Please specify the cables and adapters you are using.
  • Please provide an AMDZ Report and upload via "wetransfer"

  • AMDZ Report
    - Please extract the amdz-v334.zip available from https://go.wetransfer.com/t-XjitlZnwFh
    - Run amdz.exe file as an Administrator
    - Select “Save All“ and “TXT“ as the output format
    - Click on the blue button to save the report
    - The .txt file will be saved in the same folder where you extracted the zipped file

  • My monitor maker is LG, model 25UM58-P
  • I'm using an adapter mini DP to HDMI: Amazon link 
  • As for my HDMI cable, it's not branded and was bought in a grocery store.
  • Here is the WeTransfer link for the AMDZ report: https://we.tl/t-RWhDzFXYlM 

  • Do you get display, if you connect the monitor to your Nvidia card?
  • Any reason you are running GeForce GTX 1060 + W6800 together?
  • W6800 does not seem to be active, since no VBIOS info available.
  • Your system BIOS is very old, try to update it from:
    https://download.msi.com/bos_exe/mb/7C02v1I.zip
  • Your motherboard seems to be too old to support 1x W6800 + 1x GTX 1060

  • I get display when the Nvidia card is connected to the monitor
  • I am running the Nvidia card to troubleshoot the W6800
  • I updated my mobo's BIOS

What I tried:

  • Putting only the W6800 on the top slot won't boot (the VGA debug light on the mobo is lit up).
  • Putting the W6800 on the top slot with the 1060 won't boot (the VGA debug light on the mobo is lit up) and does not try to boot on the 1060.
  • Putting only the 1060 on the bottom slot boot work normally.
  • Putting the 1060 on the top slot with the W6800 on the bottom one boot. But as you mentioned, doesn't seem to really activate the W6800.
0 Likes

Since I'm not the original owner, I'm afraid I cannot apply for the warranty service. However, it's worth mentioning that I am well-versed in the electronic world. It would be extra helpful if you could guide me on what to troubleshoot, no matter scope. Off course if its not too much to ask.

0 Likes

For troubleshoot you would need another mainboard to try the W6800 on 

Im not sure if this can be of any help, but yesterday while installing archlinux for test purposes, I came accros multiple error: 

In the arch linux installator got error: "[drm:amdgpu_ras_eeprom_init [amdgpu]] *ERROR* Failed to read EEPROM table header"

And while booting in arch linux, I got this error: 

20231108_011747-1.jpg

 I'm not convinced that this bring more info than window's error code 43 but, who knows, certainly not me.

0 Likes

Arch Linux is not a supported OS. It would be better to install Ubuntu 22.04.3 and see if the error message comes up

 

(deleted)

0 Likes

Take the card to your local pc sales/repair store, ask them to test it (might be a small fee)?

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

Hi, after relooking inside gpuz I finded that resizeable Bar was activated for the gpu. However since my disk was using Mbr instead Gpt of I couldn't boot in UEFI mode and utilize resizable bar. After reinstalling in gpt and activating resizable bar I managed to get output from the gpu. Sadly it is still not recognized properly: Here is We transfer link to a video 

0 Likes

In GPU-Z move your mouse in the BIOS Version input box and then a pop-windows will appear. Try to capture a screenshot from the screen and attach it here

0 Likes

Yeah well about that, I tried to reflash the bios, and now it seem to be fully bricked, computer won't boot no matter in what slot it is. Will have to buy one of those handy eeprom programmer I guess.

0 Likes

Soo, after some trial and error, it appear that currently the card will not let the computer boot if the bios is in UEFI mode, however, if in (legacy + UEFI) mode the card work like at the start (is detected in gpuz but won't output).

0 Likes

Okay ! So after retrying everything, it appear that it was actually installing arch linux that fixed the vbios ? Soo she is now able to output but still doesn't get detected properly in windows. 

image_2023-11-09_143350280.png

Also, I don't know if it's relevant, but GPU-Z is currently reporting only 30720 MB of VRAM. Is it possible that a VRAM chip is not working and preventing the card from being properly recognized?

0 Likes

Also, the ROM that is currently on the GPU and was downloaded from the VGA BIOS collection on the TechPowerUp website gives some errors when analyzed with GopInfoX : 

4eae16d8-fc58-4f6d-91d6-1aeac8b825c4.png

I don't know if it's expected behavior or if the ROM provided is corrupted.

0 Likes
fsadough
Moderator

Please try to update the Video BIOS of your W6800. See the link below:
https://we.tl/t-EHqcwcsbMf

 

Capture.PNGimage_2023-11-09_165845330.png

I flashed it, but it returned to the no-output state.

0 Likes

After starting ArchLinux it was once again able to output: image_2023-11-09_172837107.png

However, if you pay close attention, you will see that once again, the reported memory size is 30GB rather than 32GB, and it's using OpenGL 1.1 instead of 4.6. I have no clue what Linux is doing, but it's definitely able to make it output.

Arch Linux is not a supported OS. It would be better to install Ubuntu 22.04.3 and the associated AMD driver.  Where does the screenshot of GPU-Z coming from? As far as I know GPU-Z is not supported on Linux.

0 Likes

Ok, I probably wasn't clear in my explainations:

0. The gpu is not able to ouput.

1. I flash the Vbios in windows and I get the first gpuz pictures, I reboot, but the gpu still doesn't output.

2. I discovered that booting on linux just once makes for some reason the gpu able to output.

3. I boot on windows with the w6800 now capable of outputing and the get the second gpuz picture.

I hope its clearer.

0 Likes

You wrote:

3. I boot on windows with the w6800 now capable of outputing and the get the second gpuz picture.

  • Is W6800 the only card in the system? 
  • Please run AMDZ Report and provide the output.

In the 3rd case the w6800 is indeed, the only card in the system.

I won't be able to post the AmdZ report untill this evening and I suppose you won't be there this week-end, so, to win some time, it would be nice if you could ask everything you want me to try or post now.

If you could try the W6800 in another system to rule out defective hardware.

0 Likes

I already tried it in other system

0 Likes

0 Likes

  1. How did your W6800 behave in the other system?
  2. Did you try the AMD Pro driver and see if you get VBIOS detected?
  3. If it is not working, file an RMA
0 Likes

  1. The W6800 behaved in the same way.

  2. I tried both the Pro and the Adrenalin, and I got the same Pa-300 error.

  3. As I previously stated, I cannot file an RMA because it requires proof of purchase, which I don't have since I'm not the original buyer. Additionally, the previous owner had it water-cooled, and I'm pretty sure that it completely voids the warranty.

0 Likes

I received my new EEPROM programmer (Ch341A). And it, too, couldn't read the EEPROM. I'm starting to seriously suspect the Vbios EEPROM to be dead. Waiting for your thought on this, meanwhile I will buy the same EEPROM to confirm that my setup is good.

If the GPU has been altered there is nothing we can do.

mpryandds
Adept I

Chris:  Hi! Of course the monitor must have its input set to the input cable signal type...DP, HDMI, USB-C(alt DP)...on the monitor.  Make sure 'extend these displays' is chosen under multi-displays.  Peace!

0 Likes