Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

AMD GPU not in device manager. AMD driver update error 1603. Windows Update 0x8007007e. Any help would be appreciated.

It all started when I simply tried updating my dad's AMD R7 360's drivers through the Radeon software - got an error 1603.

  1. Then i realized the GPU was no longer identified at all in Display Manager.

  2. I wiped the drivers with Display Driver Uninstaller in safe mode, but I get the same error 1603 with Radeon software.

  3. Then I checked Windows Update and saw 3 updates:

Windows 10, version 1809 amd64 2019-03 (which always ends with error 0x8007007e) ,

AMD, Inc. driver update for AMD Radeon (TM) R7 360 Series (error 0x800703fb)

AND AMD - MEDIA - 11/16/2017 12:00:00 AM - (error 0x800703fb)

4) I've tried clearing the windows update folder so it re-downloads the updates in case but the same errors occur.

6) I've tried running sfc /scannow which leads to "Windows Resource Protection could not start the repair service." DESPITE enabling NetTrustedInstaller

7) I've disabled Windows Defender multiple times but the Radeon software still displays an error 1603 (even after wiping them in safe mode with DDU). Same with Windows update.

8) I've re-installing Microsoft Re-distributable - no change. 

9) I've ran the DSIM RestoreHealth in cmd - it leads to 0x800f081f - "The source files could not be found"

I've researched quite a few forums and I just can't find a solution to anywhere to this. Would someone be please please guide me through this? I can post logs if required. My theory is the newest GPU software requires a certain version of windows which was failing for different reasons even prior the GPU update error occurred, however I can't confirm this.

My dad's specs are: AMD Phenom II X4 955 3.2 Ghz, 8GB RAM, Windows 10 Pro 1803, OS build 17134.285


I am unsure how to find my GPU in bios, but I looked through every possible setting in Bios and I only see the HDD/SSDs, no mention of a GPU anywhere. I also disabled quick boot to see if this would make a difference: it did not.

0 Replies