Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

7900xtx not recognizing 4k 120hz refreshrate.

Guys Im hooked up to a hisense ugh that my old rig can play 4k 120 on all day, I upgrade my pc to a 7900xtx (7900x3d cpu) and am using the proper cables and ports/ connections. Ive watched about a hundred videos about this or that radeon setting should be on or off. tried about everything i can think of but I still cant enable 120hz refresh at 4k. I know this has been an issue with drivers on older cards in the past but any help or advice would be appreciated. 

1 Reply
Volunteer Moderator

I'm not sure what you have all tried but have you gone to display settings (right click on desktop) and then to the advanced settings tab where the refresh rate is and manually switched it to 120hz? Some monitors/ TVs also have it in the menu of the monitor/ TV itself.

Screenshot 2023-03-23 100153.png

Ryzen 7800X3D - RTX 4090 FE - ROG Strix B650E iGaming - 64gb 6000mhz G-Skill Neo - Arctic Liquid Freezer ii - ROG Loki Platinum 1000w SFXL - 5TB of Crucial P5 Gen. 4 NVMe - NR200P Case - ROG PG48UQ OLED