Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept II

7900 xtx driver timeout

Hi guys, I recently built a new PC using AMD products for the first time. So far, I'm very pleased with the performance it offers, but I'm facing a problem with some games that I can't understand.

Until now, only Palword (which worked perfectly on my old PC with a 1080ti) and Helldivers 2 are completely unplayable (while other products like Destiny 2 run perfectly). What happens is that when I load into the game, the screen freezes, goes black, and then I receive an error message about an AMD driver timeout. I managed to play Palword for 1 hour initially, but now I can't even load the game, and with Helldivers 2, I can't even complete the tutorial.

I've tried a fresh install of Windows, used DDU to reinstall drivers, installed older drivers, and even undervolted the GPU (next, I'll try limiting the GPU frequency to 2500 MHz).


  • CPU: AMD 7800X3D
  • RAM: 32 GB Trident Z5 6400 MHz
  • GPU: Sapphire Nitro+ 7900 XTX
  • PSU: be quiet! Straight Power 12 Platinum
  • Motherboard: Gigabyte B650 AORUS ELITE AX
7 Replies
Journeyman III

How many watts is ur PSU?


1000 W



I built a pc for my friend with very similar setup: 7800X3D, 7900XTX, B650 Aorus Elite AX, Straight power 12 850W, 32GB 6000MHz ram.. and he is experiencing identical issues in CS2 & wow classic, Rust have yet to crash.

Tried fresh minimal driver install with DDU, but no difference. I don't have access to his system at the moment so can't really try any advanced stuff out.

Did you try driver version 23.12.1?


I tried the 23.11.1 and it had the same problem, later I'll try on CS2 too.


Okay, I tried CS2, and it seems to be working fine. I need to test it during longer gaming sessions.

Regarding Helldivers 2, I found out that the game has some problems with the new AMD GPUs. Therefore, lowering the graphic settings appears to be a temporary solution.

With Palword, I tried lowering the GPU frequency to 2500 MHz and adjusting the voltage, and it worked for 40 minutes. However, I need to conduct longer sessions to confirm its effectiveness.

For some reason, I noticed that the LED on the motherboard for the VGA remains on, and I can see some flickering on the desktop (not noticeable in-game). Restarting the PC turns off the LED on the motherboard, but the slight flickering persists.

Adept I

The Same Problem now how on Release from Forza Motorsport with the 7900XTX

Adept I

And AMD sleep ,no new driver