Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

7900 XT No output

I have a 7900 XT that I bought in December and today I went to turn on the PC, but got no output to the screen — no bios splash screen or anything.

The motherboard isn’t giving me any error codes and the screen works with other computers, so I’m assuming it’s the graphics card. The fans appear to spin, so it’s getting power.

I have a 12700kf so I’m unable to plug a monitor into the motherboard directly.

I’m not really sure what to do at this point. Any ideas?

8 Replies
Adept III

Based on the information you provided, it seems that your AMD Radeon RX 7900 XT graphics card is not displaying any output to the screen, even though the fans are spinning and the card appears to be receiving power. Here are some troubleshooting steps you can try:

  1. Check the display cable: Make sure that the display cable is properly connected to the graphics card and the display. Try using a different cable or port to see if that resolves the issue.

  2. Reset the graphics card: Turn off the computer and unplug the power cable. Remove the graphics card from the motherboard and reseat it firmly. Plug the power cable back in and turn on the computer to see if the issue is resolved.

  3. Update the graphics card driver: Check for any available updates for your graphics card driver. If you're unable to update the driver on your current system, you could try booting into safe mode and updating the driver from there.

  4. Try a different PCIe slot: If your motherboard has multiple PCIe slots, try inserting the graphics card into a different slot to see if that resolves the issue.

  5. Test the graphics card on another system: If you have access to another system with a compatible PCIe slot, try installing the graphics card on that system to see if it displays output to the screen.

  6. Contact the manufacturer: If none of the above steps resolve the issue, it's possible that the graphics card is faulty. Contact the manufacturer's support team to see if they can provide further assistance or arrange a replacement if necessary.

In summary, if your graphics card is not displaying any output to the screen, there are several troubleshooting steps you can try to identify and resolve the issue.

Strangely, I tried all these items and none of it worked. I finally pulled the card and took it back to the store. They tested it on a bench and it worked fine. I took it home, reinstalled it, powered it on and it worked! So, I dunno… I guess maybe pulling the power cables and reinserting those did something??? 

Either way,  it now works, so calling this the solution. Thanks for your advice!


Did you update to 23.3.1??  When i did, it now takes me to hit a key on my keyboard, to get both my displays to turn on. Super odd. Before, when i turned the rig on, my displays (a 27" and a 32" samsung g7's) would just turn on. Now,.. i MUST hit a key on my keyboard, to get both to come alive.  I did the same thing. Updated, and .... nothing on screens. But my rig/mobo didnt show any error. At all. All seemed normal, but both displays are off, and spite the fact i had to "hit any key" to get my monitors to run. Ive talked to 4 others, that i know, that its the same. Something in the start up/boot changed for us. 


Any update on your issue? I'm having something similar where on start up, everything would spin and start up fine, but there would be no video. However, no matter what I press, nothing shows up. I would have to restart my computer and then there would be video.

I've checked event viewer and it used to show a warning regarding the drivers, saying it failed but successfully recovered. After corresponding with AMD support, that error went away, but the problem persists. I want to know if I can fix it as my return window for the card is running out.



Nope. Ive just been "hitting the any key'" like i did in 1988. Something is odd with the boot/start up imho. My junk is running, but why and how all these changes just suddenly appeared, after this update, is beyond me. I am one update behind, and im scared to do the new one. 



7950x/Asus x60e-e/ddr5-6000/7900xtx/seasonic 1000 titanium


I'm on 23.2.2. The update on my situation is that if I leave my PC idle (and locked) for a few hours, I will often return to it in some kind of weird sleep state. If I try to power the computer on at this point, nothing will come on the screen. I have to power the computer off at the wall in order to get it to power on correctly. Even more strange is that sometimes when doing this power off/on process it is unable to load the display drivers and I have to reinstall Adrenalin.

Screenshot 2023-03-06 061911.pngScreenshot 2023-03-06 062223.png

Adept I

I had the exact same problem, it came from my motherboard and I had to change from CPI_E1 to CPI_E2 then change the setups in BIOS once I had access to it.

I don't know if your BIOS will display the same but basically with my MEG, PCI_E settings are by channels called GEN 1, 2, 3, 4, and Default.

If the BIOS jumped from one setting that worked to another one changing to PCI_E 2 slot might help to recover the settings for PCI_E 1 in BIOS.

I'm not saying it is the problem you are facing but the symptoms are the same so there is a chance it might work.

Normally, when your GPU doesn't give you any signal, your motherboard should emit a fault code, it's weird it doesn't and it could be BIOS related, also, if you have reset the CMOS, everything is back to default.

If this is what causes the GPU not to output any signal, there is little chance that you can recover it without changing PCI_E 1 and change its settings.

Journeyman III

In BIOS change CMOS to UEFI. This help me.