cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

BraveKiwi
Adept III

7800 XT crashing with dual monitor setups (DP+HDMI = Green screen and system reboot)

Hey everyone,

I'm having a strange issue where the card will completely crash my system when i have two displays plugged in. My card is a Gigabyte 7800 XT GAMING OC 16GB. My main display is a 1080p 144hz monitor plugged through DisplayPort, and my secondary display is a 1080p 60hz monitor plugged through an HDMI connector. The crash happens when running games, at random times, and does not appear while stress testing; the main screen goes black, the secondary HDMI screen goes green for a few seconds, and the whole system reboots.

After speaking to several users online, i'm not the only one with this specific problem, as several users with this same monitor setup have the exact same issue. I am positive that the problem is the GPU, as i'm using a system that was completely stable for months otherwise before installing this GPU, and the problem disappears when i replace the 7800 XT with a GTX 1070.

Fixes i have tried:

  1. Changing my power supply to rule out power issues
  2. Disabling XMP
  3. Doing a clean driver reinstall several times, using DDU in safe mode and replacing the driver by both the 23.9.1 versions and the 23.9.3 versions, in full, minimal, or driver only installs (the crash persists in all of these scenarios)
  4. Disabling MPO
  5. Doing a complete clean reinstall of Windows
  6. Plugging the secondary monitor through an HDMI-DP adaptor
  7. Updating my motherboard BIOS to the latest version
  8. Plugging both monitors into the card in different ports (i tried all possible combinations)

None of these measures helped stop the crashes. The only thing that has actually worked to stop the crashes is using only my main DisplayPort monitor, that is to say, unplugging the HDMI monitor.

I'm looking to see if there are any other users here who are experiencing this issue, see if there is anything else i haven't thought of trying, and to maybe find out if this is a known issue that can be fixed by a driver update, or if i should return the card.

203 Replies

Shout out from NZ! I assume you're in NZ based on your name lol

I have exact same issue with same monitor set up. Just wondering if you had any crashes since using 2xDP cables? And is one of the cable HDMI/DP? My secondary monitor only has a HDMI connector so my only option is using a HDMI/DP cable.

Not in NZ sadly, just an imposter (thanks for the shoutout anyway!)

 

No crashes since using two DP monitors, and i’m using DP-DP cables, using an adapter didn’t work for me, but i didn’t try HDMI-DP cables.

You're seeing the exact issue I am. I'm trying two display port monitors as of today. Will be updating in this thread with my findings in a week or so. Best of luck!

zellith
Adept II

I have a similar issue.  But I havent tried the HDMI thing.  Im using 3 monitors on my wifes machine.  2 display port and 1 tablet with hdmi.  Just unplugged it to see how I get on.  The pc we have just reboots completely.  Nothing in logs except that error 41.

Update:  So one monitor has AMD freesync premium, and the other one says variable refresh rate or some such.  Turned them both off in the monitors individual settings.  In addition, my wifes drawing tablet which connects through the HDMI has been powered down (but is still plugged in).  So far after over an hour of playing, her computer hasnt rebooted.  (Which while not a long sample time is still a lot better than what we normally do)

 

I dont know if it was the disabling of AMD freesync on one monitor, variable refresh rate on the other, or if it was the cecastion of HDMI use which has resolved the issue, but the combination so far seems to be working.  Comaring to other peoples experiences, it seems like the HDMI being used is the issue.

Im clicking the reply button now.  Let's see whether Im gonna hear my wife tell me its rebooted the moment I do so.  Sods law and all that.  

So still no crash after disabling Freesync directly in the monitor ?

HairyFace
Journeyman III

Hi, I've just installed my Sapphire 7800xt pulse (non overclocked version).  HDMI to TV and also DP-HDMI cable (no adapters) to a monitor on standby.

Micro stutters with audio and video when watching movies (Netflix or media player) and opening a new chrome tab for uni or emails etc.  Even when only watching the movie and during gaming but much less often. 

Tried to replace HDMI cable, no fix.  Changed DP-HDMI cable to HDMI only, no fix. Used female HDMI dongle with no cable inserted, for quick diaconnect/connect in future; no fix.

Best fix so far is complete disconnection of 2nd cable from gfx card. Still occasionally stutter audio with a little video lag when moving tabs from Netflix to gmail/uni/empty tab. 

There was no issue when using the monitor (DP-HDMI) only but tv was still on.  Issue is still happening as I type this with hdmi to tv only and with a new hdmi cable.

Newest version of adrenaline installed and all sound drivers checked and uodated as necessary. 

 

Mine was already at default and it happened anyways

Isendyl
Adept II

I bought a HDMI/DP cable and not an adaptor for my HDMI screen 3 days ago, it hasn't crashed since, can't say if it's fixed or i'm just lucky

is it still working for you?

Still no crash since

Ok so i was lucky i guess, i just crashed

I also bought a DP>HDMI adapter and we havent had any issues since we stopped using the HDMI port.  (The adapter we bought was a Deltaco one that supports 4K (3840x21560) @60Htz.  So maybe find something similar?

Someone else here did the same and it didn't work for him, that's why i went with a HDMI/DP cable. Guess we'll have to wait and see if it's the GPU or the driver 

Be mindful that @zellith is using his DP port to convert to an HDMI display, not using the HDMI port (Which seems to be the problem)

It was fine until yesterday (or the day before).  We have had 1 reboot so far even without using the HDMI port.

(To be clear for those who see this, Im using a DP, DP and DP to HDMI adapter.  So 3 monitors.  Games stopped crashing after I started using the DP to HDMI adapter, but a day or so ago it rebooted the computer during internet browsing.  No game was running.)

averagejoe
Adept I

Has anyone found a solution my pc keeps crashing even with just one monitor at 144hz using a display port I've tried disabling freesync it still happens i tried lowering the color depth to 8bpc and nothing seems to be working its random when it crashes as well

also im running at 1080p

It sounds like you might be running into another issue - Different from the one described in this thread. Do you get any notable error codes in Event Viewer?

Try this.  uninstall windows kb5031354.  it is known to cause crashing in games.

It already was happening on 22621.2283 for me, so 22621.2428 probably isn't it?

have you manually set your clock speeds

2565Mhz for the max frequency on GPU 

I don't mess with default GPU clock speeds. That's usually the sane thing for stability. In my screenshot above, GPU Core maxed at 2581.0 MHz which is above "Boost Frequency: Up to 2430 MHz" from https://www.amd.com/en/products/graphics/amd-radeon-rx-7800-xt . Not sure if that is the cause, a symptom, or completely unrelated to this instability.

Set your clocks manually in the tuning section. A lot of people have also resolved the issues as the card overboosts and the drivers give a higher boost and then not enough voltage is applied which can also cause it to crash

At least for my particular case, changing clocks and power delivery did nothing to fix the issue - It was only fixed by using two DP monitors instead of HDMI, very strange.

Running a single monitor with display port also.

Black screen crash with forced restart still happening, totally at random times. 

Odargson
Journeyman III

I got my 7800xt today, and was having the black screen with hdmi+dp, so i tried using hdmi+hdmi and its working. No problems so far. Also, when i was with DP, i reduced de HZ to 60 and then the DP monitor worked.
P.S. Mine is a Saphire 7800xt Pulse

averagejoe
Adept I

Still having the issue where one screen is black and one is green even when using 1 Display port cable and 1 hdmi>display port cable I've set the max gpu freq to 2500 every time it crashes it resets the manual tuning i do as well

AntoinePL
Adept II

Very same problem here. I described everything in another post here.

I will try to use 2 DP instead of 1 DP and 1 HDMI. But this is not a satisfying solution at all : a 500€+ gpu should work without crashing the whole computer, no matter which video outputs are chosen.

Here is a copy paste so you have all the info :

---

Hardware & drivers :

Mobo : ASRock B650M Pro RS Wifi 1.30.AS02[Beta]

CPU : Ryzen 5 7600

GPU : Sapphire 7800XT Pulse - Adrenalin v.23.10.2

PSU : Seasonic Focus GX 750W

Monitor 1 : 60hz HDMI 1080p

Monitor 2 : 165hz DP 1080p

 

Description (Black and green screen crash) :

New computer (1 month).

Crash happened 5 times so far.

Only on some games (or maybe this was luck and happens on any game).

  • Games without crash : Starfield (70h without a crash), Against the storm.
  • Games with random crashes : Cyberpunk (4 crashes), Foundation (1 crash).

 

Description (White flickering) :

While playing Starfield, regular occurence a white flicker (only on right half of the monitor). Lasts a few ms and occur ~2/3 times per hour.

averagejoe
Adept I

Ok i think i might of found the issue for some reason the amd software was overclocking/boosting the gpu freq to 2600 every time i ran funmark it would insta crash so i've set it to 2400 and ran fun mark for 5 mins and there was no crash ill update if there are any more crashes 

I've read this in a German Forum as well. This seems to be (hopefully finally) the issue, especially for factory OC Cards.

This card seems to be really spikey.

ASRock RX 7800XT Challenger OC here

I've read this in a German Forum as well. This seems to be (hopefully finally) the issue, especially for factory OC Cards.

This card seems to be really spikey.

ASRock RX 7800XT Challenger OC here

yeah thats the card i have as well it looks like the the software resets every time I restart my computer so i have to manually tune it every time i restart I've submitted a bug report for it 

The resetting every time is due to a  Windows update. Disable fast start up in the control panel power settings and uninstall any W11 updates since October.

Posture9298
Adept II

I encourage everyone to report this via the AMD Bug Report Tool when it occurs. Attach any event logs, photos or crash dumps you can. Mention your monitor setup too if you feel it's a contributing factor.

Major_263
Adept I

I really hope this is some kind of Driver issue specific to the RX7800XT and not hardware related.

 

I think there is something with the amd software  overclocking/boosting the gpu freq to 2600. I can set my tuning to balanced and default and the GPU gets to 2400 and everything is fine. I've done this for 2 days now and it's been fine gaming for an hour. Will report back after this weekend.

On a single monitor setup via DP 7800 xt gigabyte 

Please do 

0 Likes
Posture9298
Adept II

I'd like to confirm that I'm still experiencing double black screen and then system restart crashes using the latest drivers (23.11.1).

I've contacted Sapphire who palmed it off to AMD saying it sounds like a driver issue. Well - This is the fourth crash I've reported to AMD.

I've also contacted the seller of the card to see if I can return it and get store credit because I'm at the end of my teather.

0 Likes

I hoped the new driver would fix it, but yeah it seems they're not aware or have not found the issue yet

0 Likes