Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept II

7800 XT Black Screen/Reboot & Cache Hierarchy Error (Event Viewer)

This seems common from searches on Google, has AMD acknowledged anything regarding this annoying issue yet ?

On my system this is very random, it happens 2-3 times a day when gaming or when quitting a game and even while just watching youtube videos. Sometimes I can play for hours and others it will crash back to back. GPU/Hot Spot is never over 75-80c as I set up an aggressive fan curve. There's never any artifacts, just a blank screen, sound still plays for a couple of seconds, then fan revs up and computer reboots. Event viewer shows a cache hierarchy error on a random core, no mini or memory dump. Most easily reproduced while playing Shadow of the Tomb Raider.

Another issue I have with the card is when resuming from monitor standby, the screen flashes white until I reboot. Both issues disappear when I reinstall my older 6750 XT.

Support has not been very helpful : reinstall windows, reinstall GPU drivers, use AMD drivers remover, update BIOS, turn off XMP, tried every driver revision since the card has been out, nothing really helps. Their last reply was to wait for a driver that fixes it. I have also used the bug reporting tool a few times now.

Has anyone have had any luck with finding a solution or has heard about if AMD is working on a fix ?

Windows 10 22h2
AMD 7800 XT Reference Card
Gigabyte Aorus B550 Pro AC F16g bios (default settings)
Corsair RM1000x PSU; tried swapping cables & also with my older EVGA 850W G2)
5800X @ defaults
2x16gb GSkill F4-3600C16-16GTZNC

1 Solution

New Adrenalin 23.12.1 drivers seems to have fixed the issue for me - only one crash so far in 3 weeks and it was not a cache hierarchy error (nothing was in the event viewer)

View solution in original post

14 Replies
Adept II

Do you ever see an error like this under Event Viewer -> System and filter for Display:

"Display driver amduw23g stopped responding and has successfully recovered."

For me the display never recovers and stays black which forces me to do a hard restart using the power button.


Couldn't find this error in there, pretty much the only error I see after rebooting is:

A fatal hardware error has occurred.

Reported by component: Processor Core
Error Source: Machine Check Exception
Error Type: Cache Hierarchy Error
Processor APIC ID: 11 (this changes all the time)

Adept II

Okay so have the exact same issue, pretty sure it's root is an interaction with the GPU / CPU. Try and go into you bios and disable both CPB and PBO for your CPU. That fully resolved my issues, but of course you lose alot of performance from that as well. I have a 5800x3d coming later this week to see if it's part specific. 


Will try that, thanks! lmk if the new cpu helped


Got CPU today, will try and update in a few days. Just reaching out to now confirm the CPB thing didn't actually work as a fix. For me this issue comes and goes so it's very hard to pin down. 


Ok! Thanks for following up, I am currently testing with a DP > HDMI 4K adapter as apparently it could be an issue when using the hdmi port on the card. lmk if the cpu helped

EDIT: Well that didn't work, it crashed while playing SOTTR on a green screen on the DP > HDMI adapter connected TV. Cache hierarchy error again in Event Viewer.


Just following up, new CPU? Didn't resolve the issue. Also tossed in a 1200w PSU too boot...  


I'm not surprised at all, this is most probably a hardware/driver issue. You'd think they would have fixed most of the issues with the 7xxxx series by now.

Pretty sure these are just widespread hardware issues with the 7800xt line. Software can really be controlled for as a variable so if it was that I think someone could have found a solution by now. 




or AMD is just very slow, It took upward of 6 months to fix a crash on a title they previously sponsored (Tomb Raider) on my old 6570 XT, it also had bsods for just watching a movie when hardware acceleration was enabled + hdmi audio was always cutting in and out.

I admit that my next system will probably not be AMD at all, will be returning to overpriced nvidia gpus and Intel cpus. AMD doesn't seem able to handle their hardware correctly and/or are driving them too close to their limit.

Currently I'm having luck by setting the max frequency limit to 2430Mhz / 95%, which incidentally is the maximum boost clock specified for the card. I'm not sure why it's set to 2525 by default as it's clearly over their own specification.


Just tested some more, interestingly, even when setting the max shader clock to 2430Mhz, it did overshoot by quite a bit while benchmarking in SOTTR  (up to 2490Mhz!).

This just goes to show how terrible and unstable their drivers are.





New Adrenalin 23.12.1 drivers seems to have fixed the issue for me - only one crash so far in 3 weeks and it was not a cache hierarchy error (nothing was in the event viewer)

Adept I