Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

6900XT random black screen, amdwddmg error

Hi folks!

Last few months I am experiencing random crashes which leads to black screen for like 30s and then a driver message pops up that settings were reset to default. Sometimes the black screen does not get resolved and I need to hard reset my PC. I am using two monitors - one with display port and one with HDMI. The main monitor that I have with DP is the one that gets the black screen and the other one is just frozen for the time being.

The crash can be caused by different things - playing LoL, scrolling in facebook with videos in the feed or even watching movie/youtube. The crashes are not frequent and they can't be reproduced easily, thus making it hard to track and resolve.

I've did some digging in windows event viewer I get the following message when I get this crash: "Display driver amdwddmg stopped responding and has successfully recovered." with eventID: 4101.

I have the latest chipset drivers and GPU drivers. I've been experiencing this issue from the last 3 versions of AMD stable drivers. The GPU I am using is Powercolor RedDevil 6900xt.

I've read some reddit and AMD forum posts with suggestions, but nothing so far have helped me. I've tried with DDU and clean install of drivers, disabling "Crash Defender service", disabling AMD super resolution and etc.

20 Replies
Adept II

Just wondering. before you uninstall the driver and reinstall. Is the machine disconnected from the internet. Had all kinds of problems with my Gigabyte rx6900xt with crashes. What I ended up doing is the ddc thing, but removed the machine from the internet. Installed the drivers then turned the internet back on. Found that windows was tiring to install driver and it was creating a conflict. once back on line. use amd to update to the most recent. I'm running 22.5.2 and so far so good. Only thing is some have reported that when the monitor goes to sleep. Things go sour and you my have to do a hard restart. There's a fix with you have to make a change in the registry. Hope this helps some and good luck.


Hi @Benago1 ! I've just tried your solution and now I am waiting to see if I get the issue once again. I've followed the steps:

1. Disconnected from the internet and prepared my drivers

2. DDU the current drivers

3. Clean install

4. Connect to internet again.

Could you please give me more info about the monitor that goes to sleep problem and the registry solution? Thanks in advance!


I have it somewhere have to find it. There's a couple of things to do. Mostly for now. don't let the monitor go to sleep on its own. Just leave it running until you shut down you machine. It does not happen with all computers. Run yours for now and see if it gives you any problems.

I just got the black screen crash today again even after I tried the solution with reinstalling the drivers while being offline(off the internet). Same error message in event logger and eventid.


I've had issues with WU trying to override my adrenaline software so I had to disable windows driver updates.

Once you do that then uninstall all amd gpu drivers with the amd uninstaller in safe mode then reinstall your adrenaline software.

Adept III

Use 22.4.2 Driver. 

@oark I was running stable with 22.4.2 for like 4-5 days until I got black screen again, same error in the event logger.


I had exactly same error as yours.

 was using Windows 11 Beta, problem started when I first installed 22.5.1.

Downgrading to 22.4.2 reduced the problem but window was not stable as before so after clean windows format problem went away (zero black screen). 

I really recommend keep using 22.4.2 since it is most stable till next new driver. 






@oark So you say I need to go for new windows installation? 


It is fixed after clean installation but I am still using 22.4.2. 

But wait for new driver will be released soon then give it one more chance before formating. 



Seeing as someone mentioned Win.11 beta, the drivers direct from amd download are for RTM builds (using insider dev/preview OS can be hit or miss for functionality).

MS suggests only using the supplied OS driver on insider builds.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

By the way, after new installation of windows 11. 

I have tried with 22.5.2 but I had one bad issue, every time I watch video in second screen while playing games in main screen, once I maximize the video (full screen) in youtube. Any game I play start stutters with fps lag. Downgrading to 22.4.2 fixed the issue.

Go read the forum alot of people have problems with latest driver, it got nothing to do with windows 11 Beta. 


Had my 6900 since Jan.2021, had maybe 1-2 driver issues, have had more issues with Win. updates (not unusual for SFC/DISM to have found/repaired system files after preview/monthly updates).


Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..
Adept II

Amd could be automatically overclocking your gpu.

Check this video to see if it helps:

But set your GPU clocks according to the 6900XT instead of the rx580.


Adept I

Workdaroud is


-> edge://flags/#disable-accelerated-video-decode
-> Disabled

-> chrome://flags/#disable-accelerated-video-decode
-> Disabled

-> about:config
-> Click 'Accept the Risk and Continue' to go to the about:config page
-> Search for 'hardware' by preferences name
-> 'media.hardware-video-decoding.enabled'
-> false
-> 'media.hardware-video-decoding.force-enabled'
-> false

Have you tried it?
Probably a bug caused by timing issues in AMD drivers.

I started getting it again and disabled the accelerated video decoder. Did it fix the problem for you?


disabling hardware acceleration didn't fix it for me

Adept II

I'm having the exact same problem with my RX 6750 XT, only using 1 monitor.

Tried different drivers (stable and optional), DP and HDMI 2.1, Made sure XMP and Enhanced Sync are disable


What OS are you using and have you tried with different drivers?

Also try turning off SAM. 


Windows 11, tried different drivers

Forgot to mention it happens with SAM off aswell