Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

5700XT Anniversary Edition - Screen resolution BUG - too small

Brand new computer - New PCIE 4.0 NVME m.2 ssd, and brand new Windows 10 install.  New AMD 3900x CPU, New Asus X570 TUF mobo, New G.Skill 3200 CL14 B-die ram, and new 5700 XT anniversary edition video card.  Been using it for the last week, and after a super rocky install (multiple BSOD crashes due to ANOTHER driver bug), which I had to take a hack off a guy on reddit and disable LAN drivers to get it to image... I've finally been enjoying a couple days of my AMD computer without any problems.  UNTIL today.... when I updated to the graphics driver 19.7.2, it broke my entire screen resolution!  I have a 34 inch 2560x1080p ultrawide LG monitor, and after updating my graphics drivers, I'm stuck on a maximum 1280x1024 resolution.  I have tried uninstalling and reinstalling the driver, and I have tried uninstalling and installing the older driver (19.7.1) that used to be working, however it does not work.  I have tried DDUing and starting completely fresh with both versions of the driver, however it also does not work.  I have tried unplugging my video card, re-plugging it in to make sure it is seated correctly, I have tried multiple display ports on the back of the video card, and multiple DP cables.   STILL BROKEN!!!!  Whatever you guys changed in the last day has completely broken my video card!

If I uninstall AMD radeon software completely, my resolution goes back to normal 2560x1080p.  However as soon as I install any version of the AMD driver (the 19.7.1 or the 19.7.2), my resolution breaks again.

I haven't owned an AMD computer or component for 10 years, been strictly Intel/Nvidia only.  Until last week....  You want to know why??? Because the last AMD computer I owned, gave me constant problems and headaches, just like this one.  It had constant driver problems, and your catalyst control center software sucked, getting updates were horrible, and support was clueless.

You are SERIOUSLY making me regret ever giving you guys another chance.  Just looking at these forums and reddit, my mind is actually blown that you guys have not improved your QA and are still releasing this buggy crap. 


13 Replies

Hello, listen funny, I also have lg 2560x1080 and I also have problems with the resolution on the Rx5700 video card, I have strange artifacts on this resolution, while others are ok. By the way, and what are you complaining about, you bought a product that just recently came out, similar problems are absolutely normal + amd these video cards are also in the new architecture. I remember with what problems Rtx started, so you shouldn’t blame everyone that you have a problem if you made the choice and buy a product that just came out.

Adept I

good day, I have the same problem after restarting the resolution of the two screens becomes 640x480, I added the resolution of their monitors with this program, custom resolution utility, it's a common problem here, at first I thought the problem with the graphics card (sapphire 5700xt) but after reading the forum here I realized that this is a problem in the drivers

Journeyman III


i have the exact same problem. New System with fresh Windows 10 Pro

14.03.2020 System built

14.03.2020 - 16.03.2020 playing games just fine

17.03.2020 - Windows updates some AMD drivers --- Resolution capped at 1280x1024 cant change it to anything higher only lower.

Windows standard display adapter works fine and gives me 1920x1080.

I tried:

1. uninstalling via device manager and reinstalling AMD drivers - does not work, resolution still capped.

2. using ddu / amd driver remover and reinstalling AMD driver - does not work

Need help. We'll soon be stuck at home because of human malware and i want a functioning gaming rig. 

@tarnix were you able to resolve the issue? 

Journeyman III

Same exact problem.

Display: LG 34UC79G-B curved ultrawide

Video: AMD RX 5700 XT

New system, fresh windows 10 pro install, worked fine from september to late january. Had some updates, windows and amd video driver, a few days later resolution capped at 1280x1024.

Reinstalled Windows 10 pro N, a few days later, resolution capped again.

Reinstalled Windows again (pro 1909), turned off all updates, a few days later, I am capped again.


Switched from Display Port to HDMI cable and now it works. Using Adrenalin 2020 Edition 20.3.1, but I suspect that isn't relevant.


just to help others in the future:

The problem happend when I let the monitor wake up/turn on by itself. I now switch on the monitor by pressing the power button and after that then start the PC. That fixed the problem. 

Very strange bug, as it was working fine before. I hope it helps some of you.

Journeyman III

Same problem here. Sometimes my resolution 2560x1080 is missing and only have 1280x1024. In many cases it fixes rebooting my pc, but other cases doesn't.

5700 xt Nitro

LG 34uc79g

Windows 10

Latest drivers AMD adrenalyn

I've tried 1000 things, uninstall drivers, reinstall drivers, uninstall device, etc

Please we need a solution. What can we do??? I can't work this way.

Journeyman III

I'm having the same issue, to get the resolution back to normal I have to unplug the DP cable or power off and power back on the monitor.

So far what I noticed is most of us have an LG ultrawide freesync monitor. 

Here is my hardware summary:

Monitor: LG 34UC79G-B 34 Inch 21:9
GPU: RX 5700 XT 50th Anniversary Edition w/ waterblock

Motherboard: X570 Aorus Master w/ waterblock
Memory: G.Skill Trident Z Neo 32GB DDR4 3600 @3733Mhz 16-16-16-32-48 1T @1.36v 
Processor: Ryzen 9 3950X w/ waterblock
Sound Card: EVGA Nu Audio
PSU:  Corsair AX850 Titanium

Journeyman III

Hello Everyone, 

My GPU is slightly different (MSI Gaming Radeon Rx 5700 Xt) however near the end of a driver update the resolution would revert to 1600x900 and could not be changed.

The issue could very well be the LG freesync monitor in my opinion or a cabling issue. Why? After endless clean installs, re-seating GPU and attempting 10+ workarounds I plugged in a HDMI cable and it worked (like memphis). I was able to adjust the resolution to 3840x2160 instead of using the DisplayPort. The downfall is the HDMI does not allow freesync to work. 

Software vs hardware issue? Beyond my pay grade. 

My specs:

Operating System: Windows 10 Pro 64-bit
CPU: AMD Ryzen 5 3600X 6-Core Processor w/ EVGA CLC All-In-One RGB LED Liquid Cooler

RAM: G.SKILL Ripjaws V Series 288-Pin DDR4 SDRAM 32GB
Motherboard: MSI MPG X570 GAMING EDGE WIFI (MS-7C37)
Graphics: 8176MB ATI AMD Radeon Gaming RX 5700 XT (MSI)
Monitor: LG 27UD68-W 27-Inch 4K UHD IPS Monitor with FreeSync

PSU: RM1000x 1000 Watts 80 Plus Gold Modular ATX Power

Hopefully a fix will be here soon. 

Journeyman III

I solved the problem on my PC, got into the UEFI and changed two settings:

1- PCI-E Bus Gen from 4 to Auto.
2- CSM Support Enabled.

One of those two did the trick for me.


I'm having this same issue and I haven't been able to find any solution yet, I'm really disappointed. I can't afford a new card so my pc is basically useless stuck at 640x480 all the time. Reinstalling Windows was the only thing that seemed to work, but that was one day only of use, then back to this


I wish I knew the answer to that one. I would talk to AMD support

Hopefully it is a simple fix you can share back with the community.

Good Luck!


You though if if is just a simple corruption in the driver install do this to see if it helps.

I would suggest trying to install the drivers from scratch again as sometimes things just corrupt.

Have the driver downloaded from AMD

Download and run DDU from wagnardsoft dot com from safe mode with Internet unplugged or wifi off. 

Restart with Internet still disconnected.

Install the AMD driver but don't pick express install. Choose the"Factory Reset" option.

See if that helps.


I would suggest not using a driver newer than Adrenalin 2020 Edition 20.9.1 and don't use a really old driver.