Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

5700 XT HDMI not working


I received my new GC yesterday (the Strix 5700XT), but I have a big problem with it. The HDMI port doesn't seem to be working so I can't plus my second screen. The Display Ports work so no problem for my main screen.

I tried several screens, several cables, adapters, but nothing works with the HDMI.

I did a clean driver install with DDU twice, and nothing.

Everything works perfectly with my old graphics card (R9 280X).

Am I missing something here? I found a few posts about the same problem between here and AMD community page, but nothing gives me a solution, anything can help.

Here is my config :

MB: Strix B350 F

CPU : Ryzen 5 2600X

RAM : Corsair 16gb 3000mhz

PSU : Corsair VS650

20 Replies
Journeyman III

I have the same problem. It works fine with DP to my monitor, but HDMI output has 'no display'. It detects the second display in windows and I can choose resolution etc, but NO DISPLAY on my Samsung 4K TV, can't seem to get it working whatever I try. I used the same HDMI 2.0 cable successfully to the same TV on my old GTX 1060 video card.


Mine now works. Hdmi cable was broken. Oops.

I have this. HDMI wont wake with a RX 5600 XT. In my case it is a cintiq screen on it. To wake the f.. thing I need to take out and plug again the connect AT THE BOARD with the Windows running, only THEN the drive wakes up the HDMI. Drivers all update.

Cintiq has a dedicated cable, I cannot change it

Journeyman III

Having issues with HDMI as well with my Sapphire 5700 XT Pulse.

Using a 1080p Hitachi TV, model L22VG07U.  I see the BIOS screen on first boot, but if I restart without first turning the monitor and PC off I get no signal during reboot until the Window 10 logon screen shows up.

Windows will only allow me a resolution of 640x480 on the desktop.  I had to use a utility called CRU(Custom Resolution Utility) to finally get a 1080p desktop.  My previous Sapphire 480 Nitro worked fine, but I have a feeling there is a bug in BIOS with regards to connecting to monitors on the 5700 series of cards.

I tried it out on a very on old HDMI only monitor and it works, but the 5700 cards don't seem to play well with monitors/TVs with a variety of connections options.

I have tried various HDMI cables

Journeyman III

It's not an isolated problem then. Why don't I see any info from AMD ?

Adept I

I just got a Red Dragon 5700 XT, and my HDMI port doesn't work properly either. It "works" but the graphics is totally messed up and full of artifacts, vertical stripes and everything is a red hue. With display port it looks fine. Problem is I have several old displays that don't have any display port.

Seems like the HDMI port is just there for show. More or less.

Journeyman III

I have a similar issue with my Gigabyte 5700XT and ASUS VX24AH monitor, and a Gigabyte X570 motherboard. I have also tried a Benq monitor and it has the same problem. Mine is out of range until the windows log on screen appears. I can't see my BIOS screen or my bitlocker password entry screen. I have to enter my password blindly to be able to load windows. I have contacted Gigabyte support and after 2 weeks when they finally replied their reply was useless "send it back to your supplier for further analysis". It seems that the graphics card can't drive a monitor through the HDMI cable until windows loads. I have plugged in my son's AOC monitor that has a display port connection and it works fine. I can see my BIOS and bitlocker screens as normal with that. Unfortunately my ASUS monitor doesn't have display port, only HDMI. . My old graphics card works fine through HDMI. It's a problem with the 5700 series graphics cards. Gigabyte doesn't want to know about it. How about other manufacturers?


UPDATE: I had several responses from Gigabyte and they were never able to offer a solution and eventually told me to return the card under warranty. I got a full refund from my retailer and bought a 2070 super. I can only assume the HDMI issues are  known problem with no solution at this time. 


Do you think that it is hardware faulty port or known flaw with HDMI of 5700xt so that they turned off a port in drivers?

Maybe they will fix it with new drivers, is there any chance to check if there is electricity in the hdmi port? Via some sofware on pc ? I really don t use it but I do not want to pay for GPU and get ports that are not working at all..

Adept I

I have 3 HDMI only monitors connected to a PowerColor 5700XT. Two are running DP->HDMI adapters and appear to be working fine. The one monitor running the native HDMI connection is stuck at 640x480. Windows will not allow me to select any other resolution for it.

Unfortunately, the DP->HDMI adapters are $35 each. 

Update: I ended up buying a 3rd DP->HDMI adapter and running that for a few weeks.Performance was not great, but that may be due to the age of my system. So I built a new system and moved the 5700XT to it.

Instant problems on a fresh install of W10 with Feb Radeon software. No monitors would go above 640x480, regardless of using the adapter or straight from the HDMI port. Hell, uninstalling the Radeon software & drivers gave me slightly better resolution with the default Windows drivers.

After a lot of troubleshooting, I tried the 5700XT on a different monitor and it worked first time. DP->HDMI or straight HDMI, it worked fine. Other computers (Fitlet, Raspberry Pi, NanoPC T4, etc.) had varying degrees of success with the original monitors. I tested the Fitlet and Raspi4 on the spare monitor and they all worked, so I concluded that the monitors were marginal. 

3 monitors later (ouch) I now have working screens using DP at whatever resolution I need. Hope this helps.


Hello guys, also experiencing HDMI not working on XFX Reference 5700XT. I tried several hdmi cables, both 1.4 and 2.0 4k@60, on 3 different monitors(AOC), no signal from HDMI. Tried GPU in x8 PCI-e port, does not work either.

All 3 DP works fine, after I installed drivers(without drivers only 1 DP works), so I guess it is maybe driver bug, more than a faulty HDMI port?

Any adivces? 


Journeyman III


I am experiencing the same exact problem with my red devil 5700xt. All the DP ports works, even DP to HDMI converters work. From the HDMI port I either get no signal or the red hue that someone described above, but that only shows during the bios screen on startup and switches to a no display when windows starts. This has to be a bios issue.... DP to HDMI converters are not a great solution as you miss out on certain refresh rates and HDR. Amd please acknowledge this it's been an issue for awhile.

I do not even get red hue, only NO SIGNAL from monitor.. Really frustrating..

Journeyman III

(awkwardly walks into the circle of frustrated customers) Hey guys i just built my new rig and have Asus strix 5700xt hdmi worked as i set everything up and after a month i upgraded to a 4k monitor and decided to try the display port (didnt trust the internet and had to compare quality to hdmi) after doing this i can no longer use the HDMI it will not detect or handshake. I work for comcast so the first thing i did was grab my box of 100 HDMI cords and make sure it was not a faulty cable. long story short ive done everything i can think of at this point i know its a setting or software issue because my monitor kicks on right away it just does not detect the video so says no signal. any additional ideas would be appreciated i have done everything listed below plus probably forgot some stuff

replaced HDMI

ensured GPU was seated correct and all pins are secure and clean

updated windows and drivers 

uninstalled drivers removed and re installed gpu and drivers 

tried low res mode in windows as well as troubleshooting graphics and audio 

ive tried multiple displays 

at this point the only thing i have yet to do is a wipe and re install of windows but that is last resort good luck and thanks for any help

Journeyman III

Hi! Just wanted to join in, and confirm that I have exactly this same issue with RX 550 and RX 580 cards also. No HDMI signal whatsoever when connecting to 4K capable monitor or TV. Older Full HD monitors and TVs work. Also QHD/WQHD (1440p) monitors work. As if the EDID from monitor is higher than HDMI 1.4 spec, the Radeon GPU 'freezes'.

Only exception being, if I use a working setup for main display (DP/DVI/Full HD HDMI), connect the 4K after booting to desktop, and then change the 4K to 640*480 or 800*600. This is the only way I've managed to get any kind of stable picture to a 4K tv/monitor from Radeon RX card HDMI output. Also, I've had some success on getting some picture on the 4K screen, when choosing 2048*1080 resolution with 23p (23.976). Although with these parameters the display drops and reconnects every few seconds. Pixel formats or drivers seem to make no difference. With the AMD Radeon drivers I also get nice BSODs and 0x0000.... null memory read crashes from AMDRSServ.exe every now and then.

Out of frustration and against the quarantine, went out and bought the cheapest 4K capable Nvidia card I could find (1030) for testing, and everything works out-of-the-box, with the same cabling and monitors/TVs. So this has something to do with the AMD Radeon cards, and nothing else.

This hardly seems to be a driver / "userland" issue, as this has happened (is happening) with 3 different cards from 2 different brands, with different TVs/monitors, only thing common being the "AMD Radeon" part. For example, you can't even get Windows (or Linux) operating system installer to show up. The screen drops as soon as the installer loads up its generic display driver and tries to show any resolution higher than 800*600 on the HDMI output. That is, if you have AMD Radeon > HDMI 2.0 > display setup. So rshelton1002, fresh reinstall wont probably do any good.

Now that I think, this has probably been an issue since day one with my RX 580, and hasn't been fixed during these few years. As someone already stated, the HDMI 2.0(a/b) implementation has to be a complete mess with these cards, and probably isn't even solvable via firmware/VBIOS update, as they would have done it by now. So 4K and/or HDR colors are only available through DP connection on these cards, and HDMI just is restricted to devices below HDMI 2.0 specification.

Journeyman III

Hey Everyone!

Perhaps i come with great news for y'all. I had the same problem with my HDMI port on my RX 5700 XT Strix 8GB card as all of you soo with some help from "ninjachop" in this thread.

If you check the manual for the 5700 and 5700 XT cards (link below), you read under the "Display Configurations" you'll read that if you want to connect a display trought HDMI port you will need HDMI adapter. Im using a DP monitor as a main and a DVI as a second monitor so i use DVI to HDMI port Adapters to connect my secondary screen to the gpu.

Thanks for all the help i got from you all and i hope you all get the problem solved. 

Yeah, thanks for the link, now it makes it even more confusing. Why to have HDMI port on gpu when you cant use it at all? :/

Journeyman III

I have an rx5500xt it also has the same problem where sometimes shows the windows logo and suddenly stops, with display port it works fine

Journeyman III

Hi, just wiggle it around it the port and put it in and out, that works for me, I usually just take it out and put it back in. I think Im going to buy me a newer card because this is annoing:(