Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

5700 reference cards fan RPM stuck at 100%

So I have 2 reference cards 5700s that were given to me by a friend since he did not need them anymore and upgraded his systems. I put them into my system and noticed that both of their fan speeds are stuck at 100% all the time. I have tried adjusting the fan curve and fan speed through Radeon software, along with using Afterburner and it does not change as they both stay at 4666 rpm. I have flashed their bios to the most recent bios according to techpowerup here but even with the new bios, it doesn't seem to change anything. I tried contacting support and since I am not the original owner and don't have proof of purchase they refuse to help. So figured I'd come to the forums to see if anyone else had had an issue similar and fixed it or am I pretty much stuck with two paperweights now. I would love to use these in my other systems and replace my current cards, but they sound like jet engines when they run. 

1 Reply

It may be the connector from the fan to the card is loose. Make sure it is properly installed and locked in. Maybe you can ask your friend you got the cards from if he had the problem? Another option would be to get a replacement fan, although usually when fans fail they don't spin or spin very slow. This is a strange problem, I hope you can fix it.