Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

5700 low clocks in most games

Board: Asrock X370 Killer SLI/ac Bios 2.5

CPU: 1700

Ram: G Skill F4-3200C14-8GTZKW @2933Mhz board limit

PSU: EVGA Supernova 650 G3

Card: RX-57XL8LBD6 XFX RX 5700 DD Ultra 8GB 

Win10 64 1903

Driver: 19.10.2

I got this card as an upgrade from my 4Gb 480 but after starting up X4: Foundations 2.60 I noticed fps was about the same as the 480 wile sitting in my ship docked at a station, about 30-50fps. So I grabbed the latest GPU-Z and started the game again. This time I noticed about 250fps with clocks around 1850mhz near 100% load wile sitting in the main menu. Once I loaded the same save as before sitting in my ship docked at a station I now have 30-50fps with clocks bouncing around from 200-1100mhz averaging 300-500mhz and average load around 50%. 

I decided to run Heaven Benchmark and it seems to behave as expected with near max clocks and load with fps scores nearly double what my 480 did. I then ran Valley Benchmark and it does something between Heaven and X4. It runs mostly near 1300mhz but goes up and down alot making the red bar in gpu-z look like a mountain range with some deep cracks hear and there. 

Fired up Kingdom Come Deliverance 1.9.3 and its behavior is somewhere between Valley and X4. Oddly enough again like X4 I got only slightly better fps than my 480 with the same settings, that I don't remember since I clicked ultra to see what it would do if put a big load on the card. On ultra 101fps in the main menu and 35fps in Rattay standing near the stage by the shops. 

Pathfinder Kingmaker 2.0.3 is another oddball like X4 where I get full load and clocks speed sitting at the main menu but drop to 75fps ingame with low clock speeds. I don't remember the speeds and don't feel like starting it up right now to see.

Borderlands GOTY Enhanced gets me about 300fps, dips down to 100 with a gpu load and clocks at about 50%.


Mad Max max settings no AA, full load and clock speed at main menu and near full load in game but does do this dynamic on the fly clock adjustment stuff wile staying above 1250mhz and 180fps.

So I did some searching and saw several mentions of the same or similar issues since release, mostly low load/heavy downclocking in older and a few newer games at 1080p. I saw several possible reasons and fixes. All that I have tried so far have done nothing. This includes disabling Chill and ULPS in registry.  Enabling or disabling shader cache in both global and the X4 profile. Enabling or disabling enhanced sync or frame rate target control, neither of them did anything in X4 the menu would still sit at 250fps. Also changing graphics setting from high to low barely effects frame rate in the X4 main menu but does lower the clocks down to about 1000mhz and the load varies between 30-57% and same effect in game with different lower numbers. I tried setting min frequency in wattman to the same as max this didn't help but had an interesting result in the only game I tested this way, X4. At the dock it bounce around from 6-1916mhz instead of 200-1100mhz like it without wattman. This brings me to something else odd if you haven't already noticed this is a non XT card. Shouldn't max boost be capped at 1750 without flashing an XT bios? I started to think I had been sold a used card as new and someone had flashed the bios before returning it but then I realized that gpu-z and windows show it as a 5700 without the XT. I also saw people mention being cpu limited alot but in pathfinder I loaded a save in a tiny room with one core thread at 50% and rest 25% or less and still only got 75fps and the gpu at around 300mhz. I even poked around the bios looking for any pci-e settings but found none but did try reverting bios to defaults. All that did was lower fps a bit and raise the case fan speeds. Being able to save presets in bios is nice.

Only things left I can think of but not yet tried is updating the bios. Mines old but saw reports of ram maxing out at 2600 last summit ridge version for my board so never considered it again until now. Not really sure if 2xxx and 3xxx improvements effect 1xxx since I haven't looked into it yet. Last thing would be fresh install of windows but I saw several that tried or had the same/similar issues on a fresh system. Though maybe the issue is 1903, I saw mention of one game getting its fps wrecked by 1903 and fixed in 1910 but cant remember the name of it since it seemed unrelated. Have considered making a backup image of C: and installing 1809 just to see. 

After seeing this all wrote down and far more organized than in my head this seems like a software issue to me. Especially if I remember correctly that both X4 and KCD are vulkan titles and seem to be the most effected. Also this was all at 1600x900 windowed since my vision requires my face to be within 6 inches of the screen, 3 inches if I'm trying to read or write text this size. I did test X4 and KCD at 1080 fullscreen and the only difference was a few fps. That reminds I also tested on another monitor that uses display port since my main is hdmi only.

10 Replies

It's CPU bottleneck, perfectly normal. 5700 is a powerful card, 900p in an old benchmark like valley is not going to max it out at all times. Mine drops to 60% also in some scenes, it is waiting for CPU. Try running it at 1440p or 4k if you want your GPU maxed at all times.

The fact it is downclocking is a feature not a bug, it is saving power when it has nothing to do waiting for CPU. It goes to 250fps in the X4 menu because the CPU isn't having to simulate an entire universe full of trading ships, and can feed the GPU all it can eat.

You will have to hope egosoft improve the performance of their engine

Adept II

It's a known issue and many people have this issue, its listed as: Radeon RX 5700 series graphics products may experience stutter in some games at 1080p and low game settings.


I am running a 3600/5700/16GB 3200mz Ram.

My i5 4690k/290/8gb 1600mz Ram got my frames in Destiny 2 at the same settings and didn't stutter.

Drivers are a mess, it's not a feature.


I'm having similar issue with Kingdom Come Deliverance, like in rattay, the GPU sits at 65-70% of utilization with CPU utilized at 40%, so it's obvious that GPU could push more frames. 

It's very bad but happens in most games if you pay attention to it, makes the games stutter for 1 sec intervals, you can test this in Destiny 2, do a Crucible pvp map and see your GPU utilization go from 99% to 2% randomly for no reason...Just one example, happens a lot in CSGO also. 

Adept II

Same GPU usage drops, but with RX 590, it constantly downlocks itself. Happens mostly in old games. I blame drivers.

So, this isn't due to it being a dysfunctional card, or anything to do with a bottleneck? It's just garbage drivers?

Since this doesn't happen in resource heavy new games, I blame drivers. I even can't watch 4K now, because of stutter and frame drops, because my GPU mostly is not in use.

Adept II

Says it's fixed now in the latest driver, make sure to do a clean install guys, hopefully it's all good now, I guess I'll see tomorrow.

Journeyman III

Can any1 confirm if the new bios update fixed the issues people have been having with 1080p/downclocking/stuttering/etc? im interested in purchasing this card for a 1080p 144hz display but with all the issues ive been reading people having i want to make sure its been fixed before purchasing the XFX rx 5700.


It's still the same, they just say it's fixed, huge thread on Reddit under r/amd if you wanna look through that. Should be a couple threads.