Showing results for 
Search instead for 
Did you mean: 

General Discussions


Ryzen 2200G games problem - most don't open, some open with 2-3 FPS - no errors

So I bought a Ryzen 2200G for my brother, along with a Gigabyte AB350M-D3V and 8 GB RAM HyperX 2400 MHz (only 1 slot).

I installed all the drivers accordingly, updated the BIOS to the latest version which was F22 and everything works perfectly besides games.

He uses steam for gaming, so we tried Team Fortress 2. It has very low system requirements so we tried to test it and it didn't even open and the process is not present in Task Manager. After that I tried The Darkness 2, that doesn't open either, neither does CS:GO. Next stop was Assassins Creed Rogue. This one opens but it's almost unplayable, like 5 FPS the most. Next I tried Fallout 4, again, doesn't even start, no error or anything, just starts and closes immediately. No process present in Task Manager.

I have to say that I tried reinstalling the windows, updated it to the latest version, installed direct x 9 and all the C++ Microsoft packages.

Reinstalled the AMD drivers over and over again, upgraded BIOS to the latest version and don't know what to do anymore...

Any suggestions? Or maybe a clue to understanding what does not work?


forgot to mention, the video adapter used is Vega 8, just wanted to mention that so we exclude the possibility of using microsoft basic display driver or things like that

0 Replies