Showing results for 
Search instead for 
Did you mean: 

General Discussions

Journeyman III

No mass storage seen by Windows 10 Install

Hoping you can help with a very frustrating issue!

The windows 10 install process is refusing to detect the mass storage drives. Either the NVMe drive that I don't want to touch, or the SATA drive attached to the first SATA socket. Both drives can be seen in the BIOS and used in Ubuntu (18, LTS). I've tried to walk through the drivers on the supplied ASUS DVD (AMD X370 Support DVD Rev.1267.08) and what I could find on the AMD X370 drivers down load page but so far had no joy. A couple of the downloads on the AMD page are exe files, are there any drives in here that are not included in the zip files? How do I extract them to put on my USB device to use during the windows 10 install process?

PC Spec:

Motherboard: Asus AMD PRIME X370-PRO AM4 Socket Motherboard

Memory: Corsair Vengeance LPX 16GB (2x8GB) DDR4 DRAM 3200MHz C16 Memory Kit - Black

SSD1 (Ubuntu): Crucial P1 1TB 3D NAND NVMe PCIe M.2 SSD

SSD2 (Intended Win10): Samsung V-NAND SSD 860 EVO 500GB

Graphics: Sapphire RX 570 PULSE Radeon 4GB Graphics Card

CPU: AMD Ryzen 5 2600 AM4 Processor with Wraith Stealth Cooler
PSU: Corsair VS Series VS550 ATX Power Supply

Windows install media downloaded direct from:

Microsoft Corporation 

Also tried copying an install DVD direct to USB (dd tool in Ubuntu) "Windows 10 Pro Full Version" but had same results, although the graphics appeared better.

Looking forward to getting this sorted! Thanks for any help that can be offered.

1 Reply

Have you searched Windows 10 support for similar issues?