cancel
Showing results for 
Search instead for 
Did you mean: 

General Discussions

Highlighted
Journeyman III
Journeyman III

displayport no signal detected

After searching mutiple forums and trying various tips suggested, I haven't found an answer to this. I just bought a ViewSonic XG2701 monitor with the intention on using its FreeSync capabilities. I have enabled Display Port on the monitor, plugged in the displayport cable that it was shipped with but no signal was detected. There doesn't appear to be any settings in Crimson. The display works over HDMI. So far I have:

- Updated the graphics card driver to the latest version available

- Unplugged the the power cable from the monitor for more than a minute

- Unplugged and plugged back in the Displayport cable from the monitor and the graphics card

- Changed the power settings in windows to high performance.

- Installed monitor drivers

Is there anything I'm missing? Has anyone else had this issue and found something else that got it to work?

As for my system specs:

-Intel Core i5 2500k

-16 gb ram

-Asus r9 290

-Gigabyte z77 motherboard

-Antec 650 watt power supply

If I'm missing any specs, let me know and I'll get some more details for you. Thank you!

0 Kudos
3 Replies
Highlighted
Forerunner
Forerunner

Re: displayport no signal detected

It should be nothing more than

- Turn off computer.

- Plugin in DP cable to monitor and GPU

- Set input source on monitor to Display Port (not miniDP). Also, this should really not be needed because it is usually automatic on monitor.

- Startup computer.

There is nothing to change on the GPU or in radeon settings. If it's not working, I suggest trying a different DP cable because sometimes they are defective.

Highlighted
Adept I
Adept I

Re: displayport no signal detected

An active display port adapter should solve your problems.

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: displayport no signal detected

You shouldn't need any adapter if you are using a DP cable on both ends. I agree that given all that you tried it has to be the cable. Get a new one. I have had 5, 3 worked great, 2 not at all. If that doesn't work, use one of the other ports on your monitor e.g. HDMI. run the HDMI cable all the way to the computer. If video card doesn't have an HDM port, then purchase a dongle that attaches to the computers DP port and has an "active" HDMI on the other end. Easy to get from Amazon, Newegg, etc.

0 Kudos