Showing results for 
Search instead for 
Did you mean: 

General Discussions

Adept II

Constant WHEA Event 18 crashes, Event 19 errors.

No bluescreen, no freeze, just instant restart.

Would get one every couple weeks since I built the PC a few months ago. Got several last week on the same day, replaced PSU and rerouted cables, and it ran perfectly since... until this morning, when they're coming randomly.
Would suspect the PSU, but it ran through a windows install and setting up my old PC (handing that down to my mom) and the last few days in this one just fine.

Not repeatable by program or gaming, that I can find. No telling if they're going to be five minutes after startup or three hours. So far the only load has been Firefox. Idles at 35-48 degrees.

No minidumps from them.

AMD Ryzen 3600
ASUS TUF Gaming x570 Plus (wi-fi)
MSI GeForce GTX 1650 Super
64gb (4x16gb) Team T-force Vulcan Z DDR4 3000 memory
Intel 665 m.2 1tb SSD, 1TB WD Blue SATA SSD, 4TB WD Blue SATA HDD
(now) Corsair RM850x PSU
Samsung DVD/CD read-write drive, if that matters.

SO FRUSTRATED. Any help, please? Dump from WHEA:

49 Replies
Adept II

No known changes aside from the PSU and rearranging (which didn't cause immediate problems) until they started.
Troubleshooting so far: Deleted unnecessary programs. Updated drivers. Disabled what I could. Routed SATA cables to relieve stresses. Reseated RAM, reseated CPU and reapplied thermal paste. Updated BIOS and reset to factory. Reset CMOS.

Those are the same errors I get and I was told that it's the GPU! I have a Ryzen 5 3600X, AsRock X570 Phantom Gaming 4S, Gigabyte Windforce RX 5600 XT Gaming OC, 16GB TeamForce Xtreeme Gaming DDR4 3733 RAM, topped off with a Corsair H110i GTX V2. Now I have to wonder is this a CPU or chipset issue... Those events are "processor failure" and "processor hierarchy error". All the searching comes up as a GPU driver issue. You have an Nvidia. So what's going on? I even saw a few posts elsewhere with Intel/Nvidia users getting this error, possibly a Windows 10 thing?? I have Windows 10 Home x64 version 2004, but these complaints go back to build 1903. I've done all the same troubleshooting, reseating stuff you did to no avail. Card heat could be an issue still yet to be addressed further. Imagine if all this crap is caused by a Windows bug! It'll take years for them to figure it out!

"It worked before you broke it!"

The 18s seem to have calmed quite a bit with some OS repair.
Think it's in large part drivers not playing well together or some corruption. Possibly exacerbated by hardware things.
Next step: a clean install of Windows.

Unfortunately that means that, yes, if it's a compatibility issue there may be little I can do about it, and it's just waiting and hoping for relevant updates.

did you install a Zen3 compatible BIOS version on your motherboard. especially with AGESA Those ID 19 / hard reboot loops are a common "feature" of this AGESA version. A had the same problem, I downgraded to a non Zen3 BIOS, now my system is stable again for over 3 weeks.


Even the AGESA Patch C BIOS versions seems to have some issues. Maybe AMD should have finalized their AGESA ahead of releasing Zen3.

Fear not, for I am watchful.

Not that I'm aware of.
When I built the PC, I updated the BIOS to 1407 (for this particular board) and did the normal run of driver updates. It had crashing issues until an update or two later, but I think mostly because the stock cooler and thermal paste wouldn't drop the idle temps down to under 55 at best, and the Ryzen's normal temperature spikes would trigger the failsafes.

After an aftermarket cooler (and, by timing, a couple Windows updates) it was pretty near rock solid until these issues. At least on the 18s/reboots. The 19s (corrected hardware issues) show up plenty in the event log, but don't seem to cause much issue.
Not that they aren't, just that they aren't triggering reboots themselves.

The only BIOS update since then was during these issues. Not sure if it helped or not, but I can only assume that 2802 had a round of minor fixes for various stuff anyway. At least if gives me the option for the new Ryzens; 1407 was pre-release.

The only thing that seems to have seriously helped the reboots is the OS repair, but the batch of new drivers and updates may have aided it.
Also switched back to the old PSU just to take out one variable. Will switch back to the new one on another day off to test.

Update: fresh Windows 10 install.
No more Event 19s (corrected hardware errors), and WHEA 18 isn't being written, just Event 41, Kernel-Power after the (maybe slightly rarer) restarts.
Across two PSUs. Memtest reported 0 errors, haven't found anything with OCCT...
I have no idea. At this point I'm almost certain it's hardware. The CPU or motherboard.


Just wait, those errors will come back, maybe not the crashes. Not to be the "harbinger" of bad news, but I've done the OS reinstall deal and it stays good for a little, then it starts tossing the same codes. Code 41 always is there. It acts like it woke from sleep or s3, when I have mine set to "high performance", no sleep, never turn off display, etc. One thing to make sure of is to set the SSD to never turn off. Spin drives can power down, SSD's never, ever. That will lead to corruption. Windows should do that automatically but the AI isn't there yet. Glad it's working out so far. I highly doubt it's hardware because there's so many of us complaining about virtually the same thing. That would mean we all need new CPU's and mobo's all in less than a year. 

Now I used DDU to uninstall my graphics driver and put an older one in and mine has behaved for 2 days so far. So if you get the crash issue, try using DDU and reinstall the graphics driver. A lot less work than doing the whole OS, drivers, games, etc.

"It worked before you broke it!"

I expect the issues will come back. Unexpected cycling does that.
I haven't re-upped the drivers yet. It's a fresh install, and so far is acting the same. I just got rid of some corruption issues, and now it's down to restarting every five hours or so instead of every half hour. And unless it updated things without asking me, they're just the base drivers for now.
I guess I'll do clean updates as a further test and hope.
Just frustrated because it would do it every few hours when I first built it, then it tamed down to only a couple times until this last week. And that didn't coincide with me updating anything (at least not manually) except the PSU, which I switched back for testing. Windows will do what it does, though.

I even checked for anything I could be shorting but didn't see any scratches, don't think passing wires would cause interference enough, so unless the 4+4 extensions lost shielding where I can't see (my case has almost zero room on that edge), there's nothing to short. And I disconnected the extensions just in case, and routed cables in a direct but ugly path.

I'd be less frustrated if Windows would even dump the crash info now, so I could check that.


First off this error is very generic and lots of things can trigger it. From bad cpu, memory issues, power issues, gpu issues, malware, registry corruption. You get the picture.

However as of late there are just a ton of these issues being reported some have replaced their AMD Navi GPU other their Ryzen processors and they say the problem is then fine. It seems to me disproportionate but more often than other cpus it seems I see this complaint with 3600 and next the 3700x both 65 watt parts. I have 2 3600 parts and a 3700 myself, all on MSI Tomahawk boards and no issues. I have not updated to the latest bios and will not at this point unless I upgrade to Zen 3 at a later date. As I have seen to many that complain of this issue being on the latest bios. I should add there are already several new reports of this trickling in on 5xxx chips too. Which also has me thinking, it is bios related. 

It sure seems in the cases where it is a Ryzen cpu and green team gpu many report that replacing the CPU has helped. So I am not sure if their is something that with the latest bios has pushed CPUs that may have teetered on that edge of just passing validation over the edge?

I for one am not sold on the idea that all these CPUs are suddenly bad. To many having this issues are people that ran these chips for months before having a problem while others are new builds.

I think it is possible something introduced into the bios in a  recent update could be a contributing factor. 

Any of you having this issue report it to AMD:

I would then highly suggest talking to the support department for your motherboard and let them help troubleshoot the issue. 

Most likely it is them that can isolate the cause. Maybe even offer an older or unreleased newer bios to help. 

Worth also doing is to run OCCT from OCBASE dot COM. It is free diagnostic software you can test your system with to see if it is finding problems with any of the major components. 




I would look in BIOS and see what version you have. If it's ending in a zero. it's a pre-release and can cause issues. It's meant for Ryzen 5000. The latest Agesa for 30000 is Bios's or are problematic. Agesa applies to all motherboards, it's the Ryzen micro code and power profiles. One other sore problem would be if you installed an AIO or removed the AM4 backplate and scratched the back of the board. I had that happen to an AM3+ and it was ruined. Had shutdown problems left and right.

"It worked before you broke it!"

Ahhh, check the back of the board, like in my last post. If that got scratched around the AM4 socket or mount area, it's a toasted board. It might work a week or 10 seconds, eventually it will show itself. The tiniest of scratches will do it. 

"It worked before you broke it!"

That sounds as likely as anything else, at this point. God knows it got moved around enough to risk that organizing things.
I'll keep an eye on the black friday and cyber monday sales for a replacement. Worse case, I sell it again and get most of my money back.

Take it apart man and look real close at the back of the board where the plate mates. It's so easy to accidently micro scratch it. I needed a magnifying glass to see it but it was around the holes on the AM3+. MSI board and the fine gold wires got exposed, shorted the entire board. Then I could see the white burn marks going to the RAM from the CPU. The CPU lived, the board no. Why they solder or melt critical wires so close to the surface of the PCB during manufacturing I have no idea. 3 layer boards and they still probably make them the same way. 

"It worked before you broke it!"

Slowed to a few a day.
Next step: inspecting the board (not easy, where all the mounts are. And it would probably be around a standoff. It's likely it just wouldn't be visible.) Going to try the old power cable I was using, just in case it's a shielding or short thing. After that, going to swap in my old GPU (a GTX 950 FTW Edition) just to try narrowing it down, except in that case I'd expect it to happen in games more than Firefox, or at least be more repeatable.
If those aren't it, it's the house wiring, surge protector, CPU, or motherboard. No other possible hardware issues that I can find.
Not ruling out software, but I wouldn't expect that to be so sudden or to reboot so hard it doesn't deliver a crash dump. And aside from updating or rolling back, there's nothing I can do about software anyway. And I'm not eager to do that without knowing what it is, because rolling back some drivers will cause issues.


Update: Switched power cord. It's a known good one. Doubtful cause, but -1 variable. Might make no difference, won't hurt.
Checked through BIOS again, Auto had my RAM at 16-16-16-39 at 1.30v (from what I can tell; there's a lot of numbers with no explanation, often a big string of 16s, no 18s) for some reason. Enabled DOCP, which adjusted it to match the 16-18-18-38 at 1.35v as on the label. I'm running 4 sticks, bought as two separate pairs, so hoping Auto was being dumb and this might level things out.
Memtest wasn't reporting any errors before, but I figure actually matching the label is the last thing that will hurt stability, and at least that's not risking underpowering it. Especially since I bought two at a time instead of a full kit. Don't know when that happened or if it's always been that way, or why either the timing or stability would change after months. Burn-in time maybe? Or the BIOS trying too hard.
Whatever. Keeping an eye on things.

Did you check the CPU back plate to the AIO area? That's the area that I meant most. Because when mounting it's easy to let that slide against the board and scratch it. Those RAM timings should be fine either way, especially if it passed Memtest. The box timings are usually tighter for compatibility but not "optimal", which is why tuners, like myself, use DRAM CALC or a similar program to calculate tighter timings for reduced latency and increased read/write speed and for the 10-20 FPS gain. But stock can't hurt.

What mobo do you have? If it's AsRock, like me, that is more of a problem. I need to RMA my board and buy a different brand.

"It worked before you broke it!"

It's an Asus TUF Gaming x570 Plus (wi-fi).
I haven't done any checking except a quick glance yet, until it's crashing again. The case doesn't leave too much visible and the PC's not in a particularly great place for it. So it's on the list, but will be a pain.

I'm also not too upset about 10fps or so, at the framerate of today's programs. Stability is a distant #1 from any other priority. If I really wanted the extra frames, I would be better served spending more on hardware instead of trying to milk it cheap from a 3600 or a GTX 1650 GPU.
I just wish Asus's default wasn't in overclocking everything. Especially in messing with RAM timings, which usually needs higher voltage IME.


Hey, don't be knocki'n my 3600X, it was all I could afford and ranks high in 1080p gaming CPU's, which is what I do. I think 165 average FPS in BF4 using "Ultra" is decent. FarCry 5 running at 131 FPS "ultra" is good too. I have a RX 5600 XT with the 14Gbps BIOS. 

Your RAM timings default wasn't an OC, it's what the BIOS read from the JDEC default on the RAM chip. Which I might add, is not too shabby, but wasn't giving you any real gains. That is more in the sub timings and the "1T" command rate, etc.

No, not true in most cases that overclocking RAM means higher volts. Mine with custom timings at it's stock 3733mhz is 1.35v, like on the box. The most juice DDR4 needs is maybe 1.4 if you try to increase frequency from 3600-4000 or something. Anymore and, yes, one delves into the danger zone and should buy faster RAM. That said, the "sweet spot" for Ryzen 3000 series CPU's is 3733mhz. It gives 1:1 Infinity Fabric to RAM clock and is the fastest you can go without decoupling to 1:2 or something. Doing that can hurt single thread performance, which AMD has a hard time competing with as it is. Your 3600mhz is fine, not a huge leap from 3733 performance. Straight CAS 16 like it put in is great and stable as Memtest showed.

Doesn't your case have a cutout to see the back of the CPU also to change the cooler if need be without removing the board? If so, you can remove the cooler carefully to inspect the area under that plate.

"It worked before you broke it!"

Oh, not knocking it. My 3600 is awesome when it's working right. But if I was one to want fps higher than my monitor's refresh rate, I would have shelled out for at least the 3600X, and a 2000-series GPU (I built it just pre-3000 series), and probably a more expensive motherboard, and WD Black or Samsung SSDs, and...
Anyway, my point is I'd much rather have something acceptably fast that never crashes and didn't hurt my bank account as much, versus trying for every ounce of speed and dealing with the headaches and/or costing twice as much.

And I did OC the RAM a couple PCs back, and know it's not a huge problem in itself. It's tightening up the latencies and undervolting it at the same time, across non-kit cards, all at once without testing along the way, that can be an issue.

And the case does have a cutout on the backside of the socket, but only there. Scratches around the standoffs are more likely, if less likely to cause issues, but even in that spot it would be a pain. The PC needs to be unhooked from everything to get it out where I can see that, and the cooler needed it's own great big mounting plate versus the stock cooler mount's... equally huge mounting plate.

Still better than my last PC's Intel mount, with the dumb push-and-twist studs that wanted to either stick or break every time.

Correct, non-kit RAM would be ill advised to OC or do anything with period. Too many variables, like do they have the same IC's? I should have mentioned mine are a matched set. The reviews are wrong that the 3600 can be made into a 3600X in a lot of ways. Like the non X is a 65W part, the X is 95W, mine pulls 107W until it "calms down".  The boost hits 4.437 on 4 cores most of the time. The RX 5600 XT keeps up with a 5700XT with the new BIOS and a mild OC, in 1080p anyway. 7924 in TimeSpy overall score. Like you said, when it works, it works well.

This AsRock is a huge P.O.S. for an X570, I expected more. I have a .png of the 32 code 41 Kernel Power System errors over the last 2 months, one was yesterday at 4:25pm. No PSU issue, just decides to reboot for no reason that I can catch. Really seems to be an AsRock issue since it had issues out of box and it's basically the same as the Gaming 4 (tons of issues with those) with a less beefy VRM/heatsink and a super crappy BIOS. That said, I think I'll replace the board with a Gigabyte Aurous Elite X570 next month. Alternatively, I say "goodbye" to AMD to go with a refurb 370X or something and a i7 9700 or 9900K now that the latter is sub $300 new. But I really am thinking/hoping the CPU isn't doing this. Nor my RX 5600 XT. 7 months of pain, all I can say.

I played bF4 for about 2 hours before it quit today with 2 errors, one that the driver quit and the other for BF4.exe and a code 4101. That code has been around since Windows 7 and seems to have more to do with crappy coding by Origin, Uplay, other launchers that I hate. Why can't we just download our games and play them like before "laucnhers" were around? This "tether" to EA and lack of caring if you crash right as you're kicking ass, sucks.

Sigh but the inconvenience of placing the PC in an awkward place is a bad habit I overcame. Because I got tired of needing to move half my room to pull the tower out because the back side needed to come off to get to wiring or to clean it. It sits on a long milk crate next to me and I don't care if someone comes in and see's the thing or the wires coming out of the back. Besides I use the rear USB all the time, the case ports are ok for a joystick or small file transfer but lacks the 10G my board allows. Even my TMX wheel I hook to a back port. 

The area on back socket side is the main thing to check, any defect there is disaster. The AM4 you gotta hold the plate while you put in studs for the AIO, mine doesn't bolt tight until the pump is mounted, so a slide is all it takes. I taped the plate and laid the entire case down with a small box to keep pressure on the plate just to make sure that didn't move. Standoffs, meh. Never saw anything critical molded into a board there. Most are devoid of insulation, like they're a ground or have ridges to hold the screws. 

Intel mounts from stock are just a gimmick. They're like a use it once and done thing.

"It worked before you broke it!"

Yeah, it would have to move around a lot more to scratch on a standoff, but that's a bigger possibility. Of course, 'possibility' and 'my actual problem' don't often match up.
Ah, I miss the days when some things just worked. Never been big into OCing, which helps, but my first build was a Pentium 4. Before huge lists of RAM compatibility, and it got upgraded with what I could afford and find. I can't remember it ever crashing. It actually still works, if I ever need to take all day to set it back up and night to check my email.


Besides my phone, I have 2 back up PC's and a junker Dell 620 laptop that is basically a board you lay an Intel heatsink on and attach peripherals to and it works.

So you didn't need to remove the stock AM4 bracket to install your cooler then? The standoff areas absolutely do not count, except for ones near the RAM, and even those they don't embed wires super close to. Under that CPU backplate, they have oodles of embedded wires going from the CPU socket to every other lane on the board with barely paint over them.

"It worked before you broke it!"

I did have to switch it. It came with a good mount, but it was the hook-bracket and lever style, and the coolers are screw type. It was just fine for months but, like you said, it can fail immediately or way down the line.
So I'll look when I can. Would be sooner if I wasn't limited for space and had to fit it where I can.
Plus I'm just exhausted. Maybe after I'm done grumbling and have slept off this turkey.


I got mine to work. It seems an article from October on here and some other searching lead me to my answer. In Event Viewer I found 83 WHEA 19 and Error 41's, 18 is similar. I tried playing BF4 and it crashed after an hour with a 4101 error. So that got me to looking online and such. AMD advertises that the Ryzen 3000's can do 1866mhz Infinity Fabric, so 3733mhz RAM is the "sweet spot". Well to shorten the story, I backed off my RAM to 3600mhz/1800 IF, set CL16 custom timings with 1.37v, left PBO +200, 10X scalar and tried it. Ran OCCT for an hour, no error. Prime 95 for 30 minutes, no error. Played BF4 for 4.5 hours and still no error.

No performance hit and it runs damned smooth. Researched more to find that one must hit the silicon lottery to be able to attain 1866 IF on any 3000 series except the "XT" which is the "fixed" version. Mine worked for a few months before having issues I'm guessing. I also found the the 5000 series while boasting a 2000mhz IF is in the same boat. Most can't get the IF to run at 1900mhz even. So Tom's Hardware's article from the other day recommends setting the 5000 series CPU's up like a 3950X. Use 3600 CL16 RAM setting the speed/timing manually instead of by DOCP, 1.10v SOC, set the IF to 1800, PBO enable, and "bling" it works! "Infinity Fabric" might be called FCLK and RAM speed MCLK in BIOS. If your RAM can do CAS 16, decent timings are 16,16,16,16,30,46, skim down to the tRFC set it 298/221/183 if it has the 3 tRFC's if only one than use the 298, skimdown to "gear down disable" and set command rate to 1T, fire it up. The other sub timings will be set by the board and you can verify them by using DRAM Calc (search it). Run that program select  pick Samsung B-die A0/Bad bin, select the Zen 2 AM 4 CPU option(works), and 3600 as the speed, look a the "fast" setting. The timings I gave you are slightly tighter, stable and the lower tRFC gives better read/write/copy performance. I used DRAM Calc first than calculated these timings using actual formulas. tRFC=tRC x 6 or 8 (tighter/looser), tRFC2= tRFC/1.346 and tRFC4= tRFC/1.625, tRC= TRAS+tRTP always. 

The answer is probably in the RAM/FCLK and that means maybe a calculator and a reboot. No pulling the PC out.

"It worked before you broke it!"

Based on what I have seen reported, your observation I think is spot on. All the people I have seen that have gotten this error to go away have done so by replacing CPU or backing off memory setting for instance turning off PBO. So I think it makes perfect sense it is dependent on what each cpu can handle with the speed of the Memory. I'm not sold on that it is totally that one CPU is better vs another as there are plenty of people that had no issues with their CPU until the Bios updates that added the initial micro code for Zen3 started to get incorporated.  Many have reported that regressing bios makes the issue also disappear. It is however all related non the less. 

You should send your findings to AMD support. 

That's because you posted part of my fix in October on here, lmao! I read it last night and was like, "wait that's the dude who has been commenting, now". Another guy too. So many problems on here answered I guess one forgets what they typed before. 

It's very Agesa version oriented as well as how good a CPU you got. Quality isn't even as close to uniform as Intel. It's more like a "grab bag" and see how good it is.

"It worked before you broke it!"

Sorry to jump in here but I've had these Event 18 crashes with error 41s (kernel-power) for several months and I just for the life of me can't figure out the fix. Happens only during games, usually the somewhat 'higher end' games (played some RL in the past months and that seems to be fine). Tried everything in the book pretty much (also made a thread on this forum:

My specs are also listed there. I have messed around with the RAM/voltage settings in bios a bit but I have to be honest here and not entirely sure what I'm doing. Judging from my specs would you have any idea what to do here? Any help would be appreciated!



If nothing else, try undervolting the CPU just a little. Not just underclocking, the voltage seems to have more effect on temp.
I had to do that when I first built mine, but before I changed coolers. The stock cooler and paste is just... inadequate to put it politely. Idle temps at 55+. But the 212 is kind of a good standard, so if your paste and temps are good I don't know.


The numbers on your box are the tCL, tRCDWR, tRCDRD, tRC, and the larger number is tRC. So if it's 18,18,19,48, the last is tRC The rest are sub timings, those you don't need to bother with if it's scary because the board will set those for you. These may not be in a row in the BIOS but should be. Either way, those letters I put above are in every advanced memory area of motherboards. Usually they keep those first 4 in a stack. The tRAS(usually 30-48) isn't always printed but the board will set that as well. 

DRAM Calc will give you the "safe" sub timings or "fast" depending on what you enter as far as board type AMD's we use are "Zen 2/AM4", RAM speed, IC quality (AO, Bad Bin, etc. always use Bad bin and you can't go wrong), setting the tRAS and tRFC as low as possible yields superior gains. Getting CL18 to run at CL16 does wonders as well. Yes, the 5000 series is Zen 3 but the settings are the same as Zen 2 for all intensive purposes relating to RAM.

I was scared, then I learned and like learning to swim, there's no fear. Nothing to "burn out" and easy to reset the CMOS or save a good profile in BIOS to switch back to if the PC fails Memtest, you get error 41's,19's, like I did. Drop the Infinity Fabric to 1800 and don't exceed 3600 RAM, that really works. Entering the RAM manually keeps the board from going solely by the SPD chip which many times is made for Intel chipsets. Manually entering the basic numbers and speed lets the BIOS use the AMD Agesa code to set the rest of the timings for AMD. DOCP just isn't refined enough to do that yet, unless you buy RAM that says on the box "made for AMD" or something to that effect. 

"It worked before you broke it!"

Thanks for the replies. I tried undervolting the cpu as well again today but to no effect @DeusMachina . Tried both -.05 and -.1 offsets, don't think I should go much lower. But yea still crashed a few mins into the game with WHEA event ID 18. 

As for the RAM, I'm trying to figure out how to use the DRAM calc for my specs but with this G.skill Aegis I have (Thaiphoon doesn't seem to recognize which die it is so I'm a bit lost on what to fill in at DRAM calc). I tried it via Samsung B-die and Hynix MFR (as the Thaiphoon report seems to suggest the Raw card designer is sk Hynix). See pictures below. With a couple of different settings I tried inputting all the visible data in the BIOS settings but couldn't even get it to boot anymore so had to clear CMOS several times and start over. Which is fine I'm not worried I'm breaking anything I just can't figure out what to enter or what to use exactly. Or would you only change the tCL, tRCDWR, tRCDRD, tRC numbers and leave the rest on auto? 

@mackbolan777 you mentioned dropping to IF 1800 and 3600mhz but I assume I shouldn't do that for my 3000mhz RAM since that's not really dropping but quite a big OC for what I have. 

Other people have mentioned in other threads I saw on this issue it could be a faulty CPU and that replacing that fixed the issue. At this point, with PSU and GPU both recently replaced already, im a bit lost as the issues just dont seem to go away. Perhaps by process of elimination it has to be the CPU so perhaps back to the store it is. I just think there could be a combination of cpu/voltage/ram settings that gets rid of this issue but perhaps it really just is hardware. 


capture 2 dram.PNG


My bad, set the IF to 1500 because you have 3000 RAM. It's always half total RAM speed unless overclocking, then things can be different but the RAM would be running faster than the IF for that. I thought you had the X570/550 chipset? If no, then that looks ok for DRAM calc. Take the PCB revision up 1 level, recalculate. Write down all those numbers from tCL to tCKE and of course the corresponding abbreviations for each number as your BIOS may have them listed slightly different. Then plug the number sin matching them to the correct thing. Like "tCL 14, tRCDWR 14" and so on. tRFC should be set to the lower number "348" or whatever it recalculates to if you change the motherboard chipset to the X570/sTRX4 (550 setting).  Bump the RAM volts to 1.360v. 

Note: If you BIOS has the setting for tRFC2 & tRFC4 the calculation for those is as follows: tRFC2=tRFC/1.346, tRFC4=tRFC/1.625 Those will give you the other 2 numbers. tRFC is whatever DRAM Calc spits out as the tRFC(alt) lower number. To find the optimal tRC it's always tRC=tRAS+tRP if it's not matching what DRAM tells you. 

Now, aside from above if you manually enter those XMP numbers in BIOS as RAM speed 3000, IF 1500, DRAM Voltage 1.35v, then manually enter RAM Timing enter the numbers tCL=16, tRCDWR=18, tRCDRD=18, tRP=18, tRAS=38, tRC=56 and no other numbers, what happens? It should run crash free that way as well, just slightly slower than DRAM timings.

I've included a screen of my DRAM for observation only, my number won't work for your 3000 RAM. The tRFC might, it's a common number. Note the numbers on the left are my timings post calculations and I'm in the "membench" screenDRAM 11_30_2020.png

"It worked before you broke it!"

BTW, someone has your name in here as a BF4 soldier. We were killing each other last night, lol.

"It worked before you broke it!"

Ha cool, yea perhaps the recent crash bandicoot brought it back. I've had it for many years since crash 1 ;)

So I found out that it's not a samsung b-die:

It was actually Hynix AFR, see below. My motherboard is the B450 tomahawk max so I've left that on B450 of course. Sadly I can't get the pc to boot with the info below. I just copied everything as stated below. 

I do have tRFC 1/2/4 options so I use 486 for 1, then 361 for tRFC2 and 299 for tRFC4 as per your calculations. Tried that with 1.34 and 1.35v but both didn't boot. If I boot however on 3200mhz/1600IF with 1.37v it does work, that's without changing any timings, but the WHEA Event ID 18 happened pretty quickly again. Is there anything else I can try here? 

Also from another thread I got the idea to run on older 5700XT drivers for a while. CoD Cold war sadly doesn't support it but on driver version 19.7.5 I'm so far getting no reboots with WHEA yet. We'll see..


Yep did you try putting in the stock settings from the box as per the last post? Even if that window that said it was Samsung IC's was wrong and it's Hynix, the box has numbers like 16,16,18,18, etc. They are what goes in the first 6 entries in BIOS or as shown below. Set voltage to stock, set IF to 1500 for 3000 RAM. For video driver, try the 20.8.3, seems to work but fix the RAM first. Also, if you have 4 RAM slots, because your PC specs didn't show in the prior link, install them in A2/B2, the second and 4th slot from the CPU. Provide your CPU type please.

You could run the RAM at 3200mhz and the IF at 1600, with the right timings. Input the RAM speed into DRAM as 3200 to get those numbers. I know I said use the (alt) but in this case you would use the the 432 and calculate from there.  Also use A0/B0. I've include 3 screen shots, 2 DRAM Calcs one for 3000, one for 3200 and one of my CPUZ, mentioned belowDRAM 3000.pngDRAM 3200.pngCPUZ 12_1.png

However, let's keep it simple. Run the specs off the box or if you don't have the box, a program called CPUZ will tell you what the XMP settings are, the chip brand, JDEC timings, etc.  The XMP numbers are shown, which is what was on my box, plus the other JDEC specs for the RAM. AIDA64 is another but you need to either pay for it or go on Ebay and buy a key to get the full readout. That program will give you every timing, type of IC, voltage, supported by your RAM. I think in your case until we get rid of the error, stay stock. You can also use those timings or stock timings and use 2T, it may increase stability. At the end, run Memtest64 for a few hours or until an error to be sure. Then try gaming. Or just game, it's the best stress test, however won't let you know if the RAM is set ok. There's a Reddit on your RAM as being a "problem child" on the 450 boards for some reason, so you might need to get something else in the end. Most likely not a new CPU but a different brand RAM. We can cross that bridge if need be.


"It worked before you broke it!"

My reply disappeared. You forgot to give your CPU type since the original link doesn't work. Post a new thread and I can help you more because I think this one is getting too full or something. Run the stock timings off the box in the first set of numbers from tCL down. Sett the IF to 1500 to match the 3000 RAM. Use the lowest Trfc and calculate from there, also use the A0/B0 setting in DRAM Calc. Make sure if you have 2 sticks to only install in A2/B2 or the second and 4th slot from the CPU.

"It worked before you broke it!"

Sorry have been very busy with work I'm gonna get around to it this weekend to do some troubleshooting. I'll let you know / post a new thread in case anything comes up. Mem sticks are definitely installed in the A2/B2 slots. CPU is a Ryzen 5 3600 - original link was here for some other specs in case they're relevant: 

Thanks for all the help so far anyway! 


You know, you have the latest BIOS and that one is a problem with the 5000 series CPU's, causes crashes and CPU errors. I even used that same Agesa version and had issues. I would go with this: 7C02v34 BIOS because it has the same Agesa version I'm running. That's the micro code the CPU uses and I found anything past that version just causes havoc with my 3600X. Try that and you should be able to set the RAM to DOCP, I would still cap the IF at half the RAM speed(1500) vs. auto to be safe but PBO and everything else should work error free. The other part is that video driver, nothing but issues as it seems heavily coded to the 6000 series cards. I would walk that back to the 20.8.3 and just see. 

I think with all the extra posts, over concern over various things I missed the fact you're running AGESA ComboAm4v2PI and that just is not working for the 3000 series. AMD ComboPI1.0.0.4 Patch B (SMU v46.54) is the one I run. There's one for but I think that'll add issues as well. That 20.11.1 driver gave me all kinds of issues, others with the 5700XT complained as well. Some have luck with the 20.9.2 but I still like the 20.8.3 overall. 

Anyhow you slice it try that BIOS flashback, put an older video driver in and see if the errors seem to vanish. Mine did, plus I put my IF to 1800, which is half of my 3600 RAM speed. Zero errors, no crashes.

"It worked before you broke it!"

Hey Mack, 

I see you edited some replies above as well, thanks so much for all your input. I've been running BIOS 7C02v34  as you suggested and went back to 20.8.3 on the GPU. Sadly I'm still getting WHEA errors/crashes in games (it basically just reboots out of nowhere). The LiveKernelReports folder in windows now also returns .dmp files in the WATCHDOG folder, with the same timings as the WHEA errors in the event viewer. Not sure what this means, here is the latest one but I doubt anything can be extracted (there are also some WHEA logs there). Some Googling shows these .dmp files are often created with outdated drivers, so I guess that's logical since I switched back to older drivers. 

Now while I was running the older BIOS and GPU driver I didn't make too many changes in the RAM. I just had XMP on and ran it on 3000mhz with 1500IF and didn't change any timings. Left PBO on though. I went back after the latest crashes and did try to set the RAM to all the timings from DRAM calculator to see if that would make any changes (with those changes to A0/B0 and tRFC 1/2/4 starting with 420, then as per the calculations 312 on tRFC2 and 258 on tRFC4). However, even on the 3000/1500 settings it just won't boot, tried both T1 and T2. CPU led on motherboard stays red and have to remove CMOS battery in order to redo the setup again. Maybe I'm doing something wrong but I'm pretty sure I've just entered everything exactly as is on the DRAM calc screen. Do I have to change all the settings including the misc items / termination block and CAD_BUS Blocks from DRAM or just the numbers from tCL to tCKE? (I actually tried both but it wouldn't boot either way so it's probably not that). 

Gonna try to run MemTest86 overnight again, I did it a couple of weeks back and had 0 fails but who knows. I noticed you said this RAM might be a problem child on this b450. Is there a RAM you would recommend on this setup that could be more stable? Sadly I don't have any spare parts lying around as this is all 5-6 months old and been out of the PC building game for a while, but if a new RAM would solve this I'd be more than happy to try it out. 

Edit: MemTest86 ran for almost 4 hours / everything passed 0 errors. I have saved the html in case you need it. Also here's a screenshot of CPU Z (slot 4 identical ofc). I guess the question becomes, how likely is the chance the issue is with the RAM if it only occurs while gaming and doesn't show up in the MemTest?

ram cpuz.PNG


Asus just released a new BIOS for X570 boards, version 3001 and its non BETA. Possibly this is something you can try?