cancel
Showing results for 
Search instead for 
Did you mean: 

General Discussions

chrinide
Journeyman III

AOCL 4.1 BLAS-integer*8 do not exit?

Dear AMD Community ,

I have tried to compile DIRAC quantum chemistry code (https://diracprogram.org/doc/master/index.html) in my AMD 7950x computer.  

The system is Rocky Linux 9.2, GNU compilers version 13.2 (gcc/g++/gfortran), AOCC/AOCL version 4.1.0.

I have tried to compile a pure 64bit version DIRAC, so I need a BLAS-integer*8 blas to link.

I have tried to use this link " -L/opt/aocl/gcc/lib_ILP64 -lblis -lflame" , as far as I know, lib_ILP64 should contains integer*8 blas?  Am I right?

But the DIRAC install process checked the link  " -L/opt/aocl/gcc/lib_ILP64 -lblis -lflame", The checked results indicated that lib_ILP64   are not integer*8 blas, but still  integer*4 blas!  And after I compiled the DIRAC and test the running, the DIRAC failed with argument " integer*4 blas not  integer*8 blas".

I have also tested the default lib " -L/opt/aocl/gcc/lib_LP64 -lblis -lflame" , which DIRAC install checked this link is also the integer*4 blas.

Yes, compiled with integer*4 blas AOCL is OK for DIRAC and I have compiled this DIRAC successfully and running smoothly.

So, My question: Is lib_ILP64 did not contains a integer*8 blas inside? what are the differences bettween lib_ILP64 and lib_LP64 in AOCL?

 

 

Chrinide

 

 

 

 

 

 

 

0 Likes
0 Replies