cancel
Showing results for 
Search instead for 
Did you mean: 

FirePro Development

Journeyman III
Journeyman III

ATI FirePro™ RG220 Unified Driver Version 8.911.3.3 on SLED11 SP2 not working

Hello,

first of all I have to say that my English isn't best but I hope you'll understand the problem.

I need to test Remote Workstation Graphics ATI FirePro™ RG220. Workstation I use is HP Proliant DL360 G7 with new instalation of SLED11 SP2. I found a "manual", how to correctly install Unified Driver 8.911.3.3 (according to patch notes, this graphics card and OS distribution are supported).

  • Download latest driver from AMD/ATI driver page
  • Open Yast2 and install: kernel-devel,kernel-desktop-devel,Gcc,Gcc c++,Make
  • Reboot, and add this to the GRUB startup options: radeon.modeset=0 blacklist=radeon 3
  • When you boot into console, become root and run: # mkinitrd
  • Afterwards, cd to download directory and run installer: # sh ati-driver-installer-*.run
  • Select default options all the way, then: # aticonfig --initial
  • And last: # /sbin/shutdown -r now

Problem is that after driver installation, at the point where I'm suppose to create initial aticonfig all  I get is this error message:

  • aticonfig: No supported adapters detected

So I'd like to find out if I do "something" wrong or if SLED11 SP2 is not supported yet or if mistake is somewhere else.

With best regards, Petr.

0 Kudos
Reply
1 Reply
Staff
Staff

Re: ATI FirePro™ RG220 Unified Driver Version 8.911.3.3 on SLED11 SP2 not working

After installing the driver can you please check if the kernel modules were built correctly. Please run modprobe -v fglrx and check if you get any error messages.

It might be that on SLED you need to allow loading unsupported modules. To do so please edit /etc/modprobe.d/unsupported-modules and set the value of ALLOW_UNSUPPORTEDMODULES to 1

0 Kudos
Reply