Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

World of Warcraft crashing after last update

I just updated my drivers, and now World of Warcraft won't run. Driver 31.0.22023.1014 10/25/2023.

Battlenet opens fine. When I click "Play" the computer blacks out. Then I click on the screen, and get a "World of Warcraft is not responding" error.

Dell Alienware Aurora Ryzen Edition R14. AMD Ryzen 9 5900. AMD Raedon 6700 XT. Windows 11. Plenty of hard drive, and doesn’t overheat or overclock at all.

I tried uninstalling and reinstalling the driver. Also COMPLETELY deleted Battlenet and World of Warcraft (even deleted folders and files in Programs, Program Files, User AppData, etc).

Nothing worked.

Turns out others are having the same problem:

Baldur's Gate 3 runs just fine.

What is going on?


2 Replies
Journeyman III

If it's the same issue I had, what's causing this is DX12. For some reason after a certain update, launching the game with DX12 enabled takes way longer than it should. If you let it sit unresponsive for a while, in my case like 2-5 mins, eventually it loads and then loads with no issues afterwards. If you can't get it to load after waiting you can go into game settings in the app and tick "Additional command line arguments". Add "-d3d11" and it will force the game to launch with DX11. Should work then as a temp measure.

I just updated to the new AMD drivers and also having this same issue like in November. Those old solutions didn't work for me then, but my old one did: I left it on the black/white (it's been changing) for 5 minutes or however long it takes and it went. Don't know why that works, but whatever I guess. It's just annoying.

Clearly the AMD driver is the issue. Very frustrating