cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

With 17.7.2 Overwatch crashes constantly

With the newest driver release 17.7.2 Overwatch crashes constantly with the error message: "Your rendering device has been lost". I have since reverted to 17.7.1 and the problems have completely disappeared. I've tried to report the issue, but apparently the issue reporting page doesn't exist.

EDIT:

Specs:

  • AMD R9 290X
  • Desktop
  • Windows 10 64 bits
  • Driver 17.7.2
  • Display device 1: Samsung SyncMaster 2443 1920x1200 via DVI
  • Display device 2: Iiyama ProLite X2783HSU 1920x1080 via HDMI
  • ASUS P8Z68-V-PRO; BIOS version 3603
  • CPU: i7 3770
  • PSU: Be Quiet! Pure Power 630 W
  • RAM: 8 GB

Message was edited by: Josh Mono

Tags (2)
83 Replies
Esteemed Contributor III

Re: With 17.7.2 Overwatch crashes constantly

0 Kudos

Re: With 17.7.2 Overwatch crashes constantly

Thanks. That is official? It's rather strange that they don't link to it themselves.

EDIT: That survey is completely broken. None of the checkmarks work (tested in Chrome, Edge, Firefox, Internet Explorer), and they're required to send in a survey.

0 Kudos
Esteemed Contributor III

Re: With 17.7.2 Overwatch crashes constantly

0 Kudos

Re: With 17.7.2 Overwatch crashes constantly

jUl9913.png

EDIT: So I installed 17.7.2 on my secondary desktop... Is this a joke? The wizard doesn't even work! The button doesn't do anything! What is it supposed to do? Lead to the non-functional survey? What's that gonna achieve?

Got any helpful tips?

0 Kudos

Re: With 17.7.2 Overwatch crashes constantly

Can confirm the issue. And for me, reverting the driver also solved the problem. R9 390x here.

0 Kudos

Re: With 17.7.2 Overwatch crashes constantly

The survey worked Just Fine on my Android phone browser, the default chrome

0 Kudos

Re: With 17.7.2 Overwatch crashes constantly

So it works on Android but not on computers? That's pretty bad, AMD. Welp, looks like I'm going to have to use a phone.

0 Kudos
Journeyman III
Journeyman III

Re: With 17.7.2 Overwatch crashes constantly

I'm getting the exact same problem, at first I thought it was an over-heating issue so I cleaned out my case, fans and applied new thermal paste. Still had the problem so after a bit of googling I rolled back my driver only to find the AMD Crimson software wouldn't recognize it. I tried this 4 times to no avail. I tried a fresh install of a driver and that still doesn't work. I looked on the OW forums and I'm seeing this is a common theme with AMD cards and people are pretty upset. I can get through maybe a game and a half before I get "Your rendering device has been lost". I am now being punished by blizzard for leaving games early.

You Crimson suite is also confusing and horrible to use. And it needs a simple roll back driver option, or the ability to roll back to an ealier driver.

Any help or advice would be appreciated. I've already sent in a ticket which said thanks for your feed back and this mailbox isn't monitored so I don't know if that's going to go anywhere. :/

0 Kudos
Community Manager
Community Manager

Re: With 17.7.2 Overwatch crashes constantly

Can those experiencing this issue provide more details regarding :

Game settings used

Driver settings used

Steps to repro ?

Thanks

0 Kudos