cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Highlighted
Adept III
Adept III

Witcher 3 Crossfire Flickering Fix!!!

Jump to solution

Hi everybody.

After many days worth of digging through forums and trying .ini tweaks, I have finally pinned down the cause of the water, metal and distant walls flickering when running Crossfire.

I noticed the flickering was most noticable in distant windows walls and water, and only affected items which were hit by sunlight and not the light from flames.

Lightbulb! Must be the lighting right? But there are no lighting tweaks, so I messed with the next best thing, namely the shadows.

I had already used RadeonPro to flip the Queue Size, this made things a bit less noticeable, but didn't fix the flickering completely.

I'm currently back on the default Queue Size, but this fix works with and without the Queue Size tweak.

Also delete any profile you may have made in CCC, and disable AA (bin/config/base) in rendering.ini just set temporal to false.

If you want SMAA you can force it through RadeonPro or Sweetfx 2.0+Reshade (doesn't work with 1.5 and the toggle doesn't work with either).

If you use RadeonPro for the SMAA and the game refuses to launch, just right click and disable API Monitoring and Auto-Detection.

Go to your 'My Documents/Witcher 3' folder and delete user.settings.bak (don't worry this is just the backup file).

Do this every time you wish to change a setting, or it will not be saved and the above file just overwrites any changes you've made.

Now open user.settings with notepad.

Scroll down to the 'Rendering' section.

And just change 'CascadeShadowDistanceScale2=' to a value of 1.7 (Ultra is 1.5 by default).

This changes the quality of the shadows rendered in the distance, and if your rig can handle it you should be able to go even higher.

Although I doubt that's needed since 1.6 left some very light flickering and 1.7 got rid of it all together.

Note...sometimes when entering the world the game may crash, happens about half the time.

If you get past this every thing is stable.

However since I can only speak for myself, I would like some responses from people with different GPU/CPU setups.

Just so people have some idea of where their settings should be at.

Please provide GPU/CPU info and off course the value you're running best at.

Other specs like game/driver/os version could also prove useful.

Mine are...2x 280x/fx8350 at 1.7.

Other Specs...Witcher 3 Patch 1.05/AMD 15.5 Beta drivers/Windows 7 Ultimate x64

In-Game every thing is on ultra except AA which is off.

I've also noticed the fps limiter makes the greatest impact on the stuttering.

For me it's silky smooth at 30 and slightly choppy at 60 but nothing major.

Hope this works for you guys/girls, and please take the time to report back if you get this working.

P.S. Sorry for the wall of text, but I though I aught to be thorough.

P.P.S This is my 1st thread on the AMD forums, so sorry in advance if this is in the wrong section or something.

1 Solution

Accepted Solutions
Highlighted
Adept I
Adept I

Re: Witcher 3 Crossfire Flickering Fix!!!

Jump to solution

15.7 drivers seems to have fixed it for real this time

View solution in original post

63 Replies
Highlighted
Adept I
Adept I

Re: Witcher 3 Crossfire Flickering Fix!!!

Jump to solution

Awesome!!! I still notice a small amount of flicker in the city, but this reduced the flicker to almost nothing.  Thanks for the research.

Highlighted
Adept III
Adept III

Re: Witcher 3 Crossfire Flickering Fix!!!

Jump to solution

No problem.

I'm just glad it worked for someone other than me.

0 Kudos
Highlighted
Adept I
Adept I

Re: Witcher 3 Crossfire Flickering Fix!!!

Jump to solution

Sadly, I tried this fix last night, it worked, kind of.  I still have a lot of flashing in cities and around water.  I have not patched the game so I'm going to try that first then report back.

My specs: FX8320 w/ 2 x XFX 7870 DD Ghz Edition Cards.

Thanks for the effort though!

Highlighted
Adept III
Adept III

Re: Witcher 3 Crossfire Flickering Fix!!!

Jump to solution

Yep... it came back for me as well a few days ago.

It's really a shame, it was running absolutely beautifully.   

It's less for me after meditating, but for some reason this only works once, until the next system restart.

The flickering is back with a vengeance, for the grass, water and walls, strangely enough the metals like sword hilts and candlesticks don't flicker anymore.

I'm currently back to running without Crossfire.

As for patch 1.06 judging from the patch notes it doesn't seem to fix anything even slightly related to Crossfire.

And from what I understand, the ball is in CDPR's court, and off course they're gonna fix SLI before Crossfire.

Shame on CDPR for selling out to those Nvidiots, also AMD dropped the ball on this one...Tressfx/Mantle anyone?

If there ever was a game where these would shine (pointing at you AMD), then this was it!!!

Still the game is fun, but I'm shelving it for now.

The ini tweaks are making little if any difference atm, and we need more from CDPR if Crossfire is ever gonna be fixed.

Unfortunately the CDPR forum have locked any thread asking about patch ETA's, and have so far given absolutely no answer to any questions in relation to Crossfire (As opposed to the dozens of responses concerning SLI). Making it pretty obvious what their priorities are.

0 Kudos
Highlighted
Adept I
Adept I

Re: Witcher 3 Crossfire Flickering Fix!!!

Jump to solution

I tried this: I saw some improvement; not all.
I even bumped up the value from the suggested 1.7 to 1.9 and got more improvement.
It's well worth trying this though: it lessens the problem from game-breaking in some areas to just an momentary annoyance.
My setup: i5 w. 2 X R9 280 OC to 1050mhz

Highlighted
Adept II
Adept II

Re: Witcher 3 Crossfire Flickering Fix!!!

Jump to solution

I have Fx8320 + 2x7950 and have horrible flickering also. Tried your solution but didn't fix my problem. I hope 15.6 fix that problem.

Highlighted
Adept I
Adept I

Re: Witcher 3 Crossfire Flickering Fix!!!

Jump to solution

I wouldn't put it down just yet. I am running the game on a single card, waiting for DX12 in July and possibly a new driver set in the coming months.

I'm getting decent frames. I have mostly everything on High except for texture which I have set to ultra and with everything turned on in post processing.  With those settings I'm still getting 35-45 fps which isn't bad for a XFX HD 7870 GHz card.

I may try thehairyfoot's fix up to 1.9 although I'm sure I'll just be sticking with a single card solution.  I've also been looking for an excuse to buy a new GPU so that may happen also.

Highlighted
Adept III
Adept III

Re: Witcher 3 Crossfire Flickering Fix!!!

Jump to solution

Ok, I can't seem to edit the original post.

I have now managed to get rid of every kind of flickering, water, puddles, windows, shadows, walls, grass, foliage etc.

The only exception being the mini-map and inventory mouse-over flickering, although it is much less than before and gone after a second mouse over (for the inventory at least).

I'll make this simple, kinda :-s.

1. Go to Witcher 3/bin/config/base and open 'rendering.ini'.

    Set 'EnableTemporalAA=' to false.

    This disables in-game AA as it causes flickering, don't freak out keep reading ;-).

    Here you can also adjust the Hairworks AA level for better performance.

2. Go to Witcher 3/bin/x64 and rename, move or delete 'APEX_ClothingGPU_x64.dll'.

    This applies some sort of physx affect to clothing, I haven't seen a difference since renaming it.

3. Go to My Documents/Witcher 3 and delete 'user.settings.bak'

    Do this every time you make a change.

4.Now open 'user.settings' with Notepad.

   And just change 'CascadeShadowDistanceScale=' to a value of 1.9 (Ultra is 1.5 by default) (1.9 was suggested by 'thehairyfoot', and has better results than 1.7).

   Do this for all of them they range from 0 to 3, (0,1,2,3 so 4 in total).

5.Open RadeonPro, make a profile for The Witcher 3.

   Right click it and disable 'API Monitoring'.

   Now go to the 'Visual' tab.

   If you want AA just check FXAA and set to Ultra, (SMAA works as well but with heavy artifacting).

   Scroll down and set Tesselation Control to x4 x8 or x16, (improves fps when hairworks is on).

   Now go to 'Advanced' tab.

   Check 'Flip Queue Size' and set it to 0, (higher settings cause input lag).

  

6.Open CCC, (right-click desktop, the top one).

   Make sure that under 'Gaming/3D Application Settings' there is no profile for 'witcher3.exe', if there is just delete it.

   Don't worry the 15.5 driver has a built-in profile, that's the one we want to load.

   Also make sure crossfire is enabled under 'Gaming/AMD CrossfireX'.

7.In RadeonPro right-click the Witcher profile you made and run the game.

   If when loading an old save, the game crashes on entering the world, just try again you'll eventually get in.

   Then just meditate to a different time of day and save, after that you should be good.

   Now open the menu and go to graphics settings, set the game to run in Fullscreen, any other mode will disable Crossfire.

   Also do not touch the AA settings in-game, as this will undo step 1.

  

And that's it.

As a side note...It takes about a minute for the second card to fully come online.

Also if the game still flickers at first, try meditating to a different time of day.

Please let me know if you still have problems with this.

I've been playing for about 4 hours and have had no in-game flickering what so ever.

I should also mention I'm running at 5040x900 (Eyefinity), on 2x Asus 280x DCII Top (stock clocks), fx8350 (4.3ghz OC) and 32gigs of ram.

Turn V-sync off and set the Frame Limiter to unlimited to get rid of the stuttering.

Highlighted
Adept I
Adept I

Re: Witcher 3 Crossfire Flickering Fix!!!

Jump to solution

Thanks for your research on this! I'll give it a shot. 


Just a quick question. Is RadeonPro the same thing as Raptr or is it different?  Sorry I've just never used that program before.

Thanks again for your attention to this!