Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


Windows won't recognize GPU after reinstall

Long history short, i updated my AMD RX 560 drivers, i had some resolution problems and my second screen wasn't working, i reinstalled Windows 10 64b because i was fed up, but now my GPU is not getting dedected in any way shape or form, trust me, i tried EVERYTHING, the hardware Works on other computers, i cleaned it, its a software problem,

Things that i tried:
Updating BIOS
Updating Windows
Updating all my other drivers
Cleaning the hardware
Hardware dedecting programs 
Device manager 
Clean install of the right driver 
AMD Auto install doesn't work, it showed the 182 error and now it says its already installed?
Installing C++ Packs 
Re-re Installing Windows (i lost all my stuff)

My mother board and other stuff: 
asus m5a78l-m lxbr - motherboard
amd rx 560 - gpu
Windows 10 64b- OS
amd fx-6300 six core 3.50 ghz - Processor

12 Replies

check your BIOS as the integrated graphics is active

try a BIOS reset to default

The BIOS doesn't show me an option to enable the GPU, but it lets me change the load order, i went to advanced>chipset>integrated graphics, i tried all of them and it didn't work, should i look for the enable option somewhere else after i do the full reset?


if there is no option, definitely do a reset of the BIOS to defaults


I have a idea.

Windows-10 has now changed the way Fast Startup work, no longer is linked to SecureBoot or FastBoot

Disable both secure boot  and  fast boot in UEFI/Bios . You don' t have to necessarily disable hybernation, unless your S4/S5/S6 Lan wakeups are all connnected, if your new to the terms they are (power states) and windows-10 mess's up so to say when Lan settings end up being ON with certain options causing Win10 to still not do a proper shutdown

Investigate that part also set your PC to Safe Mode minimized bootup before running the following tasks

Disable Hybrid shutdown

Admin CMD Box  run these commands as Admin either CMD or Powershell either works fine.

powercfg /h type REDUCED

chkdsk /f

After chkdsk finishes and Win10 is finely set to perform a Real shutdown known , shutdown your PC restart and it should take a really long time to start

If you still think your PC isnt shuting down properly and its still focing fast startup and it still took a long time to start but just cant get rid of the Fast-Stratup Bug run this. Yes it is a known Win10 bug no matter what system is running Win10 everyone is now advised to disable Fast Startup from Fresh installs to reinstalls to Refreshed Installs and MAKE SURE THE LAN SETTINGS ARE GOOD TO GO.

Lan is yet another bug they just cant fix yet ....

Performing a real shut down in Windows COMMAND
Shutdown /s /t 0

Power back on the PC

You should boot directly into safe-mode and check to see if the GPU is now at least showing in device manger.

If it is good, if its showing but with yellow triangles just let me know, i got a work around idea for that. If its showing but disabled , thats a whole other problem but not one that wouldn't be fixed if you check the settings i listed.

You should never see Yellow Triangles anywere mot even in safe mode, that means basic system drivers are missing or if at Normal Boot, Device Drivers have malfunctioned. Depending on whats got the triangles depends on how serious it is, Good idea to list any Yellow Triangles your seeing Including the new HyperV mess Win10 now has going on. FUN FUN  

You say you tried everything but probably never looked into the LaN problems and a ton of other things i dont see you listed, Dont give up its solvable. It wont matter if you have a LaN installed or rip the LaN directly out the PC, Win10 uses its registry and settings regardless of setups, so the problem will persist until we find out what windows10 is seeing and correct it

I do not have problems with windows using fast boot as my machine is windows 10 whql compliant

if windows is that magned, might be best to reset it

that can be done from the setting / windows update and recovery


kinda hard for me, but i'll try, ty for the attention


Sorry that i took a while, but my BIOS doesn't have a option "secure boot" or hybernation, i tried all the rest and it took sometimes to turn on but it didnt go to safe mode by itself or show the GPU, maybe i did something wrong?


Windows 10 Fast Startup could be detrimental to your computer 

How to Enable or Disable Fast Startup

Deciding whether to bother with Fast Startup actually takes longer than turning it on or off. First, open up your power options by hitting Windows+X or right-clicking your Start menu and selecting Power Options. In the Power Options window, click “Choose what the power buttons do.”

power options

If this is the first time you’ve messed with these settings, you’ll need click “Change settings that are currently unavailable” to make the Fast Startup option available for configuration.

available options

Scroll to the bottom of the window and you should see “Turn on fast startup (recommended),” along with other shutdown settings. Just use the check box to enable or disable Fast Startup. Save your changes and shut down your system to test it out.

fast startup

If you don’t see the option at all, it means hibernation is not enabled on your machine. In this case, the only shutdown options you’ll see are Sleep and Lock. The quickest way to enable hibernation is to close the power settings window and then hit Windows+X and open Command Prompt (Admin). At the Command Prompt, type the command:

powercfg /hibernate on

After turning hibernate on, run through the steps again and you should see both the Hibernate and Fast Startup options.


Hey i did this, the slow startup worked but it didnt show my GP. Also i did the thing with the admin cmd to allow hibernate but the command didn't do a anything?


You have to reboot your computer after making the changes for them to take effect.


just did that, didnt work.


Hello, Did you manage to fix the issue, i'm having the same problem as of today, i've tried everything i could think of and that i could find online for the past 5 hours and no success.

The windows just install  its drivers, i uninstalled them and tried a bunch of stuff, i even got AMD software to display what version they want to install and after i select it i get that the AMD software is not compatible to the Operating Software ( been using the same windows 10 pro with the same license as previousely ). This is just a fresh windows install , if i cannot find a way to fix this, i will try to re-install the windows all over again.