Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Windows update broke radeon settings app

The newest windows update (KB4601050 and KB4598242) seems to have disabled the radeon settings app (no tray icon present, context menu option doesn't open the app) and this has also disabled MSI afterburner from hooking the driver to display monitoring OSD with RTSS.

However settings I had applied before the app broke are still being applied to games and windows display outputs (various AA and AF settings + RGB 4.4.4. colour and VSR are still working).

Windows 10 20H2

Ryzen 7 3700x (@stock clocks)

Radeon RX 5700 (@stock clocks)

Asrock B550 phantom gaming 4

32GB 3200 ram


Steps tried:

Reinstalling AMD driver 21.2.2

Rolling back driver to 21.2.1

Attempted to uninstall the above updates but no option to do so seems to exist (can only uninstall the previous updates from 13/02/21)

Restoring windows from a 2 day old back up (only option that seemed to do anything but windows immediately updated itself and broke the app again)


Any other suggestions?

1 Solution

Ok manually uninstalling chipset drivers then reinstalling them seems to have worked

View solution in original post

5 Replies

Have you tried the SFC and/or DISM commands to find and fix windows errors.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

Yep SFC reports no errors and DISM completed with no errors. Problem persists

Windows error logs have an APPCRASH report for RadeonSoftware.exe but it's a generic and entirely useless report


Ok resolved as of right now with factory reset of driver. Annoying as I now of course have to set up everything again but at least it's working


New problem, factory reset uninstalled chipset drivers, chipset drivers will not install now


Ok manually uninstalling chipset drivers then reinstalling them seems to have worked