Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Windows cant recognize my AMD Radeon RX 6950XT & DP & HDMI dont work when plugged in the GPU


Hello y'all,

am facing 2 issues/problems. 


I just got a full amd pc build, I freshly installed Windows 11 Pro, and when I finished all the updates, both on -Windows Update, Microsoft Store, AsRock drivers, AMD own Software. 

i noticed under "Device Manager" - Display adapters - AMD Radeon RX 6950 XT. it has a warning sign.

"Windows has stopped this device because it has reported problems. (Code 43)"

I cant find any solution, I think I have tried everything, please help me. 


also to mention, I have plugged my HDMI cable from my monitor to the Motherboard itself, because when plugged it to the GPU, nothing happens, I don't get any input/output or whats it called.

i have tried with 2 different DisplayPort cables, and the same working HDMI cable, nothing worked when plugged into the GPU.

am not sure if its because of the Driver missing, but that shouldn't be the case?

i really hope the experts can help me here.


  • - Lian Li Q58 with extra mesh panels
  • - ASRock | B650E PG-ITX WiFi
  • - Ryzen 7 7700x
  • - Lian Li Galahad Cooler - FREE DDR5 Ram Kit
  • - 1TB NVME SSD Samsung 980 PRO
  • - AMD Radeon RX 6950 XT FE
  • - EVGA 850w PSU
  • - 3 x arctic P12 Fans
9 Replies
Journeyman III

another issue is the boot time, it takes around 1 minute to boot to the login screen. 

can it have anything to do with I have plugged HDMI cable to the motherboard?


No output from the card itself is not a good sign and the card will only output through its own ports not the mb.  Are the pcie power cables fully plugged into the card and the PS?  They must be fully engaged and latched. 

Have you tried moving the card to a different pcie slot on the mb?  If you get a signal from a different slot the mb is bad or you have set the bios wrong. 

If all else fails unplug the power to the system, remove the cmos battery, drain the caps and wait 5-10 minutes for the power to drain from all caps on all components then with the video cable plugged into the gpu not the mb try to boot and see if you get signal. 

And lastly if you are swapping cable types to the monitor are you changing the input ports in the monitor OSD to match?


1. Yes, i did fully check if the card was placed correctly. (the card itself do run, I can see the red light from the "Radeon" logo, and see the fans spinning.

2. Forgot to mention that there is only 1 PCIE slot on the MB. it is a mini-itx build (ASRock | B650E PG-ITX WiFi) I did also try to Reset all BIOS settings.

3. there isn't any cmos battery that I know off.

4. yes, I do I have a fancy monitor which allow me to use the remote controller, to switch from HDMI to DP. and everytime I tried it just switched it back to the HDMI. (I tried with have both the HDMI and DP to be plugged into the GPU. at the same time) but that didn't work either.


Do you have another card you could try in that slot or do you have another computer that you could try that card in to see if its good?


no sadly


Is the GPU new and still within its return window?  I would send it back and get another card as it should output signal from the moment you hit the power button.


yeah, i bought it from AMD's own site, its under 2 weeks old,


Don't see any mention that you set mobo bios option to boot dedicated graphics card (initial dispay first?). And no monitor connected to mobo port.

Also 2 separate pcie cables from psu to card (not the 1 into 2 split).

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., G5 27in..
Journeyman III