Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Windows 10 RGB444 4K 60hz 10bits mode issue

Graphic Card:RX580

Radeon Driver:18.10.2

Monitor : BenQ EW3270u

Connection cable : DP 1.4 cable

OS:Win 10


               Radeon Driver 18.10.2

               In RGB444 / 4K / 60hz mode ,  I can't enable 10-bit color depth

               The AMD control panel can see the menu for 10 bit option , but select the 10 bit will get back to 8 bit after monitor blink out for a sec

               The windows 10 display information show the display mode still in 8 bits

               Radeon Driver 17.11.4

               In AMD control panel , select the 10 bit option also get back to 8 bit

               But , the windows 10 display information show the display mode in 10 bits


              Radeon Driver get some problem with 10 bit mode , this issue need to fix

86 Replies

I really don't know what information there is regarding the non-Pro graphics cards. My GPU and driver are the Pro and Enterprise versions, so I can't say, but I would bet there is some information in these forums that will help. The two versions of drivers seem to share parallel development, so I wouldn't give up hope. Just search for your version of driver and GPU and you'll likely find helpful information.


Changing to 60Hz in advanced Adapter Settings should fix it.

Answering more for other people to be able to find this.

I asked by PM and was informed that changing the Bit Rate to 8.1GHz (HBR3) is only available with workstation graphics cards and not with gamer cards.

(Reason I asked despite the existing fix: while 10bit is now fixed, choosing 12bit still behaves exactly like 10bit previously did. BENQ EW3270u/RX480/DisplayPort)


New member here desperate for some help. I’m using a 2018 MacBook Pro with a Vega 20 Pro running Windows 11 natively with no Bootcamp partition, using 23.9.3 Red drivers as those are the latest drivers that will install and work on my system. I have several computer monitors I use that output 4k 60hz full RGB 10bit no problem with this setup. But when I connect my Lg C3 OLED to my MBP, the best I can get is 4k 30hz RGB 4:4:4 8bit. I see in this thread you mentioned something about emulating EDID as a workaround. Would you be kind enough to possibly help guide me into emulating the EDID needed to get this tv to work at 4k 60hz RGB 444 10bit? I’ve spent over $200 in adapters and cables from Club3D, Cable Matters and Best Buy with no luck. I’m using certified HDMI 2.1 8k cable connected to the adapters. I’ve also tried using 8k USBC to HDMI active adapters with no luck. I greatly appreciate your time/help. This issue has been driving me nuts the past 5 days. 

PS/ I also forgot to mention I have tried messing with CRU, but no luck.


To better understand the problem, just take a look at these two screenshots for 4K@60Hz/10bpc/RGB444 configurations. One is by VESA standard reporting a Pixel Clock of 533.25 MHz and the other by DCI standard reporting a Pixel Clock of 594 MHz.4K_Pixel_Clock_Vesa.jpg4K_Pixel_Clock_DCI.jpg


check if this is set to 60Hz and not 59Hz.  see screenshot.


Journeyman III

I have same problem with 2400g Vega 11.

Mi TV is OLED c8

How can solution? :S



Fixed in 19.Q2 driver available on May 15th.


Just tested the 19.Q2 driver and it contains the fix


is possible link me new drivers?


Fixed in 19.Q2 driver available on May 15th. I cannot release the driver yet.

fsadough‌  I see that you managed a fix for the 10bpc bug,  however, your screenshot is of a Pro WX3100 GPU card,   Will the updated driver also fix the consumer type cards?  ie:  Vega's and R7's ???

Please advice,

Thank You in advance,


Yes it will

I installed the 19.5.1 drivers yesterday and it worked.  The 10bpc is enabled (vega 56) and I can fully utilize my monitor full potential (BenQ SW320).  Just need to re-calibrate it now.

Everything works great now and the new enabled colors look fantastic.

Big Big Thank You to fsadough‌  for his attention to this matter.10 Bit enabled.jpg

Some of the boards below are only supported in Win 10. Check the release notes when the driver is released. Radeon R7 is not supported.

Radeon RX 460 Series
Radeon RX 470 Series
Radeon RX 480 Series
Radeon 500 Series
Radeon 530 Series
Radeon 540 Series
Radeon 550 Series
Radeon 540X Series
Radeon 550X Series
Radeon 550 Series
Radeon RX 560 Series
Radeon RX 570 Series
Radeon RX 580 Series
Radeon RX 590 Series
Radeon RX Vega
Radeon VII
Radeon Pro Series
Radeon Pro Vega

Please disregard my previous message. Wrong post.


So the Next Adrenalin Update will have this Fix too?


Create a new thread of any new issue


This is encouraging news! Thank you fsadough! I'm looking forward to using it with my WX7100.

After the installation of Driver 19.Q2 my Benq SW271, connected with a WX 7100,  works perfectly at 4K UHD/10 bpc/60 hz/RGB 4:4:4 Full.

That's great to read! Glad for you! Enjoy.

Sadly, installing the same driver has bricked my machine. Win 10, WX3100, Benq EW3270U.

The only way I can recover it is to pull the card out and go back to the motherboard graphics. I have tried to remove the drivers, but putting the card back, it simply boots to a black screen. I hear the audio telling me Windows has booted, though...


That's really unfortunate! Hopefully others here may have insight into the issue and can offer helpful troubleshooting tips. It may be  helpful (if you want others to comment) to offer more technical details of your hardware and software setup, as you see in other posts. Just a suggestion.


Thanks. I recovered it, eventually. I had to do a full removal and cleanup of the AMD drivers, and it seems if I turn Radeon Pro Image Boost on, it goes back to 8 bit. If I force EDID emulation and up the clock to 8.1GHz, it goes black screen and I have to do a system restore...

Adept I

wx7100-19-2Q.pngwx7100-19-2Q-drivers.pngThanks to fsadough‌ & support team. BenQ PD3200U works perfectly at 4K UHD/10 bpc/60 hz/RGB 4:4:4 Full. Thanks very much.

Indeed, it appears to be fixed:


Journeyman III

I am using an AMD Ryzen G2400G connected through the 2.0b HDMI out on Asus TUF B450M-Pro Gaming to my LG OLED55B6V. Graphics is set to 3840x2160@60Hz and LG tv-set has HDMI Ultra HD Deep Color set to 'on' and the HDMI-input is configured to PC. Driver version is 19.5.2.

Only in 4:2:0 am I able to set a color depth of more than 8bpc (10 and 12bpc are available). Changing to 4:2:2, 4:4:4 or RGB results in 8bps being the only viable option (selecting anything else, reverts back to 8bpc). So same problem as the original poster even though I am using the latest driver.

It seems to me that the people reporting the issue as fixed, all use monitors (via DP cable..?) and not TV sets. fsadough's post from March 15, 2019 seems to indicate that the CEA extension block commonly used in TV sets with HDMI connections is the problem. Is that correct and is there a workaround for this and/or a solution coming?



  1. Please provide an EDID report using CRU 1.4.1
  2. I assume you are using an HDMI 2.0 cable, correct?
  3. How long is your HDMI cable?
  4. Please provide a screenshot like this:

I tried downloding the tool you mentioned, but wasn't sure how to use it.

Instead I hooked up my sons gaming computer to the TV (using the same input, cable etc.). His Radeon 580 was able to output 4K@60hz 4:2:2 in 10 as well as 12bcp without issues. He is on driver v22.19.677.257 (Microsoft).

It seems the limitation is on my new AMD Ryzen 5 2400G or the Asus B450 motherboard...?


EDIT: I tried using the program Monitor Asset Manager. It seems like there is quite a difference between the amount of information the program reads directly from the monitor vs. what it reads from Windows' registry. I have attached the two reports. Note: the reports were generated from the Asus B450/AMD G2400 - not my son's gaming PC.


Feeling late to the party, but that OLED tv from LG you have looks like it's had several software updates,.. have you gone to the LG support site to see this? Maybe updated the TV software ( or does this do it on it's own )? These are rather large files by the way.


Thanks, but the TV is set to update its firmware automatically and runs the latest version.

Again, I was able to run my son’s gaming PC AT 4K@60hz HDR 4:2:2 10bpc, so I take it I can assume neither the cable nor the TV is the reason why I can’t do the same on my AMD 2400G HTPC. 


I see people are throwing around custom timing information. Since you have a working reference setup through the rx580 running at the resolution and color space signals you want, it might be possible to glean the resolution timings from it and then try to replicate those timings from the 580 signal in the timings for the 2400g as a custom resolution.

I haven't read everything here, but this may be a viable source. Otherwise I tend to agree, maybe a board issue.

Adept I

I'm having the issue also. Vega 56 on a Sony A1E using HDMI Cable (HDC-BR100P) Get weird issues with hz readings. Fixed it by deleting "TV Resolutions" in the Data Block but also cause other weird quirks.




We do not have enough bandwidth to do 594MHz pixel clock


It is my understanding that 4K@60hz 4:2:2 12 bit is supported under the HDMI 2.0 specifications, and hence I would expect my AMD 2400G to be able to deliver this in Win10, provided my HDMI-cable supports 18Gbps and the display (LG OLED B6V) is set correctly (PC icon, deep color setting etc.). 

Not sure what pixel clock is, but it sounds like it is one more determinant in calculating required bandwith between GPU and tv/monitor. If I understand you correctly, a pixel clock of 594MHz is also the reason many users see 4K@60hz 4:2:2 12 bit defaulting back to 8 bit when using an HDMI-connection.

Assuming my understanding is correct, what is the pixel clock "assumed" in the HDMI 2.0 specs, when it says 4K@60hz 4:2:2 12 bit is supported? Is it possible to lower the pixel clock (and how?), and what are the trade offs?

Not sure if I am asking the right questions....


Please provide an AMDZ Report
- Please extract the file which you can download from
- Run amdz.exe file as an Administrator
- Select “Save All“ and “HTM“ as the output format
- Click on the blue button to save the report
- The .htm file will be saved in the same folder where you extracted the zipped file



The download link no longer works. Could you post another one?

Meanwhile, I thought I would post the Adrenalin-screen dump you asked for and a CRU1.4.1 screen dump as well. Not sure if the latter is the report you asked for...

2019-06-13 (1).png

2019-06-13 (2).png



Thanks, report attached.


I need more understanding to your one sentence response. I have never heard of a bandwidth issue regarding the pixel clock. If this is the case YOU (AMD) need more advertised specs to your components. I bought an 2017 Sony A1, vega56/64, new cpu, new HDMI 18mbps+ cable for your hardware just to STILL be incompatible for ATLEAST non-HDR proper 4k true color at a petty 60hz. Get freaking real, dude. Unbelievable.