Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Windows 10 RGB444 4K 60hz 10bits mode issue

Graphic Card:RX580

Radeon Driver:18.10.2

Monitor : BenQ EW3270u

Connection cable : DP 1.4 cable

OS:Win 10


               Radeon Driver 18.10.2

               In RGB444 / 4K / 60hz mode ,  I can't enable 10-bit color depth

               The AMD control panel can see the menu for 10 bit option , but select the 10 bit will get back to 8 bit after monitor blink out for a sec

               The windows 10 display information show the display mode still in 8 bits

               Radeon Driver 17.11.4

               In AMD control panel , select the 10 bit option also get back to 8 bit

               But , the windows 10 display information show the display mode in 10 bits


              Radeon Driver get some problem with 10 bit mode , this issue need to fix

86 Replies
Adept I

I have same issue with the card reverting back to 8 bit on the BenQ ew3270u 4k display
here is my setup
Graphic Card: WX 5100

Radeon driver: 10.Q3.1 Enterprise Edition
Connection: DP 1.4
OS: Windows10 Oct 2018 update
Monitors: 4x BenQ GW2765 @ 2560x1440 10bit 
               1x BenQ EW270u @ 2160x3840 4k

the strange thing is that the 4 benq gw2765's are all running in 10bit mode, only the 4k monitor is in 8 bit. as the OP stated, I can select 10bit in the AMD settings but it just flashes the screen and then reverts back to 8bit. I did notice that if I enable HDR in the windows settings for that monitor, I can then choose 10bit without I treverting. however, this is not ideal since I am normally working desktop applications that look washed out in HDR, I only switch to HDR if I want to view media. I should be able to run the monitor in non-HDR mode AND 10bit

Journeyman III

Same issue with all Amd card i have.

Graphic Card: RX550 ,RX580, RX Vega56

Radeon driver: 18.8.2 ,18.9.3, 18.10.2
Connection: Lindy DP 1.4
OS: Windows10 1803 and 1809
Monitors: BenQ EW270u @ 2160x3840 4k

                 LG 27UD69-W @ 2160x3840 4k

Only @YCbCr422 or @30Hz can switch to 10bit.

But another can easily get 4K 10bit RGB444.

Journeyman III

I have same issue too.

Graphic Card: RX Vega56

Monitors: BenQ EW3270u @ 2160x3840 4k

Radeon driver: 18.10.1 , 18.10.2
Connection: DP 1.4
OS: Windows10 1803

Unless it is set to YCbCr422, can not operate at 10bit/60Hz.

The value of "Current Link Settings" also does not reach the maximum bandwidth of DP1.4.

5.4Gbps is for DP1.2.



I too have the same problem (differs from op that win10 actually shows 8bit/sdr, same as in driver)

Graphic Card:RX590

Radeon Driver:18.12.1

Monitor : BenQ EW3270u

Connection cable : DP 1.4 cable

OS:Win 10

As mentioned above, reducing the sampling or refresh rate, allows 10bit.

(I also see the 5.4Gbps x 4 in Adrenaline, but it's definitely a DP1.4 cable...)

I wonder if this is AMD, BenQ or the cable's fault...

Adept I

I also have the same problem. When i select 4k 60 Hz 10 bit for RGB 4:4:4 it reverts back to 8 bit after flashing.

Graphic Card:Vega 64

Radeon Driver:18.12.1

Monitor : BenQ EW3270u

Connection cable : DP 1.4 cable

OS:Win 10

Adept I


Graphic Card: RX480

Radeon Driver:18.12.3

Monitor : BenQ EW3270u

Connection cable : DP 1.4 cable

OS:Win 10

Same as OP. I have tried using another DP cable but the issue still persist. Goes black and back to 8-Bit.

Someone on Reddit (New Benq EW3270U monitor having trouble outputting 10 bit depth. : Monitors ) actually managed to output 10-Bit

and is using DP 1.4:


So how come someone not even using AMD drivers can output 10-Bit while we cannot?
Can anyone please help us here? Did anyone solve it yet?


I have not found a resolution yet. I have tried multiple displayport cords to make sure it was not the issue. It did not make a difference. It then tested the monitor and cable using a friend's NVIDIA card, and it worked as you stated. This seems like an AMD driver issue and they clearly need to fix it.


Yeah same here, tried two more 1.4 displayport cables and still no luck. OP in that Reddit Thread also got it working, so with you it makes 3 instances.

I even tried RadeonMod and enabled 10-Bit but that gave me a black screen, so I had to go back to Safe Mode to deactivate it.

Would someone at AMD look into this for us?

Journeyman III

Same Porblem.

OS: Win10 1809

Driver: 19.1.1

Lindy DP 1.4 cable

Benq 3270U With Asus RX580



Adept III

Same problem and same behavior with BENQ SW271 and Radeon Pro WX7100. The italian Benq Support told me that it was a problem of my monitor so I sent back the display to the seller with the idea to reorder it but, after this list of 'me too', i will wait.

My setup is Windows 10 1809 and, at the moment of the availability of the Benq SW271, driver 18.Q4. I use a RADEON PRO product to obtain the support of 10 bit workflow with Adobe Photoshop.

Actually I use an ASUS PA249Q in 10 bit mode.

Adept I

Graphic Card:RX580

Radeon Driver:win10-64bit-radeon-software-adrenalin-edition-18.3.1-march5

Monitor : BenQ PD3200U

Connection cable : DP 1.4 cable

OS:Win 10 1803

This Version it's can be use 10bit RGB444,please try it.

share my Unmodified drivers file:

win10-64bit-radeon-software-adrenalin-edition-18.3.1-march5.exe - Google Drive 

enjoy,have fun.


I downloaded the 18.3.1 driver from amd driver website.

Radeon™ Software Adrenalin Edition 18.3.1 Release Notes | AMD 

Looks to me the same driver and I wanted to get it from an official source.

It did not fix the issue though. I still could only get 8 bit RGB444. The only way i can get 10 bit is with YCbCr422.

Anyone else have any luck with that driver version?


do you try "DDU" software thoroughly clean up the old drivers,maybe can solve the problem.(Best in windows safe mode)

Attach a screenshot of my system:





Tried the 18.3.1 drivers from the official AMD Site and nothing. However @Danceking doesn't even have the BenQ EW3270U. If you look up his screenshots it says PD3200U - 2 different monitors.

In fact, my main point is to try to get an older driver to get 10bit_60Hz.
Although the two monitors are different, the official data verification supports 10bit_60Hz.
So everyone can try older drivers, although there are a small amount of performance loss, but depending on 10bit is more important.

Ps: my English is not good, use Google

Adept I

I just install 19.1Q drivers (launched several days ago) and I can't get 10 bits with this configuration (with older drivers 10 bits color was also unvailable):

AMD Radeon WX7100

Benq PD3200U

DisplayPort - MiniDisplayPort 1.4

60 Hz

I am very confused... I need 10 bits color for Adobe Creative Cloud apps.

If I set same configuration with 30 Hz, color 10 bits (10 bpc) is available. Why happen this? I don't know. If anybody have an awnser, it is more than welcome.



Today I tried this configuration:

AMD Radeon WX7100

Benq PD3200U

DisplayPort - MiniDisplayPort 1.4

60 Hz

Pixel Format: YCbCr 4:2:2

And I get 10 bit color.

But I want RGB 4:4:4 Full RGB... is it a driver issue or not?

19.2.2 initial clean install on my computer picked 3840x2160 59hz for my Monoprice 32in 4K IPS panel causing bit rate to go from 10 to 8

Selected the correct mode in Windows10>Start>Settings<Display>Advanced Display Settings>Display adapter properties for Display>List All Modes fixes the problem for me and 10bit 4:4:4 Full RGB is what Radeon Display Panel shows after the change:

Thanks... but this way in my graphic card+monitor, the 10 bits color doesn't work . I hope this was a driver issue than Adobe can fix with futures version of drivers...

Adept I

Well... I dont suffer alone, then. LOL.

Thanks billy72‌.

Hi pppm,

No you don't suffer alone. I have the same problem as you do. I started the first thread hyperlinked in the post from billy72 over a year ago. Since then I have been told by an AMD engineer (in my linked thread above) that my problem is that  my monitor is telling my WX5100 graphics card that it cannot display 10 bpc (the engineer (an FAE) looked at the EDID data from both of my monitors). I have 2 BenQ SW320 monitors.

One difficulty that I have is that this explanation doesn't seem to square with all the facts. For example I can get 10 bpc to work under 2 conditions:

1) reduce the monitor refresh rate to 30 Hz, and

2) change the Pixel Format to YCbCr 4:2:2.

Neither of these solutions is desirable in a creative (photography, graphic arts) workflow! If my EDIDs are saying the monitors are not capable of 10 bpc, how is it possible that the monitors displayed 10 bpc? Maybe the engineer would say this: the EDID says it's capable of 10 bpc at the settings above. But skip down a paragraph.

A second difficulty that I have is that AMD support will suggest these work-rounds as solutions -- although they are really work-rounds, not solutions -- rather than helping me to find out what is not working properly with hardware that is advertised to support 10 bpc 4K@60Hz, whether it is an AMD issue or not. AMD support never even acknowledge that the lower level of performance they are recommending is less than the capability of the graphics card, which is basically ignoring the reason that I bought the card, and wasting an opportunity to help me determine what else in my system configuration may be preventing me from utilizing the maximum capabilities of the card. Instead they offer options that leave me with crippled performance without disclosing that the performance that I'll get with their recommendation will be reduced!

There is also a third way that I got 10 bpc to work, but it was using an older version of the Radeon Pro Enterprise driver. It was early in my effort, which has turned out to be a year of troubleshooting, and I lost track of the version of the driver that worked, so going back to it is problematic. It is also interesting to note that since an older version of the Radeon Pro driver worked at 10 bpc 4K@60Hz, how is that possible if two monitor's EDIDs are reporting to the WX5100 that they cannot support 10 bpc 4K@60Hz? Clearly I don't have the whole story.

In my troubleshooting, an FAE (field application engineer) told me that 10-bit format has nothing to do with 10 bpc color depth. And I also found a document, apparently from AMD, that attempts to explain their confusing 10-bit references in this document: AMD’s 10-bit Video Output Technology. But this document didn't really make it clear that they are unrelated. In addition, there appear to be customers here who believe the recent fix 19.Q1.1 fixed their 10-bit issues. This points to a third difficulty I have -- there is no manual that accompanies the card or drivers that explains the many settings to non-FAEs (or laymen) adequately, so many of us are wading through this quagmire confused by the usage of terms like "10-bit" and ignorant of what the settings in the driver are intended to do, and where there might be settings that interact. So the very slow and potentially erroneous trial and error approach appears to be the only option toward resolving the issue.

I have noticed that there are a number of customers here who have this same exact problem, who also have BenQ monitors: SW320 (mine - I have 2), PD3200U (yours), ew3270u (2 different customers have these), and maybe others that I have missed. I checked the DisplaySpecifications web site and all of these BenQ monitors are listed as 10 bpc (30-bit) capable displays. Then there are those customers who have the same problem, but don't have BenQ monitors, such as AOC AG273QCX, a Dell monitor (customer didn't mention model) and perhaps others. I know less about them except that the AOC monitor is listed as an 8-bit panel, which might be the issue with it.

And the last difficulty that I have is the deafening silence from any official AMD representative to give some kind of useful aid to help us solve this nagging problem which has gone on for more than a year (at least for me). This is surprising from a company who has competition.

So the question that comes to mind to me is which is more likely? All of these BenQ monitors -- different models, different lots, presumably purchased from different dealers have the exact same problem with them, or the AMD driver has a problem with it? Note: by the way, Club3D has VESA certified DisplayPort cables on Amazon. Don't know if this will help (it didn't help me), but it rules out one more potential issue.

I have a case in with BenQ, but they have been even worse to respond to this issue. It has been 20 days and they still have not assigned anyone to work on my case. If anyone has the key to getting a quick response from BenQ, please let me know. I did see where one customer got a response where they told the customer to reduce the monitor refresh rate, but I believe it was a monitor where 60Hz should work.

I have been buying ATI, and now AMD video graphics cards for something like 20 years. What kind of company treats loyal customers this way?

Finally got a response from BenQ. Apparently my ticket was placed in “pending” status for unexplained reason, but now is being passed on to the development team. But the initial response to the issue was “there might be an issue with the panel itself, as 10 bit is passive and directed by the GPU.”. This seems to be in conflict with what the engineer at AMD told me about how the GPU uses EDID. I guess I’ll find out.

I fully understand your frustration and I can assure you that we are very much interested to solve the issues reported as long as they are AMD related. AMD is quite strict with VESA standards. That, I cannot change. Do cable manufacturer follow VESA standards? Do monitor manufacturer follow VESA standards? I don't know and we have no means to force them.

Also the issues that are reported here could be OS related, the way 10bpc is being interpreted is also an OS issue and not only a  driver issue. There are plenty of information on the web regarding 10bpc and 10bit pixel format and the difference between them. Also information related to EDID and how it works.

True, we might have a bug in our driver and if so, we will investigate. I have shown in numerous screenshots that my Iiyama 4K@60Hz monitor is fully capable of supporting 10bpc@RGB4:4:4. I have also received the EDIDs of BenQ SW320 & SW271 from another user and once I emulate the SW271 on my system, I can get 10bpc@RGB4:4:4 but not on SW320. It is on the same OS, same AMD driver. Why would SW271 exhibit 10bpc and not the SW320? So, what does it tell you? See my screenshot below. 

I am still investigating the issue and will try older driver 17.50, as one user claimed the older driver worked for him, although on a Vega FE card. One other thing that we can try is to get the latest Video BIOS for your GPU, just to be on the same page. For that I need to know which version is installed. You can see from my screenshot, where to find it. Also the complete OS version is very important.



Thanks for digging into this. Would you be able to do the same for my situation (AOC AG273QCX)?

I'll provide whatever info you want - EDID, video BIOS dump, etc. if you just tell me what tools to run and what to dump.  I've seen several of your posts elsewhere but haven't read through everything yet.


Hi mudkips.

I don’t know if this is helpful or not, but earlier I looked up several monitors of folks having trouble with 10 bpc here in this community to see if there was some commonality, especially the BenQ monitors. I think I found yours, but not sure. If so, it was listed as an 8-bit panel without FRC (I believe this is a technique that can be used to allow 8-bit monitors to simulate 10-bits). Take a look at the link to see for yourself. AOC AG273QCX Hope you find this helpful.


It's 8 bit plus FRC. It accepts 10bpc signals just fine when under the DP 1.2 bandwidth limit.


Please provide me with your EDID. That is all I need. However I am not sure if you saw my comment in the other thread. We have identified a different behaviour of 19.Q1.1 driver vs 18.Q1.1 with some BenQ monitors. I have created an internal ticket for our display team and the issue is being investigated. 


Do I just grab this from the registry?  Or should I use something like NirSoft DumpEDID?

I've actually decided to return the monitor (primarily because AOC support is very, very underwhelming (it took them weeks to send me a manual for the thing, the page website has incorrect specs listed, the driver link points to a driver for a different monitor, etc. etc.).

I'll be swapping it out later today.  I'll still provide the EDID though, in the hopes that it can help someone else or help AMD figure out if there's some pattern with different displays.


From registry:


From NirSoft's DumpEDID (if this is accurate as to what the monitor's putting out, then wow):

DumpEDID v1.07

Copyright (c) 2006 - 2018 Nir Sofer

Web site:


Active                   : Yes

Registry Key             : DISPLAY\AOC2730\5&2fec0a7a&2&UID256

Monitor Name             : AG273QS4R4

Manufacture Week         : 49 / 2018

ManufacturerID           : 58117 (0xE305)

ProductID                : 10032 (0x2730)

Serial Number (Numeric)  : 465 (0x000001D1)

EDID Version             : 1.4

Display Gamma            : 2.20

Vertical Frequency       : 48 - 144 Hz

Horizontal Frequency     : 230 - 230 KHz

Image Size               : 59.7 X 33.6 cm (27.0 Inch)

Maximum Image Size       : 60 X 34 cm (27.2 Inch)

Maximum Resolution       : 2560 X 1440

Support Standby Mode     : No

Support Suspend Mode     : No

Support Low-Power Mode   : Yes

Support Default GTF      : Yes

Digital                  : Yes

Supported Display Modes  :

     720 X  400  70 Hz

     640 X  480  60 Hz

     640 X  480  67 Hz

     640 X  480  72 Hz

     640 X  480  75 Hz

     640 X  480  100 Hz

     640 X  480  120 Hz

     800 X  600  56 Hz

     800 X  600  60 Hz

     800 X  600  72 Hz

     800 X  600  75 Hz

     800 X  600  100 Hz

     800 X  600  120 Hz

     832 X  624  75 Hz

    1024 X  768  60 Hz

    1024 X  768  70 Hz

    1024 X  768  75 Hz

    1024 X  768  100 Hz

    1024 X  768  120 Hz

    1280 X 1024  60 Hz

    1280 X 1024  75 Hz

    1920 X 1080  60 Hz

    2560 X 1440  60 Hz


Again, this is an AOC AG273QCX (despite it being identified as AG273QS4R4), and it DOES work at 10bpc at 2560x1440@120 Hz, and DOES work at 8bpc at 2560x1440@144 Hz, but not 10bpc @ 144 Hz (unless I  switch to 4:2:2).

And again, it's going back to Amazon, but I'm providing the info in case it can be of use to others / AMD.


Thank you for your extensive reply and continued effort. I appreciate what you’re doing to help. Any frustration I have is with the issue and the nature of the resolution process, and not with you personally. I understand that you are Sr. FAE and that troubleshooting this issue is not your primary responsibility. So thank you for offering your help! 

As you suggested, the issue is complex. I understand. There are many parts that theoretically can contribute to the problem, including combinations of: OS capability, OS configuration, cable type and certification, monitor capability and configuration, monitor firmware, GPU drivers, GPU BIOS, GPU driver settings, application compatibility, testing methods and probably more.  It’s clearly not simple. And without customer advocacy, my only option is to solve the problem by trial and error working with each vendor — a slow process that is not foolproof. So thank you for taking a step or two beyond your duties to help me. Sincerely. I have learned much from you.

I have gathered most of the info you mention above and will post it later this evening. 


I collected the information for my displays when running in 10 bpc (YCbCr 4:2:2) and when running in 8 bpc (RGB 4:4:4)

Running at 10 bpc YCbCr 4:2:2 mode


While running in 8 bpc mode, RGB 4:4:4


Adept I

I have the same issue under Windows 7 using 2 RX 470 GPUs in CrossFire and a single AOC AG273QCX display.

I should be able to run 2560x1440 @ 144 Hz and 10 bpc.  However, I can only run 2560x1440 @ 144 Hz and 8 bpc or 2560x1440 @ 120 Hz and 10 bpc.  It seems as if it's stuck on DP 1.2, and Radeon Settings shows 4 lanes of HBR2 (5.4 Gbps) being used.  DP 1.3 and 1.4 should be on HBR3, which should have plenty of bandwidth for 2560x1440 @ 144 Hz and 10 bpc.

Adept II

Hey, folks. I just stumbled upon this thread, I got the Benq PD3200U yesterday, combined with Vega 64, and I'm unable to output 10 bit 4:4:4, it just reverts back to 8bit after trying to select it. However, I'm also using beside it its predecessor, BL3201PT, which is also a 10bit panel (8bit+FRC), and in there 10bit works without any issues at 4:4:4. I'll post driver screenshots when I get back home soon.

I tried the mini DP cable that was shipped with it, the DP cable I just bought today, and the DP I used so far with my previous panel, nothing helped. I'm on Windows 10, and the 19.2.3 driver. Older BL3201PT also, surprisingly, supports Freesync (48-60Hz), but PD3200U doesn't offer it, and I hoped since its pretty much the same AU Optronics panel inside. Maybe its related...

Edit: here's the pic.


Fixed in 19.Q2 driver available on May 8th.

Root cause:

Whenever a monitor has a CEA extension block with a CEA SVD for 3840x2160@60Hz the current and some previous drivers (except 18.Q1.1 and older) use 594MHz pixel clock and for that we do not have enough bandwidth to do 10bpc, that's why the color depth jumps back to 8bpc. Obviously the monitors without the above mentioned CEA extension block did not have any issues reporting 10bpc/RGB444/4K@60Hz

CEA extension block with a CEA SVD is mostly used for digital TVs & HDMI connections

Interim Workaround:

Emulate the EDID of your monitor with a Bit Rate of 8.1 GHz, that might work for some monitors. If you need assistance with that, PM me.


BenQ EW3270 still reports 594MHz, which seems to be a monitor issue (still under investigation). However changing the Bit Rate to 8.1GHz (HBR3) resolves the issue.

Thx for the response. Looking forward for May then.


Since my monitor is a BenQ EW3270, do you mind telling us how to change the bitrate or shall we wait for the patch?

That's actually the very first real response I read that has a possible solution to it.

Really appreciate what you're doing for us!


tbsteel‌ I don’t know your troubles, but I saw that you have a BenQ monitor. If you’re trying to get 10 bpc to work, you might find another thread in this community helpful. Try going to the bottom of this thread How do you get the WX 5100 to use 10-bit? In short, using an older Enterprise driver, 18.Q1 (Feb 2018), I was able to get 10 bpc, 4K@60Hz. One other user, m0reilly‌, tipped me off to this. Although my monitor is BenQ SW320, it may work for you as well. But there may be other issues with the driver for you since it is old. See the bottom of the linked thread.

I have the same BenQ EW3270U Monitor that is connected through a DP 1.4 Cable but i am using a non Pro graphicscard the Vega 64 so i cant use a Pro driver (at least not that i am aware of).

I changed to 60Hz in the advanced Adapter Setting, still no luck. Are there any news regarding this for Consumer Cards?