Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Windows 10 gets corrupted while installing AMD GPU Drivers

So last night I removed my GTX 1060 and installed my new ASUS Vega 64. I just booted back into Windows and installed the AMD Radeon drivers from AMD's website. While updating the drivers my screen turned black for a little (that doesn't raise any alarms obviously). But it stayed black and after a while my PC just shut down. When I rebooted back into Windows my pc got stuck at the Windows starting screen (scanning and repairing drive D: 100%). Then I booted into Safe Mode, backed up all my important data, formatted my drive and installed a fresh installation of Windows 10, only to have the same problem again. I also tried DDU'ing my drivers but to no avail.

How can I get my Graphics drivers installed without corrupting my PC?VEGA 64.PNG

14 Replies

Could you write your CPU and PSU?


Running a Ryzen 7 1700 on my MSI X370 GAMING PLUS powered by a Corsair VS650 


Whichever version of Windows or whichever driver with OS compatible you use. The problem you are experiencing is usually hardware related. You should try the graphics card on another system. Your power supply is sufficient. But how much? You need to know that.


EDIT*Almost forgot,make sure all windows updates are done before this.

You are going to here:  

Picking your drivers as this Pic shows


Pick Windows 10,download then doing a manual "custom" and "clean install"

Thanks you very much


And to add to that two things. One is make sure you're using Windows 10 1903 as it is quite stable, and two is to use the last WHQL driver release instead of the optional to rule out a one in a billion conflict of some sort.

I did exactly this on Windows 10 1903 but to no avail. 


Thank you for sharing this amazing idea, really appreciates your post. 


While doing a clean install may help it also may not delete all prior drivers. The AMD clean install only deletes drivers installed by AMD, not AMD drivers installed by Windows AMD Repository drivers. That is what happens, you are installing the driver and and Windows Update is interfering trying to install it's driver at the same time.

So if that doesn't work for you, download DDU from Wagnardsoft_com and run it from safe mode, it will delete any and all GPU drivers, leftovers of AMD, AMD repository, Nvidia leftovers you name it and leave you with a clean slate.

Then with the internet disabled re-install the AMD DRIVER. The internet being off will keep Windows Update from interfering and messing up the install again.

Good Luck!

I meant to add that if you didn't disable the internet before when doing DDU, that may be why you didn't have good luck. You can also go to services and disable Windows Update temporarily while you install to be sure.

Adept I

i got also problem i can instal only 19.3.1 version of drivers ,the new doesne work at all .I got  low resolutions whic cant be changed .the resolution is on grey color .and cant be changed .I have tried uninstall it with ddu and instal again but alweys the same problem.


It certainly can be that these new drivers are just hosed. I honestly have not tried them. I am in the camp of if they are working right for me I don't update anymore. It seems for every one thing that might get fixed one or more other things are broken. You never need to update a driver, unless you NEED to update a driver like something doesn't work and that new driver says it fixes it or an OS update for instance requires it. Make sure to ASK AMD FOR HELP: 

Sorry you all are having this trouble. I know how frustrating it is to have things not work.

When you all do find a solution please do reply back with what worked, it helps the community.



Why is Windows repairing Drive D: and not the Windows Drive C:? 

If you have two internal Drives connected, Drive C: (Windows) and Drive D: and D: is being repaired maybe for troubleshooting purposes you can physically disconnect Drive D (Temporarily) and see if Windows boots up. In case Drive D: is defective.

Since your computer worked with a GTX 1060 and not the RX Vega 64 it could indicate a PSU Power issue.

The GTX1060 only requires a minimum PSU wattage of 450 watts to run your computer system while the RX Vega 64 requires a minimum PSU Wattage of 700 watts to run your computer system.: PSU REQUIREMENTS - RealHardTechX  plus with the Ryzen Processor with a TDP of 65 Watts put even a slightly heavier load on the PSU.

If your RX Vega 64 is a Liquid cooled edition it requires an even more minimal powerful PSU of 900 Watts.

Plus you PSU is a "WHITE" rated PSU which is normally below one of the Metal rated PSU (Platinum, Gold, Silver, or Bronze) as far as efficiency goes. It is possible your PSU is not able to supply proper voltage to the RX Vega 64. 

Also make sure that both 8 Pin GPU Power connectors uses two separate PSU GPU Power cables instead of one cable with two 8 pin GPU Power connectors.

Adept I

I had this same issue. I fixed it by running an sfc scannow command in an elevated command prompt, then running a DSIM repair health, followed by one last sfc scannow. If it is the same issue the first sfc scan will say there are corrupt files but that they cant be fixed. Then the DSIM will fix that, The last sfc scannow should yield the result of no errors. 

Hope this helps, I wish I had this when I wanted to smash my face into a brick wall.