Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Windows 10 DRIVER_IRQL_NOT_LESS_OR_EQUAL (rtwlane.sys) blue screen error, Constant crashes!

I just built a custom PC about 3 months ago with AMD parts.  I have been getting blue screened for the past few months since I built the PC.  It happens when I keep the computer on for a few hours.  The error is this:

Windows 10 DRIVER_IRQL_NOT_LESS_OR_EQUAL (rtwlane.sys)

I have searched all over for solutions but haven't found anything yet.  I keep reading it is my network card.  I'm using a TP-link 300mbps adapter.  All the drivers are up to date.  I don't have a realtek driver in my network adapters list in the device manager.  I'm not sure how to solve this and I want to make sure my PC doesn't die early because I can't fix this issue. 

Any help would be greatly appreciated as I am learning more and more about PC building.

17 Replies
Journeyman III


I have this problem that happens frequently when im working and i haven't found a solution for this problem hope you can help me.

This error started when i reinstalled the windows 10 pls click on link and get solution

Windows 10 DRIVER_IRQL_NOT_LESS_OR_EQUAL (rtwlane.sys) blue - Microsoft Community

If the previous steps have not been understood and if the problem is not solved then click on the link below,

follow the steps in this simplest method in these posts and repair your own PC Using DIY steps. It has helped me. plz try once i hope get solution.

thank you.

Adept III

Most likely Driver issue!!! Do a clean boot or boot into safe mode to see error message come back or not......


Hi,  I've searched all over the internet and just about every one of the forums said it's the "realtek" network adapter.  I don't have a realtek network adapter listed.  I've gone and updated every driver I have and everything is up to date.  I'm really not sure if I have to download anything new.  I even uninstalled all the drivers and reintalled and still got blue screened with the same error. 

BTW, I am using a TP-link 300mbps network card. 


If you have any suggestions I'd really like that.

Thank you so far!!


Run a file search for 'rtwlane', you may find some similar to

May be related to mobo drivers, ask on their(your make) forum ?. Somewhere to start.

If no luck there, try

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., G5 27in..

I just did a windows re-install.  Hopefully this will help.  I'll keep you posted if I come across the error again.  Thanks for your help so far!!


If this was working fine and now isn't I would suggest you try returning to previous restore point with a date during the time frame you know it was working.


It happened a few weeks into my building the PC.  I'm not sure if it ever was a good point.


It can be very frustrating dealing with IRQ issues. Something you could do to free up and hopefully get Windows to reasign the IRQs is to free disable some items likely using IRQs you don't need. In your bios disable all com ports, serial, parallel etc. whatever it shows. This will leave a couple not shared. Then go to device manager and uninstall your video card and reboot. Then do this for other devices if that didn't fix it. Try the same with sound, network etc.


At TP-Link I see two products that seems to be what you have. One is a USB with a 2018 driver and the other a PCI internal Card with a 2011 Driver.

Which TP-Link are you using the USB or PCI Card?

If you are using the PCI Card it is possible it is not compatible with Windows 10. Download for TL-WN851ND | TP-Link

Where as the USB Dongle would be compatible with Windows 10: Download for TL-WN823N | TP-Link

Also I notice you have an Intel Network Driver. You might want to download and use Intel Driver and Support Assist to update all of your Intel Motherboard Drivers including the Network Driver.


So I just re-installed Windows 10 and doing that got rid of the exess stuff in the network adapters list.  This is what I have now.  Also, I'm using a PCI card.  I checked for an update and it said the driver was up to date.  I built my PC with AMD parts so IDK why I have an intel product showing on my machine lol.  I kept it in there for now.  This is what I have now after the re-install.  BTW, that link for the network card isnt for Windows 10.



Much of the time even when a manufacturer doesn't offer a driver version for older hardware, but Windows loads one from it's repository you should be good to go. This means that MS either adjusted the driver supplied to the previously or already worked as is. Most hardware makers including AMD stop supporting their products. Frankly they just want to sell you new stuff and can't spend resource supporting old stuff no longer making them money. As much of a black eye Microsoft gets at times, they actually do a tremendous job keeping old hardware viable if they can. Don't ever, IMHO try to replace a driver that Windows installed for a device that seems to be working with a manufacturers driver that doesn't claim current OS support. That would be a last option if it is not working only. That device manager list looks pretty clean now. The intel adapter is likely installed on the motherboard, IE it came with it. This is not uncommon. The OEM can use network components from anyone they want even on a board that supports AMD cpus. The TP link is wireless only so those are 2 different things.


Thanks so much for that great response and great info dude. 

I did a re install of windows and have been using it all weekend and haven't had a blue screen yet so so far everything is good. 

IDK why there was all that junk installed under my network devices.  It must have been auto installed by one of my software I installed to help monitor my computer.  Now I only have the two in the most recent attachment.  I'll keep you guys all posted if anything happens.

I was guessing since you never mentioned the exact TP-Link you were using. The PCI version is obsolete and doesn't have any Windows 10 drivers from the manufacturer. Thus you need to allow Windows Update to install a compatible Driver for your PCI TP-Link card as per pokester​ comment when he mentioned about old hardware being still used in Windows 10.

Adept III

I'm having the same problem, but only when ReLive is on

Adept I

I had the same problem a few days ago.  I would suggest to restore your Bios settings and to do a clean install of your windows at my belief this is caused by a malware. I hope this could help you.


uninstall AMD Driver...………..

Adept II

I am getting this exact same issue. This has started happening in the last few days.Try this, hope it works:The easiest method try to  Safe Mode is from the Windows OS.For more information about windows 10 blue screen error, please check this article.