cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

mat777
Challenger

Will there be a new amd driver update to support Windows 10 v1809?

  Windows 10 v1809 (October update) will there be a new driver for the new update ?? I am downloading the new update today

Message was edited by: Matt B

Edit title

0 Likes
19 Replies
georges
Challenger

Maybe this week ..

0 Likes
goodplay
MVP

Maybe/maybe not until official rollout.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 7000s 2tb, Nitro+RX6900XT, RM850, Win.10 Pro..
0 Likes

Microsoft pulled a fast one and is allowing the official October 2018 update to download starting today. Microsoft skips over Release Preview and drops the Windows 10 October 2018 Update - Neowin

Just went to the Microsoft download page and it has the new October 2018 to download via Creation Media tool or upgrade directly from online: Download Windows 10

I see/read that the 1809 download has been removed (back to 1803 download), from your download link.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 7000s 2tb, Nitro+RX6900XT, RM850, Win.10 Pro..
0 Likes

That link is the official Microsoft Windows download page.

Why they changed it back to April 2018 update I have no idea.  Probably Microsoft will explain why they reverted back to the previous Windows installation from the October 2018 download

It is possible Microsoft will make October available again on Patch Tuesday on the 9th of this month. If not, then Microsoft will hopefully explain why. Maybe some unknown issue popped up after Oct 2 download and decided to take it off the market again until they fix it.

0 Likes

pastedImage_0.png

0 Likes

Thanks that explains why Microsoft stopped the Official update from its website.

kingfish​ gives a much better explanation as to why Microsoft stopped the Official Update download from General Discussion : Users are Reporting Lost Data After Installing Windows 10 October 2018 Update

0 Likes

It's official I get the update from Windows Update

0 Likes
codexllll
Adept II

Installed it (clean install) and getting an OS crash when installing the AMD 18.10.0830 chipset driver.

Reformatted and re-clean-installed build 1809 twice with the same result.

Crash is SYSTEM_THREAD_EXCEPTION_NOT_HANDLED in amdpsp.sys.

I reformatted and clean installed build 1803 and the crash does not happen.

0 Likes

I also got this crash (upgrade from 1803).

After the upgrade my crossfire is not working anymore. (2x Fury X)

0 Likes

If anyone has a potential solution I'd be happy to hear it. It crashes, and after rebooting if I attempt to install the driver it crashes again. There's no way to install the chipset driver without crashing the OS, so I'm stuck with having to use Windows 10 1809 with a bunch of devices with no driver installed, as seen by a yellow exclamation mark in the device manager.

0 Likes

Interesting. If I let Windows install the drivers (which normally is one of the first things I disable), trying to install the driver from the Device Manager leads to Windows attempting to install the driver from its driver store, and it then crashes the OS with the exact same error in amdpsp.sys. Not too surprising though seeing how amdpsp.sys from Windows is exactly the same version and digital signature as the one in the AMD 18.10.0830 chipset driver package.

The only partial workaround I found is to delete the amdpsp  and amdpsp_svr folders from the driver package prior to install. This way, every other component of the chipset driver installs as expected, resulting in only two devices (as opposed to maybe a dozen) with no driver installed in the device manager.

0 Likes

I have the same issue,  it worked fine after I upgrade windows with 18.10.xx something before 18.10.0830  .  after I uninstalled the PSP and just installed the new one it started BSOD with AMDPSP.sys same error .     we need new PSP driver to support the new 1809 . they changed the kernel and windows tries to protect it self because of wrong driver signing or something . please release new chipset or AMDPSP driver because it was not changed at all

0 Likes
noodles59
Miniboss

WHY?

the current latest AMD driver is working fine on 1809 ... no problems .. and I just updated to 1809 (no clean install)

Futuremark's skydiver even set a new record for my 4k monitor scoring 21463! (in 4k resolution) which is a ~thousand higher than before.

offler
Adept II

To add some information...

Microsoft decided to change internal system timer to 10 MHz (Win 10 1809).

Reasons?

Probably its related to Spectre/Meltdown (aka sidechannel attack).

Did they informed anyone? No.

Is it possible to disable it?

I tried to disable useplatformclock and useplatformtick. Those values were to disable HPET times in system, but it did not changed the 10MHz timer.|

The answer is "no".

I would like to ask guys who suffer of BSODs:

Do you have HPET (High Precision Event Timer) disabled in your BIOS/UEFI?

The thing is I cannot disable it in mine, and 10MHz timer indicates its being read from HPET... If you dont have it in system or its not enabled, and Microsoft apparently did not expected this, system will for sure go BSOD...

So... I recommend to enable HPET in BIOS and try if your system will continue to crash.

0 Likes

I have HPET enabled on the bios,  when I use Bcdedit /set useplatformclock  true   it enabled HPET 14.xx mhz ..   but I didn't  check if AMDPSP.sys installed properly with that..    are we suppose to use HPET now ?  or this will start causing issues now in games and such  ?  they said AMD  have no issues with Meltdown and Spectre , why they change things for our AMD ?

0 Likes

You dont need to enable useplatformclock, also its still safer to NOT enable it.

The thing is, before 1809, system used 3.14Mhz as a system timer, which is TSC. Now it uses 10MHz... and given the frequency its either HPET on lowest standard frequency, or something different I am not yet aware of.

Microsoft has been rolling Spectre/Meltdown mitigations for months now, regardless if it was AMD or Intel - in some cases patches were retracted because of terrible performance impact or BSODs.

So far i experienced some minor performance impact, some minor bugs - however each were related to precise timing.

When useplatformclock is disabled, it seems that OS allowed LatencyMON to read timing values with precision of 0.1 microsecond, but nothing more precise. (This is on Threadripper 1900x). Thats why it looks exactly like Spectre/Meltdown mitigation.

AMD Platform Security Processor - Wikipedia

If its true that AMDPSP is an arm core incorporated to a Ryzen/Threadripper platform, it is however vulnerable... If it also requires precise OS timing to run properly, again there might be a problem...

0 Likes
karsten
Journeyman III

Hopefully new AMD drivers coming soon, crossfire broken on 1809 w/ Vega64, can't enable

0 Likes

Anything new ?  can we install AMDPSP without issue ? or does it still crash

0 Likes