Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Why is it impossible to install drivers for 6900xt on Ubuntu?


We have bought 2 x 6900XT, 8 x 6800 XT and 1 6800 graphics card. We are trying to set them up to work on Ubuntu using amdgpu-pro driver. We tried:

Installing 2.30, 2.40, 2.45 on Ubuntu 18.04 - none works and each time the same dpkg error

Installing 2.40, 2.45 on Ubuntu 20.04.1 - doesn't work, same error

Installing 2.40, 2.45 on Ubuntu 20.04.2 - doesn't work, same error

Installing 2.40, 2.45 on Ubuntu 20.04.1 and Ubuntu 20.04.2 with 5.4.0-54 kernel and all other kernels removed - doesn't work, same error

Installing 2.45, 2.50 on Ubuntu 20.10 - doesn't work, same error

Tried zillions of other stuff like downloading latest firmwares (from amd help page url), installing appropriate versions of llvm, etc. NOTHING WORKS.

Why is it impossible to install AMD drivers on Ubuntu without losing mind? Why do I need to be kernel developer to use graphics cards on operating systems exclusively used in our industry?

The cards are all new. Should I return them all because they are completely unusable and you cannot make a driver for them? Fun fact: even on Windows the latest driver crashes occasionally with some Driver timeout message!!!

What is the solution?

1 Reply
Journeyman III


I just had similar/same yesterday. So it will be "n00b leading the n00b" and all senior experts- please do come and comment and correct me!


System Linux Mint 20.1 and "number of kernels" installed. 6900XT.

What did the trick for me and i will not paste here my googling history was:

1. dpkg --purge all "newer kernels than linux-image-5.4.0-54-generic" && apt autoremove

2. Make sure linux-image-5.4.0-54-generic is installed

3. (optionally) install mesa and vulkan if you wish

4.  get your corresponding newest driver from,


5. Go according to your need as they say here:

(There is no update in doc regarding PAL, should be "rocr" for opencl)

$ ./amdgpu-pro-install --opencl=rocr  

For mining operation you probably are OK with "--headless"

Anyway: after many unsucessful attempts and dpkg error it installed OK, also made kernel upgrade to - and dkms took care of the driver also. I will see about newer kernels later.

Maybe it helps

But I agree. Linux running customers should be treated more seriously. We need clear hardware-driver-software compatibility matrixes and documentation. And what is it about a "human-readable" GUI tool to play around with clocking etc??  I have found only one third party option so far.