Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Why do my games keep *video* crashing (Overwatch CSGO Apex Legends) but everything else works such as audio?

The Problem: I'll be playing games such as: Overwatch, CSGO, and Apex Legends, and the game will run flawlessly, but at seemingly random times the video will just stop working all together. I am able to play the games for sometimes hours until this occurs, but sometimes just a few minutes. Normally when this happens I still have audio, but other times it will completely lock up my OS and in order to get out of it I must hold the power button on my case. When Overwatch crashes it gives me the message that my "rendering device has been lost" (surely that indicates a driver issue or a GPU issue at the very least). This problem only occurs while playing games, and not when I am just using chrome, discord, watching videos etc.

Here's what I've already tried:

  • Update mobo bios (MSI B450 Tomahawk MAX)

  • Update chipset drivers

  • Remove factory drivers with DDU and fresh install of recommended drivers

  • Older driver versions

  • Replaced PSU

  • Ensured that no overclocking is in place (outside of XMP)

All of which to no avail

Any help or input is greatly appreciated!


CPU: Ryzen 5 3600X

MOBO: MSI B450 Tomahawk MAX

GPU: Gigabyte Radeon RX 5700 XT GAMING OC 8G

RAM: G.Skill TridentZ RGB Series 16GB (2 x 8GB) 288-Pin 3600MHz

PSU: EVGA Supernova 650 G+

1 Reply
Adept II

Hello smoov,

AMD is having a major problem with their driver right now.  It appears to show up mostly on the 5700Xt's but also does show up on other, older cards such as the Vega series.

Several of us are having this issue in several other games, not just Overwatch and the other games you mentioned.  There is a rather lengthy thread discussing this subject at length.  It is located here:

If you look through the readme file of the latest vid drivers from AMD, you can see the issue has been identified and is being worked on.  Hopefully this will be resolved soon.

Chris Smith