Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Why did AMD leave support for old BIOS?

Why has AMD leave supporting old BIOS now? None of their latest drivers are compatible with devices having an old bios and the support forums say to be on the latest bios version. How can I be on the latest when the last version is the current latest available for that device. It's ridiculous if the company looses support for BIOS and doesn't update the bios for that particular device, we are stuck with an older version of gpu drivers. 

Many have reported this issue on the other forums, and idk if this is the right place or not but I'll be opening a ticket for it too after this. Do give some kind of an explanation or a warning not to update the drivers then, my driver version is 16.xx back from the 2017 and I can't use any of the latest version, yet it still keeps asking me to update.

My device is Acer aspire v5 122p with A6-1450 apu and Radeon HD 8250 gpu alongside it. Amd gives latest driver for the device on their website but the driver only produces lags overall on the display. Please take a note to this AMD you're losing customers this way, no matter how little. You still are. 

10 Replies

That's a problem for Acer--not AMD.  There is nothing wrong with the Adrenalins, as far as I can see. 

A problem for Acer since they dropped support for their device?

I have a hard time following you since this problem isn't just with Acer laptops, I can link a lot of forum threads from different forums here which goes through the same problem. 

For some the 17.xx version works, for some 18.xx it's just different for everyone but more or less it is related with the years old devices. Devices which aren't getting any updated bios anymore. 


Is this why all the 2019 editions of the radeon drivers has had serious issues with my R9 280 on Windows 10?


Could be, but more or less this issue is about the screen lags. The whole monitors lags. It's not the mouse neither can it be fixed as some gave a definitive idea to fix it by enabling mouse trail. Which just makes it seem like it's not lagging but in fact it is. Play any video or something and one can see it lagging. 

I think it's more on the amd's site. It's not like Acer made those gpus if they leave support for it amd should still consider it, I mean that certain gpu is still in use and the drivers are being updated for it. So why put the blame on Acer, not saying they aren't at fault too. But hey, somebody gotta get a fix. Besides it's not just my Acer notebooks problem but a lot of other desktops plus laptops problem. 


AMD recommends using the graphics drivers provided by your notebook's manufacturer (OEM)as the manufacturer has customized the drivers to support the built-in display and the features and functions specific to the notebook. Customized graphics drivers are available for download from most notebook manufacturer's web site.

If the current operating system is not the version originally installed on the notebook it may not meet all requirements and compatible graphics drivers may not be available. Please refer to the notebook manufacturer for supported operating systems and drivers.

AMD Mobility Radeon™ Graphics Driver:

AMD provides generic reference drivers for AMD Mobility Radeon graphics with limited support for notebook specific features and functions.

Edit: I wanted to add that I was only answering the sub question withing this thread asking about the R9 card question by lonegamer77:

"Is this why all the 2019 editions of the radeon drivers has had serious issues with my R9 280 on Windows 10?"

As and R9 380x and HD 7950 and 7870 owner I feel your pain on the recent driver woes. I now have it working after the latest cumulative update from MS. I will copy and paste what I already wrote in another thread about this issue:

It is really hit and miss with these older cards installing the newer drivers from what I can tell. The problem is that when express or upgrade  installing these there seems to be a hangup that will cause the driver to incompletely install and then Windows itself wants to interject it's opinion and install a driver from it's repository at the same time leaving to a corrupt driver install. Then when people reboot they are getting black screen hangs and some people are trying over and over to keep rebooting. I fear that the miss-installed driver is causing some of these cards to overheat and die. If you see this reboot to safe mode immediately. Hopefully you card is not in this state. So after the latest round of cumulative updates for Windows 1809 I am finally able to get the latest Radeon 19.1.2 drivers running on my RX 380x, HD 7870 and HD 7950. Make sure to RUN DDU FROM SAFE-MODE. Disconnect from the Internet and then install the driver. If it is not behaving normally, then reinstall it again this time as an express install over the same driver. 


From there if it isn't working and an older driver is I don't have further advice other than to open a support ticket with AMD. 

I honestly did try your suggestion, and it seemed to work at first, but after an hour or two my system started hanging every few seconds or so like before, this is with Radeon Software Adrenalin Edition version 19.1.2. So I reverted back to the last version that worked normally for me which is version 18.11.2 (Nov 19) for now. These issues seem to have started happening for me from version 18.12.1 (optional) and has continued all the way up to  the current version 19.1.2 (optional).

I'll create a support ticket with AMD and see what they have to say on the matter.


So the lag seemed to have stopped for you on the latest version? For an hour though but with the method above? 


Seems strange I know, but it seems to work at first and then eventually doing anything that uses h/w acceleration like streaming a HD video file or watching one locally seems to cause the lagging for example, and sometimes the display goes black for a few seconds then goes back to normal as though the display driver is crashing. This doesn't happen with 18.11.2.


Well I think I might give it a shot then but it might not work since I've tried installing the driver directly from device manager without all of the other Radeon software. None of the methods worked for me though but I'll try it out tonight and see what happens.

Edit: Guess I was late to read the edit above that the particular solution was for R9 subpost. Well either ways I still tried and the result was same. I've made two video files showing the problem. One shows the mouse lagging with the latest drivers, and the other shows mouse perfectly fine for which I'm using the drivers from acer's site which are old back from 2017. Even though I'm sure another later version worked for me once, 17.xx I guess but later after them did never work. And for now the only driver which works is below 17.xx only. Just watch the videos and you'll know what I'm talking about.