cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

thwomp
Adept III

While you guys are fixing the Mantle crash bug, do you mind fixing triple buffered vsync too? Hasn't worked in Win10 since catalyst 15.4

Triple buffering hasn't worked in Mantle for over a year now. In order for me to get it working, I either have to install catalyst 15.4, or I have to copy DLL's from Win 10 beta drivers 1018.1 or 1023.0 to the game folder (since they are WDDM 2.0). And that's only a valid solution for a single card.

With crossfire, those two DLL versions will crash any mantle game. For BF4, I found a second workaround that works with most mantle DLL versions by setting "RenderDevice.RenderAheadLimit 1" in the user.cfg file and it seems to give me decent vsync performance, in that my frame rate doesn't automatically drop by half if my frame times go below my refresh rate.

So I guess I'm wondering, since you guys clearly had triple buffering working in 15.4 and those early Win 10 drivers, as well as all other Win 8 drivers before that, is there any way you can fix it?

0 Kudos
4 Replies
kingfish
MVP

Re: While you guys are fixing the Mantle crash bug, do you mind fixing triple buffered vsync too? Hasn't worked in Win10 since catalyst 15.4

0 Kudos
thwomp
Adept III

Re: While you guys are fixing the Mantle crash bug, do you mind fixing triple buffered vsync too? Hasn't worked in Win10 since catalyst 15.4

I've been reporting it for a year now. This is the first time I've posted about it here, mainly because I know they're in the process of fixing the new bug introduced last month

0 Kudos
amdpete
Staff
Staff

Re: While you guys are fixing the Mantle crash bug, do you mind fixing triple buffered vsync too? Hasn't worked in Win10 since catalyst 15.4

For Render ahead, using a value greater than 1 would increase input lag which isn't exactly good for a first person shooter game.  I have no issue setting triple buffering via RenderDevice.TripleBufferingEnable 1 with Vsync enabled in the single player portion of the game with Mantle enabled as I just tried it.  Crossfire enabled Win 10 X64 using the 16.6.1 drivers using 2x R9 290X cards.

0 Kudos
thwomp
Adept III

Re: While you guys are fixing the Mantle crash bug, do you mind fixing triple buffered vsync too? Hasn't worked in Win10 since catalyst 15.4

Have you tried it without modifying the default value for RenderAheadLimit (should be -1)? Because you can see reports on different message boards dating back to 15.7 of triple buffering breaking in Mantle. The RenderDevice.TripleBufferingEnable 1 command doesn't even show up in the command console Mantle mode if I remember correctly. I had it in my user.cfg file anyway but it never worked.

The reason I bring this up is because in Battlefield Hardline, the "RenderAheadLimit 1" trick doesn't work as it does in BF4. It still has some massive jumps in CPU frame times (causing unplayable stutter/dropped frames) whenever your GPU frame times start to rise near your refresh rate. You can make it better by setting FramePacingMethod to 1, but it still doesn't solve the issue once GPU frame times exceed the refresh rate (even if its by a fraction of a millisecond).

So my thinking is: if you guys can restore triple buffering to how it worked pre-catalyst 15.7, then I wouldn't have to mess with all those console settings in BF4, and BF Hardline would work correctly as well. I guess this leads to my main issue currently: there is no good way to play BF Hardline in crossfire. DX11 has severe frame pacing issues, and mantle has triple buffering issues. Mantle in BFH does have perfect frame-pacing though, so if triple buffering were working properly again then that would be the way to go.

Just for your reference, I'm currently running crossfire 380x's with an i5 6600k @ 4.3ghz. Previously I had a single 380x, and before that I was using a 7970 (in a different PC), and this issue was observed in all those setups.