Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

WHEA 18 logger event, random PC rebooting

Hello, a few months ago I bought a new PC, pre-built with the hopes of it being a new gaming PC and massive upgrade from my 10 year old potato computer. It worked fine for a few months, ran games really well and functioned properly. Around late September it began having WHEA event logger 18 errors in which my computer randomly reboots, screen goes black and it freezes for 1-2 seconds then does the reboot. I checked EventViewer and every time it happens it's also a WHEA event and I've tried to troubleshoot and look at old pages from various forums of other AMD users having this issue and it's just been driving me mad. It usually tends to reboot when I have a game running but sometimes it'll reboot when I'm watching videos or even when I'm idly browsing the web. 


OS Name Microsoft Windows 10 Pro
Version 10.0.19042 Build 19042
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DESKTOP-QUU67B6
System Manufacturer Gigabyte Technology Co., Ltd.
System Model B450M DS3H
System Type x64-based PC
System SKU Default string
Processor AMD Ryzen 5 3600 6-Core Processor, 3593 Mhz, 6 Core(s), 12 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. F60c, 10/29/2020
SMBIOS Version 3.3
Embedded Controller Version 255.255
BaseBoard Manufacturer Gigabyte Technology Co., Ltd.
BaseBoard Product B450M DS3H-CF
BaseBoard Version x.x
Platform Role Desktop
Secure Boot State Off
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume4
Locale United States
Hardware Abstraction Layer Version = "10.0.19041.488"
User Name DESKTOP-QUU67B6\User1
Time Zone Eastern Standard Time
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 15.9 GB
Available Physical Memory 10.9 GB
Total Virtual Memory 31.9 GB
Available Virtual Memory 22.9 GB
Page File Space 16.0 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled
Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not Modern Standby, Un-allowed DMA capable bus/device(s) detected, TPM is not usable
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware No
Hyper-V - Data Execution Protection Yes

There's my system specs and I've also ran WhoCrashed and for my past errors and current ones it basically says the same thing every time.

On Mon 11/16/2020 11:12:08 AM your computer crashed or a problem was reported
crash dump file: C:\WINDOWS\LiveKernelReports\WHEA\WHEA-20201116-1112.dmp
This was probably caused by the following module: ntoskrnl.exe (nt+0x97EC16)
Bugcheck code: 0x124 (0x0, 0xFFFF8B02A4013A80, 0xBEA00000, 0x108)
file path: C:\WINDOWS\system32\ntoskrnl.exe
product: Microsoft® Windows® Operating System
company: Microsoft Corporation
description: NT Kernel & System
Bug check description: This bug check indicates that a fatal hardware error has occurred. This bug check uses the error data that is provided by the Windows Hardware Error Architecture (WHEA).
This is likely to be caused by a hardware problem.
The crash took place in the Windows kernel. Possibly this problem is caused by another driver that cannot be identified at this time.

I've run a few different tests on it like FurMark and Memtest86, some others as well but I can't remember them off the top of my head. I did recently use the Verifier tool built into Windows and tested the non-Microsoft drivers and it seemed to trigger a reboot like I usually have but my non-Microsoft drivers should be up to date so I'm not sure at this point. 

7 Replies

What is your GPU and PSU? How old is your PSU? Have you tried resetting the BIOS to factory settings and trying the system without any changes?


The GPU specifically is Asus RX 5700 XT 8 GB and I'm not sure on my PSU currently inside the PC but the vendor sent me a new PSU today through Amazon and it's an ARESGAME Power Supply 650W 80+ Bronze Certified, I haven't installed it yet so I'm still using the one that originally came with the system. I did do a reset of the BIOS from inside the main BIOS page and tried turning off XMP but it didn't seem to affect it. 



Try the new 650w PSU. The restart problem will probably disappear. If restarting still occurs, there may be a problem with the motherboard.


Actually I was a little off on the GPU I think, it's actually still Asus but it's Asus Dual RX 5700 EVO OC according to GPU-Z. I'll definitely try the power supply though because after some troubleshooting it seemed like that might be the problem since nothing else seemed to work. 


The most likely cause of the restart problem is the PSU. If the PSU capacity or temperature is not suitable, this type of power cut may cause the problem. If I were you, I would try to solve the restart problem with a PSU replacement. I'd also try to solve the WHEA error with the BIOS settings. I think if you increase the CPU core voltage manually with the BIOS, you will solve the WHEA error (if the new PSU does not fix it). You can find documents about manual voltage increase using the Google search engine.


Necroing my previous post, apologies. I put in the new PSU recently (took some time because I messed up putting the PSU in and reconnecting my SSD). But the PSU didn't help. I did upgrade the motherboard to the newest current BIOS. So I'm sure what the issue may be.

I haven't tinkered with the voltages in the BIOS outside of disabling XMP because I have no idea how to do that and don't want to mess anything up. 


You can try resetting CMOS on the motherboard.  Then boot into BIOS and set precision boost over drive to "disabled".  Try running the PC.  If that works okay, reapply the RAM XMP (D.O.C.P.) profile and make sure everything is still okay.