Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Weird crash that only checks out to be a driver issue?

So I recently (3 months ago) bought new pc parts to fully upgrade my computer, only about 2 months ago I started to get weird crashes and just assumed it was because of how high settings I was running. I recently started to notice that the crashes are getting worse and worse happening almost every time I open a game within 30 minutes. At this rate, even simple tasks will soon be impossible. So I did the thing everyone does and looked on the internet for some answers and ended up searching my event log, it says "The AMDRyzenMasterDriver service failed to start due to the following error:
The system cannot find the path specified." and "The AODDriver4.3.0 service failed to start due to the following error:
The system cannot find the path specified." Now I'm no technical whiz and I also couldn't seem to find any solutions to my problem. My computer doesn't even show a BSOD or any such it just simply powers off with my keyboard, mouse, and headphones still being powered. So I tried to uninstall and reinstall the drivers, worked for about 10 minutes more and then the same thing started to reoccur, so I tried to backtrack the drivers a few editions and bam it happens again. So the next thing I try is resetting my computer with no files and trying to redo all drivers in the system as well as checking for malware/viruses, needless to say, I was unable to reset my computer, I would get about halfway in and it would stop because of a "problem" while trying to reset. I have already checked for viruses and such and nothing has shown up. This is my last option at this point and my pc specs are Radeon rx 570 amd 2600x 16gs ram and a b350 mobo. Any and I mean any solutions would be greatly admired and appreciated

Sincerely and thanks Nate

3 Replies

Please fill out this form about your issue, you are not alone in this issue.

AMD Issue Reporting Form 

The more users who fill out this form and report it to them, the faster they will fix it. 

AMD is looking very closely at these reports specifically to solve the issue for all of us.

Journeyman III

Is there anything at all I can do in the meantime? Waiting for an update to the drivers is not a sure-fire way to get rid of my problem.


This started happening to me recently and seemed to cause a serious crash. I was able to solve this by deleting every AODdriver reference from the registry (I backed up the entries just in case).

When I checked registry reference, I tried to use the file path to find the files. The folder and files within the "Program Files/AMD/" for this service didn't exist. Even after uninstalling and re-installing the drivers, the files didn't seem to get replaced. So, I figured it was a cleanup issue and that's what I manually did. It has a been a few days and I haven't had the issue again yet.

Hope this helps