cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Highlighted
Adept II
Adept II

Weird crackling noise coming from RX 5700 XT on 2020 drivers

Subj. You can read more about it on several posts on reddit:
Weird crackling noise coming from RX 5700 XT? : Amd 
TLDR:
latest driver that works without noise when scrolling in browser is 19.12.1
I have already tried raising the voltage / clock and nothing changes. All programs with hardware acceleration cause noise from the card, when the window is updated. (browser scrolling).

0 Kudos
19 Replies
Highlighted
Adept II
Adept II

Re: Weird crackling noise coming from RX 5700 XT on 2020 drivers

0 Kudos
Highlighted
Adept II
Adept II

Re: Weird crackling noise coming from RX 5700 XT on 2020 drivers

If you install driver only (without software) all noise issues will gone. So root cause in radeon software, not in a driver.
Please fix radeon software!

0 Kudos
Highlighted
Community Manager
Community Manager

Re: Weird crackling noise coming from RX 5700 XT on 2020 drivers

Please could you provide the following information (please also include motherboard and BIOS version details) so i can investigate?

https://community.amd.com/thread/196209 

Highlighted
Adept II
Adept II

Re: Weird crackling noise coming from RX 5700 XT on 2020 drivers

Yes, of course. Apologize @amdmatt. This is my config:
```
AMD Graphics Card
    XFX RX 5700 XT 8 GB (this model and bios - https://www.techpowerup.com/vgabios/212289/xfx-rx5700xt-8192-190616)
    with custom liquid loop, average tempreture 43 C (Junction T is 43 C too) in game around 60 C
Desktop or Laptop System
    Desktop
Operating System
    Windows 10 Pro 1909 Build 18363.657
Driver version installed
    Adrenalin 2020 Edition 20.2.2
Display Devices
    LG UltraGear 27GL850-B 2560x1440 @144Hz DisplayPort 1.4 (cable from LG package )
    LG UltraGear 27GL850-B 2560x1440 @144Hz DisplayPort 1.4 (cable from LG package )
Motherboard + Bios Revision
    Asus Prime x570-p firmware 1405
CPU/APU
    Amd Ryzen 3900x
Power Supply Unit  Make, Model & Wattage
    Thermaltake Toughpower Grand RGB Sync Edition 850 Watt 80+ Gold
RAM
    64 GB ( 4x Kingston HyperX Fury Black 16GB DDR4 3200 CL16)
```

So for now I'm using a driver from 20.2.2 with prev. (2019) software. I still can hear noise when scrolling, but it's definitely quieter than with the 20.2.2 + adrenaline 2020 software. (with 19.12.1 and 2019 software I don't hear anything when scrolling)

Please keep us updated on how your investigation is going, can you reproduce this or not, etc

Highlighted
Community Manager
Community Manager

Re: Weird crackling noise coming from RX 5700 XT on 2020 drivers

Thanks for the information, i will file a ticket with engineering. 

I have a couple of suggestions you can try in the meantime as possible potential workarounds. 

  1. Set PCI-E Gen 3.0 for the PCI-E lane which the GPU is in. (if your motherboard has this option, should be under Advanced > Onboard Devices Configuration.
  2. Disable hardware acceleration in any apps you are using. 
0 Kudos
Highlighted
Community Manager
Community Manager

Re: Weird crackling noise coming from RX 5700 XT on 2020 drivers

Which browser are you using?

0 Kudos
Highlighted
Adept II
Adept II

Re: Weird crackling noise coming from RX 5700 XT on 2020 drivers

amdmatt

> Which browser are you using?
I use firefox 73.0.1 (64-bit)

> Set PCI-E Gen 3.0

I forgot to say I use thermaltake razor PCI 3.0, so I've already switched to PCI 3.0 mode.

> Disable hardware acceleration in any apps you are using. 
lol what? this advice is like - don't use your gpu. I actually want to use hardware acceleration, in IDE, in browser, in discord etc. How to live without it in era of electron apps? No, I'm definitely won't do it.

0 Kudos
Highlighted
Community Manager
Community Manager

Re: Weird crackling noise coming from RX 5700 XT on 2020 drivers

It's just a temporary suggestion to avoid your issue, by all means carry on using it otherwise. 

0 Kudos
Highlighted
Adept II
Adept II

Re: Weird crackling noise coming from RX 5700 XT on 2020 drivers

I think new drivers can increasing the clock speed at small update in hardware accelerated app and go back immediately too often, so such jumps often go up and down can cause this. I think that the delay in the transition to a higher clock should be customizable (at least it should determine whether the user is in the game or not). But this is just my suggestion, who knows why it only happens on 2020 drivers.

0 Kudos