Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

VSR doesn't work on LG TV

VSR does not work on LG TV (the exact model is now difficult to indicate because it hangs on the wall, except that the resolution is 1080p and 42 inches). Already tried on two different video cards (R9 280 and RX 470), it is noteworthy that on Nvidia cards I can easily create custom resolution higher than native on the TV, and also activate the analog of VSR without any problems. I am already writing about this at AMD for the fifth time, but it seems that it will not give a damn either. At the same time, it works on a specific version of drivers. One of the last that I found is 19.8.2. I also tried to activate VSR on another TV from Samsung (NU7002 50 inches) and everything works on it. The maximum resolution using VSR was 5K with something. The problem, as I understand it, is completely on the driver side, since the technology works on one version, but not on the other, and again I don’t understand why I can’t create a custom resolution higher than the native one, for example, the same ultra-wide 1080p

2 Replies
Adept I

I want to add that I have the exact same problem with my Radeon VII. The last working driver I know is 19.8.1 (maybe .2 works also). The problem also only exists in combination with some TV and AVR modells as it semes. But since it is working with specific driver versions the problem must be in the drivers.

Also noteable: the problem already existed when I bought the VII but was solved some month later, just to come back with drivers after 19.8.


I solved this problem by changing AMD to Nvidia. The NITRO+ Sapphire RX 470 just burned out. Never again will I buy graphics cards from AMD. Their software is terrible and unstable, their graphics cards are also like that too. I wish you a prompt decision on this matter. Try to contact the official support and not this amateur forum.