cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Highlighted
Adept II
Adept II

VSR does not work correctly at R9 390 for 6 months.

Beginning with driver Adrenalin 2019 Edition 18.12.2, when VSR is ON in AMD Radeon Settings lose the ability to select a 3200x1800 screen resolution for a display connected via HDMI (and recently through DVI) (I have Panasonic-TV TX-LR32X5). My TV is HDReady. In driver 18.12.1 and earlier this opportunity is.
And one more problem - when I choose the remaining available VSR resolution 2560х1440, then the active resolution 720p is turned on instead of 1080p. Previously, when I chose 3200x10800 I had an active signal 1080p.
My system:
CPU Intel Core i5-4460
Motherboard MSI B85-G41 PC Mate
System Memory 16311 MB  (DDR3 SDRAM)
Video Adapter MSI R9 390 GAMING 8G
Radeon Software Version 19.5.2
Windows Version Windows 10 Pro (64 bit) 1903
Monitor Panasonic TV model - TX-LR32X5 (supports 1080p60Hz)

P.S. I already wrote 2 times to tech support and sent 2 times the report, but this has not been fixed, and the support responds with a couple of standard tips, and then silence.

I have already raised this problem here earlier on the forum (Virtual Super Resolution (VSR) does not work on TV with HD ready through HDMI ), in the end it was approximately fixed in six months, but now some idiot did it again.

Screenshot-554.png

Screenshot-555.png

Screenshot-586.pngScreenshot-587.png

UPDATE:

Now I installed the latest video drivers 19.6.2 And now in the list all modes of 1920x1080 modes for my TV it became recommended (see photo) and after turning ON the VSR, now the image is not reset to 720p. That's all. The most important thing is that there is no possibility to choose a resolution of 3200x1800 and 2560x1440 that works with an active 720p signal and has not been fixed.

Screenshot-592.pngScreenshot-593.pngScreenshot-5541.pngScreenshot-5901.png

UPDATE2: I tried to make a clean installation of 19.6.2 using the DDU - nothing has changed, which is a pity.

54 Replies
Highlighted
Big Boss
Big Boss

Re: VSR does not work correctly at R9 390 for 6 months.

Have you reported this issue to AMD for each driver it still doesn't work for?

I you have not done so already you might want to reload that driver with a clean slate.

Disable fast startup/hibernation

Run DDU from safemode with internet disabled, get it at wagnardsoft_com

Install the downloaded driver again with internet disabled.

0 Kudos
Highlighted
Adept II
Adept II

Re: VSR does not work correctly at R9 390 for 6 months.

I wrote above - P.S. I already wrote 2 times to tech support and sent 2 times the report, but this has not been fixed, and the support responds with a couple of standard tips, and then silence.

Reinstalling the driver does not give anything.

0 Kudos
Highlighted
Challenger
Challenger

Re: VSR does not work correctly at R9 390 for 6 months.

Edited, this message is for references in the message below, the reply below this is more or less the solution to regaining that functionality.

----8<-----------

There are a number of things wrong here. Firstly, you TV is HD ready, that makes things easier - this is a standard that revolves around broadcast television and image processing ( image processing being the issue ). Secondly, your native panel resolution is 1366x768 which is 720p or 720i, depending on who you ask, and is close enough to 1280x720 that this is "HD" circa 2005ish. Thirdly, if your TV is telling you 720p, this is fine, it looks to be close enough to native to the panel, and lastly a 1080p signal is a VSR for the panel itself. Continuing...

From my experience, the VSR resolution is the resolution you choose in a game or full screen application - the GPU just makes them available as an option to the game or application. It might be possible to choose it in windows as well, my experience is varied with this. Let me explain a bit...

If windows itself is where you are trying to do this very high VSR, then you should set your hdmi output to the max native resolution of the TV. And do not let the TV downsample the 1080p signal - I think this is what was happening prior to the updates. Stick with the "720p" signal for that TV ( or isolate the native 1366x768 resolution via the monitor properties ) and use the GPU VSR rather than the TV internal processor. 

So set your actual output resolution to 1366x768 over hdmi - see that this is set via drivers or monitor or signal info.

At this point you can either:

A) Go to your TV menu and disable down sampling and up sampling - choose native only if possible.

Then enable VSR, then go to windows display properties ( the new user interface is fastest ) and check for if the VSR resolution is present - then change to the VSR mode. At this point,  what you have is what you get here. I do not know how to establish a custom VSR.

Or B)

A problem may arise from this where the TV is unable to have its signal compatibility behavior changed as described above. And it's not desirable to do so - in this case you can go to the monitor or display properties for the TV in windows devices and look at the supported modes. In this same area you should be able to disable modes that are not native to the panel, i.e. 1080p, but are able to still be processed by the reciever in the TV itself - because its "HD ready" and the drivers are being difficult ( your problem at this point is that it's not seeing the 1080p availability ).

In other words, 1080p can be processed by the TV, but it's not a native resolution to the panel itself - in fact hdmi or dvi signaling will report it as an available mode even though there are some undesirable side effects. It's actually already running these 1080p signals as a virtual super resolution for the panel itself. And if you want to run something higher than 1080p as a VSR, you need to eliminate the TV as the additional intermediate processor.

I cannot explain away why it doesn't list more VSR modes for you unless the sequence of driver updates from both Windows and AMD were incorrectly identifying the nature of the panel this whole time. It should be perfectly acceptable to have any number arbitrary VSRs available - but I wouldn't know where that meta-data is stored.

I would choose some VSR resolution that is mathematically rational to 1366x768. ... Which you've already done 3200x1800.

I suppose the question is then where to set a custom VSR resolution. 

0 Kudos
Highlighted
Challenger
Challenger

Re: VSR does not work correctly at R9 390 for 6 months.

How to Enable and Configure AMD Virtual Super Resolution | AMD 

Alternatively, you can eliminate 720p or 1366x768 from the monitor's modes and isolate the 1080p.

According to that information in the link above 3200x1800 is only available for the 1080p native signal modes. So you can have your TV continue to spoof the 1080p native resolution but you will want to stop it from going into "720p" modes via the monitor settings.

Sorry for all that reading. Your signal is/was down sampling twice, once by the GPU and again in the TV.

Edit: see my ramblings above for more information.

0 Kudos
Highlighted
Big Boss
Big Boss

Re: VSR does not work correctly at R9 390 for 6 months.

You need to do this for every driver release that does not fix or list the issue as known. 

0 Kudos
Highlighted
Esteemed Contributor III

Re: VSR does not work correctly at R9 390 for 6 months.

How to Enable and Configure AMD Virtual Super Resolution | AMD 

Supported VSR modes are dependent on the target display's native timing (resolution, refresh rate).  However, some VSR modes are only available on certain AMD GPUs.  Please refer to the table below for supported VSR modes.

Target Display TimingSupported VSR Modes
1366 X 768 @ 60HZ1600 X 900
1920 X 1080
1600 X 900 @ 60HZ1920 X 1080
1920 X 1080 @ 60HZ2560 X 1440
3200 X 1800
3840 X 2160 (AMD Radeon™ R9 285, AMD Radeon™ R9 380 and AMD Radeon™ R9 Fury Series)
1920 X 1200 @ 60HZ2048 X 1536
2560 X 1600
3840 X 2400 (AMD Radeon™ R9 285, AMD Radeon™ R9 380 and AMD Radeon™ R9 Fury Series)
2560 X 1440 @ 60HZ3200 X 1800
1920 X 1080 @ 120HZ1920 X 1200 @ 120HZ
2048 X 1536 @ 120HZ
Highlighted
Adept II
Adept II

Re: VSR does not work correctly at R9 390 for 6 months.

My TV sees 1080p and it is available without VSR, the TV does not interfere with the video driver. I wrote that before the video driver version 12.18.2 everything worked fine. And I can not understand why the active signal is 1080p at 3200x1800, and 720p at 2560x1440 on my TV?

I apologize, but I do not speak English very well, so I didn’t understand much of the technical information you wrote.

0 Kudos
Highlighted
Adept II
Adept II

Re: VSR does not work correctly at R9 390 for 6 months.

I know about it. My TV supports 1080p (I added this to the main message) and I have a R9 390 card. I should have 2 permissions available when turning on the VSR: 2560x1440 and 3200x1800. But the latter is not. And 2560x1440 works with an active 720p signal on my TV.
0 Kudos
Highlighted
Esteemed Contributor III

Re: VSR does not work correctly at R9 390 for 6 months.

What your tv supports and it's native resolution are two different things. VSR relies on native resolution.

0 Kudos