cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

oliverf0x
Journeyman III

VFIO Setup - Screen is bugged with every driver after 20.4.2-may25

Hey there,

I'm using a VFIO Setup with ESXi 6.7 - 7.01 Update 1b and have Problems within my Windows 10 64-bit VM if i install any newer driver than 20.4.2.

The GPUs i use (in different ESXi-Hosts) are RX480, RX580 and RX5700 XT (PowerColor Red Devils) and this problem can be reproduced with any of these 3 GPUs (altough my RX480 is currently under repair).

With the Driver 20.4.2 the GPU transmits the Picture of the VM to both Displays that are attached to the GPU (Connected over the Displayport or HDMI depending on the Card) and therefore works like a bare-metal installation of Windows (You boot the VM and you see on the display the windows logon screen).

But if i install any driver later than 20.4.2 the the displays showed a bugged "old" content of what has been displayed before with dots:

https://ibb.co/wRKB6Lp

I guess something has changed with the driver after 20.4.2 that caused this bug to appear as this problem still appears with 20.11.2 and it doesn't matter on which esxi host or GPU combination is running.

Would it be possible to take a look on that? I only found that out because Horizon Zero Dawn needed a higher Patch than 20.4.2 and with 20.4.2 Playing Games or doing work wasn't a problem and freesync also worked perfectly (G-Master GB2760QSU).

 

I can even install 20.4.2 (everythings working) afterwards any other driver (screen is bugged) and then (after DDU Uninstall and host reboot due to PCI Reset Bug) install 20.4.2 again - everythings working :)

Best regards!

Oliver

 

 

0 Likes