Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Updated AMD GPU-PRO Drivers for Ubuntu 21.04/Kernel 5.11 and above?

When will an updated version of the proprietary drivers be released? I like my graphics card not being a paperweight. Thanks!

24 Replies

These drivers intended for enterprise with long term support. AMD usually skip unstable Ubuntu and non LTS.

Tried latest Ubuntu 22.04 LTS and it was like - What the hell? This one is unstable.

As I see they support recent RHEL and SLES\SLED with new kernels.




I can't use "newer" features that have been out for over two years and have graphics acceleration if I have an AMD graphics card installed. 


@rodneyjsm Please specify which new functions you cannot use? For example I use opensource driver and have graphics acceleration.


How often do you hijack people's threads? Just curious....

Adept I

This is quite the accomplishment by AMD, not being able to ascend above the low bar provided by Nvidia. That's your answer? Just use Redhat Enterprise?


I am also waiting for 22.04 drivers. Open drivers are missing OpenCL compute support.

Come on AMD, it's been a while since 22.04 was released.

@dpospisi I'm not using Ubuntu, but I link something that may or may not help you.

I can recommend to read this: 





Nope. I have spent whole days to get OpenCL working without official AMD drivers using this or similar packages or any other method you can find. None of them worked properlly.


@dpospisi  sudo apt install mesa-opencl-icd

This is limited solution. Something might not work, but you should try.





AMD will do good job if they pack all drivers dependencies in container and stop using external libraries needed only by their drivers.

PS. tried to install OpenCL+rocm in recent SLES 15 SP4 with Kernel 5.14 (Leap 15.4) and it works but failed to build kernel module that was not needed.


Installing that package places amdgpu-proprietary.list file into /etc/apt/sources.list.d which contains:

# Enabling this repository requires acceptance of the following license:
# /usr/share/amdgpu-install/AMDGPUPROEULA
# deb jammy proprietary

The repo is disabled so the amdgpu-install fails unable to locate anything.

If I manualy remove leading "#" character and enable the repo, the installer still fails with:

sudo amdgpu-install  
Hit:1 jammy InRelease
Hit:2 focal InRelease                                                                                                                                                
Hit:3 jammy-updates InRelease                                                                                                                                        
Hit:4 focal-updates InRelease                                                                                                                                        
Hit:5 jammy-backports InRelease                                                                                                                                      
Get:6 jammy-security InRelease [110 kB]                                                                                                                                
Hit:7 stable InRelease                                                                                                                                            
Hit:8 jammy InRelease                                                                                                                            
Hit:9 stable InRelease                                                                                                                                     
Hit:10 jammy InRelease                                                                                                                     
Get:11 jammy-security/main amd64 DEP-11 Metadata [11,4 kB]
Get:12 jammy-security/universe amd64 DEP-11 Metadata [608 B]         
Hit:13 jessie InRelease          
Fetched 122 kB in 2s (63,7 kB/s)
Reading package lists... Done
W: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for detai
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package rocm-opencl-runtime is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Unable to locate package amdgpu-lib
E: Package 'rocm-opencl-runtime' has no installation candidate
E: Unable to locate package rocm-hip-runtime
E: Unable to locate package amdgpu-dkms


Not sure if I am doing something wrong or it is some sick joke from AMD.


@dpospisiWhy your repository mixed with focal(20.04) and jammy(22.04) and Debian jessie (8)?

I left deb camp because of repository(ppa) hell. I think your suffering not worth it.

I wont install ubuntu again just to confirm proper driver installation.

I use Manjaro with opencl-amd and latest kernels without issue.// saying just in case


Yes I realized that my PPA config is messed up. Not sure how that happened, probably with dist-upgrades.

I tried clean ubuntu, but still:

sudo amdgpu-install --opencl=rocr
[sudo] password for dominik:
Hit:1 jammy InRelease
Hit:2 jammy-updates InRelease
Hit:3 jammy-backports InRelease
Get:4 jammy-security InRelease [110 kB]
Hit:5 jammy InRelease
Hit:6 ubuntu InRelease
Fetched 110 kB in 1s (105 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
linux-headers-5.15.0-41-generic is already the newest version (5.15.0-41.44).
linux-headers-5.15.0-41-generic set to manually installed.
linux-modules-extra-5.15.0-41-generic is already the newest version (5.15.0-41.44).
linux-modules-extra-5.15.0-41-generic set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
rocm-llvm : Depends: python but it is not installable
Depends: libstdc++-5-dev but it is not installable or
libstdc++-7-dev but it is not installable
Depends: libgcc-5-dev but it is not installable or
libgcc-7-dev but it is not installable
Recommends: gcc-multilib but it is not going to be installed
Recommends: g++-multilib but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


@dpospisireported to developers at ... 24 march 

I confirm issue in virtualbox.

This looking bad - they seem dropped rocm support for 22.04 so to install driver you need to disable opencl. I think you may want to leave deb camp like me. 






Or pull the RX6800 card from my computer and put into the trashbin in front of my house where it belongs. I can't belive that AMD is doing so so bad. How they can release a driver without any basic smoke testing like is this **bleep** even going to install?

This level of non-profesionalism in such a big company is beyond my understanding.

@dpospisi  I agree with you about trash like service. But device is good so I can't agree to bring it to "trashbin"...

The problem is that AMD developers use old libraries like python and gcc 5 or 7. Canonical regularly drop support of crucial old libs. That's why we have Valve Steam OS 3 build with Arch base (because before they dropped 32 bit libraries needed by Steam).

Why I left deb? - I needed to look for ppa to bring that support back. When I done so got same mess like you with sources and it was unstable and sometime removed itself completely (dependency hell is like domino castle< you pull one piece and it all destroyed).

@Matt_AMDCan you look into this issue? Low quality of pro drivers release. We can't install drivers for Ubuntu 22.04 in clean installed system, rocm in particular. It required dependencies that is not provided by Canonical.  As I said before in this topic if AMD will use something like flatpack for dependencies it will solve everything.


@dpospisiAMD released new build of drivers. I will test it later in virtual machine. 


@dpospisi Same broken rocm installation. Don't try this build because it clearly without fix.


So far, I got the best luck with amdgpu-install_22.20.50201-1_all.deb.


I recently got a pair of RX 6400 (OEM: XFX Speedster SWFT105), just to check out. The cost was below an GTX 1650 and it only uses 53W compared to 75W or more (depending on model). All the other GPUs I have are different nVidia ranging from GTX 1650 to RTX A2000, including some M class Tesla and Quadro. The slowest are GTX 1650 (TU116) and according to's theoretical data, the RX 6400 have better performance than the GTX 1650. All my computer hardware are involved in BOINC projects.


In a number of attempts, I have been trying to get OpenCL to work, but failed every time. The BOINC software has not been able to detect the two RX 6400 properly. BOINC has an issue, looking for the outdated, but that's not problematic. The second best attempt was with amdgpu-install_22.20.50200-1438747~22.04_all.deb. BOINC accepted then the GPUs, but every WU (task) failed initially. Checking stderr files of concern, the gfx1030-amdgcn-mesa-mesa3d.bc file was reported to be missing. Checked the files on the computer and it was correct, but it's the wrong file. RX 6400 require gtx1034-... The GPU has been reported as "Beige Goby" only. (Probably nothing to bother about, but still an indication of improper work)


Last and best attempt. Found amdgpu-install_22.20.50201-1_all.deb, installed it and tested. The gfx1030 and Beige Goby issues was fixed. This time, the GPUs started to work, but failed at a later stage. In BOINC, I tested with work units (WU) from PrimeGRID and Einstein. With Einstein, it failed after just 13 seconds. The related stderr.txt starts with

process exited with code 69 (0x45, -187)

and ends with 

17:39:28 (2816): [debug]: Flags: X64 SSE SSE2 GNUC X86 GNUX86
17:39:28 (2816): [debug]: glibc version/release: 2.35/stable
17:39:28 (2816): [debug]: Set up communication with graphics process.
boinc_get_opencl_ids returned [0x1e062c0 , 0x7f35eeb42d90] 
Using OpenCL platform provided by: Advanced Micro Devices, Inc.
Using OpenCL device "gfx1034" by: Advanced Micro Devices, Inc.
Max allocation limit: 3636461568
Global mem size: 4278190080
Couldn't create OpenCL command queue (error: -6)!
OpenCL shutdown complete!
initialize_ocl returned error [2013]
OCL context null
OCL queue null
Error generating generic FFT context object [5]
17:39:28 (2816): [CRITICAL]: ERROR: MAIN() returned with error '5'
FPU status flags: 
mv: cannot stat 'LATeah3012L12220719_812.0_0_0.0_3194361_0_0.out': No such file or directory
mv: cannot stat 'LATeah3012L12220719_812.0_0_0.0_3194361_0_0.out': No such file or directory
mv: cannot stat 'LATeah3012L12220719_812.0_0_0.0_3194361_0_0.out': No such file or directory
mv: cannot stat 'LATeah3012L12220719_812.0_0_0.0_3194361_0_0.out': No such file or directory
mv: cannot stat 'LATeah3012L12220719_812.0_0_0.0_3194361_0_0.out': No such file or directory
mv: cannot stat 'LATeah3012L12220719_812.0_0_0.0_3194361_0_0.out.cohfu': No such file or directory
mv: cannot stat 'LATeah3012L12220719_812.0_0_0.0_3194361_0_0.out.cohfu': No such file or directory
mv: cannot stat 'LATeah3012L12220719_812.0_0_0.0_3194361_0_0.out.cohfu': No such file or directory
mv: cannot stat 'LATeah3012L12220719_812.0_0_0.0_3194361_0_0.out.cohfu': No such file or directory
mv: cannot stat 'LATeah3012L12220719_812.0_0_0.0_3194361_0_0.out.cohfu': No such file or directory
mv: cannot stat 'LATeah3012L12220719_812.0_0_0.0_3194361_0_0.out.cohfu': No such file or directory
17:39:40 (2816): [normal]: done. calling boinc_finish(69).
17:39:40 (2816): called boinc_finish

The rest in between are only parameters used by the cruncher.

With PrimeGRID, I got

process exited with code 1 (0x1, -255)</message>
AP26 OpenCL 10-shift search version 3.1 by Bryan Little and Iain Bethune
Compiled Aug  7 2020 with GCC 7.5.0
Command line: ../../projects/ 267839065 267839184 0 
Error: Creating Command Queue. (clCreateCommandQueue) returned -6


The crunchers in both project reports basically the same. A OpenCL issue.

Here, with the same subproject, I noticed that it's slow, very slow. When the GTX 1650 was finished with one task, the RX 6400 that started at the very same time, had only completed about 10%. When the RX 6400 finally reached just above 90% completion, the crunch speed dropped to about a 1/10th. The first of the two RX 6400 who reached just above 97%, caused the other one to fail too, regardless of progress.


As I have spent hours trying to make this work, I soon will reach a limit. After passing that point, I will sell the two RX 6400 to someone that doesn't care about OpenCL and buy a RTX A2000, despite way higher cost (maybe wait and buy a RTX A4000). With nVidia, I will immediately get working Plug and Play ...


Have now finished to try to do a full install in Windows. Didn't go well. GPU-Z reports that only OpenGL is installed. No OpenCL or Vulcan. On top of that, no surprise, OpenGL is broken, lacking files.


Conclusion is that the RX 6400 is good only for running the basic GUI, but nothing else. That's seems like a nice scam job by AMD.


@MasseI have 6500 XT (beige goby) and it is working without issue only with latest kernel 5.19 + rocm opencl addition. I don't use pro drivers.

I use Manjaro with opencl-amd, and Kernel 5.19. If you don't want to use Arch|AUR then I guess sell those gpu's. 

PS I don't have any problem in Windows.




Earlier this spring, when I was checking out different Linux dist's to replace Windows completely (due to perf. and security), Manjaro/Arch Linux was part of them, but didn't like how stuff was organised, compared to Debian/*Ubuntu. As in my case, the BOINC software was partly located in /home/[user], where it shouldn't be due to security reasons. At that time, I didn't want to mess with the installation of BOINC, so I kept it 'as is'. I know I can change the directories of concern, so I'll try again.