Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Update Problem: cannot connect to amd servers


I have win 10  Pro

and a AMD Raedon R9 370X (Currently running version 18.3.3 (manually installed))

The Problem i have is, that always If i ll try to update I ll get the error: Cannot connect to amd Servers, to look for an update (My Connection is fine + I ve tried fresh installs already quite often, it doesn t help...)

Actually I m just able to download the drivers manually + here the minimal setup doesn t works either, always getting the message all components are already installed If I ll try to update

I have this problem already for a longer time and it s getting a lil bit annoying (idk f it s important, but it worked some months ago just fine)

I really hope someone can help me to fix this

Thx very very much in advance

2 Replies
Journeyman III


anyone found a solution for this problem?

Best regards



Maybe you need the new auto detect tool, you'll find it on the drivers download page.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., G5 27in..