Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Update (new gui?) broke everything


I started to play MHW : Iceborne earlier, and my game crashed with an error (ERR:12 Graphic Device Crashed). I searched for a solution, and people said to update drivers, and I did it. I went from 19.11.X (don't remember) to the 20.1.1 version. With the update came a new gui and probably more. But when I tried to play a game, my performances went from 45-50 fps to 15-20. I first thought it was due to some recording or instant replay options since they make me lags, but they were off.
I uninstalled everything and tried to install 19.12.2 (the version I'm currently using) but it still lags.
For each installation I did a clean delete before, and restarted my computer after.
Is this a common issue, what can I do in order to get back my 30 fps?

I'm under windows 10 64bit.
GPU : R9 290X

CPU : i3-4430 3.0 GHz
RAM : 16Go

I know my cpu is a bit old and all, but since it worked before I'm pretty sure the problem comes from the new gui (or some settings maybe?). I tried to remove some of them and restart my game, but nothing worked yet.

If you need more informations, feel free to ask. I'll reinstall 20.1.1 since it's not the origin of my problem.
Hope you can help.

2 Replies
Journeyman III

Ok little update, I didn't change anything and now it works. Maybe it was related to the error? my gpu was too hot or something?

Adept II

Turning off DirectX 12 works for me. But I get abysmal fps.