Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Unity Games Crash on Launch

I am facing an issue where any time I try to launch a game based in unity, after a few moments of loading the game crashes. According to the error log 

"amdxx64.dll caused an Access Violation (0xc0000005)
in module amdxx64.dll at 0033:707754c2."

And this is backed up in the event viewer 

"Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\Pathfinder Kingmaker\Kingmaker.exe
Faulting module path: C:\WINDOWS\System32\DriverStore\FileRepository\u0385557.inf_amd64_ec9d8bb56fc39c0b\B385520\amdxx64.dll"

This problem occurred both before and after updating my 6600XT to the most recent drivers. I'm unsure exactly when the problem began, but the most recent time I updated my drivers prior to attempting to fix this issue was November 15th, for the Darktide Preorder Beta. These games used to run on my system, and no solution I've found so far has worked. I've tried disabling my firewall, running as administrator, updating my drivers, and reinstalling the games. I am not running Citrix, I have no controller/joycon devices plugged in, and have tried running the program from a cleanboot. I am completely out of ideas.

4 Replies

Hey, I just wanted to say that I noticed that with my AMD Radeon rx6600, I'm also having a game crash (HD Poker) in the month of November, and updating my graphics card driver doesn't change a thing; it's still crashing immediately on startup. Here is my log that mentions my graphics card: 

Event ID: 1000

Logged 12/6/2022 11:43:41

Keywords: Classic


Faulting application name: HD Poker.exe, version:, time stamp: 0x62dfeb55

Faulting module name: amdxx64.dll, version: 31.0.12029.10015, time stamp: 0x6387ad7c

Exception code: 0xc0000005

Fault offset: 0x00000000003854c2

Faulting process id: 0x3a40

Faulting application start time: 0x01d909ab0af5143e

Faulting application path: D:\SteamLibrary\steamapps\common\HD Poker\HD Poker.exe

Faulting module path: C:\Windows\System32\DriverStore\FileRepository\u0386220.inf_amd64_1894141ab65df02b\B386218\amdxx64.dll

Report Id: c783f797-c742-4a76-a112-eed352b8f11e

Faulting package full name:

Faulting package-relative application ID:

Can we get some help with this, AMD?

I ended up uninstalling my graphics driver and reinstalling the Adrenalin 22.5.1 (WHQL) release as rolling back wasn'tan option. This solved my problem, which leads me to believe it's inherent to the latest driver. 

Journeyman III

Any updates from AMD on this?   If not I guess I'll try your method as well. 

Journeyman III

So I had the same problem.  Anything based on Unity was crashing. 

AMD Ryzen 3600x CPU, Gigabyte Radeon 6700 XT 12G GPU (only 6 weeks old), 16 Gigs of Ram and plenty of SSD space.  

So your solution worked!  Though I experimented a little to see if I could continue to use the current driver.  Turns out I was I was able to still use the current driver in the end so I suspect the issue is garbage files from previous updates that may be interfering somehow. 

I did the following:

  1. Downloaded latest AMD driver for my GPU
  2. Downloaded a copy of DDU (freeware that removes any and all previous GPU drivers for a clean install), unzipped the file and had it ready to go. 
  3. Created a new Windows restore point just in case.
  4. Blocked Windows from any updates temporarily and disconnected internet (overkill I know)
  5. Then uninstalled AMD Adrenaline app. 
  6. Rebooted into Safe Mode. 
  7. In Safe Mode used DDU program which walks you through step by step.  It was a total of maybe 4-5 clicks of my mouse.  Super easy.  Cleaned out my system.  Took about 5 minutes or so then restarted in normal mode. 
  8. Installed the current AMD driver and restarted again. 
  9. more crashes with Unity based games!

 Thanks again for your solution and I hope this helps someone else!