Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Unable to install Windows - Ryzen 9 5900x , x570 mobo

Hi there, I have been struggling for a couple of days trying to figure out what's the reason why Windows 10 can't 'see' my NVMe disk on installation. Hi have read quite some posts related to this issue but so far none of them did the trick for me, hope anybody has already suffered this and can give me a hint.

System details:
RAM: Ballistix BL2K16G36C16U4B 3600 MHz, DDR4, DRAM, 32GB (16GB x2), CL16
CPU: AMD Ryzen 9 5900x
Disk: NVMe Sabrent Rocket 4 Gen4 x4 - SB-ROCKET-NVMe4-1TB
Motherboard: MSI mpg x570 gaming edge wifi
BIOS version: E7C37AMS.1E1
VGA: Gigabyte GEFORCE GT 730

System settings:
Disk configuration in BIOS:

Settings\Advanced\Integrated Peripherals
- SATA Mode = RAID Mode
- Onboard Wi-FI module control = disabled

Settings\Advanced\Windows OS configuration = CSM (I also tried setting this to uefi and secure boot disabled)

Settings\Advanced\RAIDXpert2 Configuration utility
- Array properties
Associated Physical Disks NVMe Gen4x4 Online

- Boot mode select = UEFI (tried UEFI+Legacy)

I tried with multiple drivers, following same order (bottom, raid, cfg) :
- MSI drivers: AM4 RAID Driver Versión
- AMD drivers: AMD RAID Driver (SATA, NVMe RAID) Revision Number

Tried with NVMe_CC NVMe_DD and RAID_SATA. When you download the drivers they are split in those 3 folders. No luck with any of them nor mixed.

Windows Image used: Win10_20H2_v2_EnglishInternational_x64.iso (latest from Microsoft site)
Bootable drive created with: sudo dd bs=8M if=Win10_20H2_v2_EnglishInternational_x64.iso of=/dev/sda conv=fdatasync status=progress at Linux

Ubuntu installation finished successfully being able to see the M.2 drive and partitioning it as well.
I also tried DISKPART setting gpt as well as MBR, didn't make any effect.

1 Solution
Adept III


Maybe try this  ( go forward in video to 2 minutes..  ( but maybe watch the entire video as well ))

View solution in original post

4 Replies
Adept III


Maybe try this  ( go forward in video to 2 minutes..  ( but maybe watch the entire video as well ))

​​​​​​​Update from Retailer
If the motherboard was purchased through a computer parts retailer, check with the retailer to see if they can facilitate the BIOS update at their location. There may be a charge for this, or it may be offered at no cost.
If you have access to a processor supported on the current installed BIOS, use it to perform the BIOS update, then swap out the processors when the update process is complete. For a list of supported processors per BIOS version, please refer to the CPU Support List document available on the motherboard manufacturer's website. BIOS download and installation instructions are also found on their website.

USB BIOS Flashback
Select motherboards are designed to support “USB BIOS Flashback,” which allows for BIOS updates from a flash drive—even if the current BIOS on the motherboard does not have the software code to boot a new processor. Some motherboards can even update the BIOS without a CPU installed. Such motherboards feature special hardware to enable USB BIOS Flashback, and every manufacturer has a unique procedure to execute USB BIOS Flashback. Customers are encouraged to determine if their motherboard supports USB BIOS Flashback and, if yes, follow the update steps described in the motherboard’s support documentation.

Original Manufacturer Replacement
The Original Design Manufacturer (ODM) of the motherboard will support affected customers with an RMA exchange for a compatible motherboard, upon request. Affected customers are recommended to contact their local representative for the motherboard manufacturer to exchange their motherboard.
If these workarounds are not feasible, please see the Boot Kit Loan section below.

Hope this helps


Turns out that I was not building properly the bootable USB drive for Windows I also had some miss configured mobo settings.

I am used to Linux distributions where you do:

sudo dd bs=4M if=OSimage.iso of=/dev/device status=progress oflag=sync

This method, still creates a bootable USB drive with Windows but IT DOES NOT work. You would be able to click Install windows button but no matter which drivers you do use it won't be able to find any hard disk device. This is why I was puzzled for a couple of days.

After disabling CSM, setting secureboot and UEFI in my mobo (as your video suggest) apart of creating a bootable drive in a propper manner, I have been able to install Windows and now I do have both Arch Linux and Windows running smoothly with dual boot.

Thanks a lot!

For Windows non-so-familiar future readers, this is how I have created my windows bootable USB drive on linux:

Adept II

Installing the new graphics card

Power down the PC.
Hit the switch on the back of the PC to turn off supply to the PSU.
Extract the side panel (usually held on by two screws on the rear).
If you do not already have a GPU installed, skip to Step 7.
Remove the screws holding the GPU in on the rear bracket.
Unlock the PCI-e slot clip.
Remove the GPU by lightly pulling on the card.
Hover the new GPU over PCI-e slot.
Push down on the GPU to slide the connector into the slot.
Ensure the secure lock clicks into place.
Screw the rear bracket down to secure the card to the chassis.
Connect any required PSU cables.
Reattach the side panel.