Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

unable to install any AMD driver package since Adrenaline on Windows 10

I have been unable to install any of the recent driver package updates, 18.12.2, 18.12.3, 19.1.1, etc, up to the most recent 19.4.3.  This happens on two identical pcs.  Both crash during the driver install and put the computers into a boot loop.  I have to go into safe mode, open device manager and uninstall the AMD driver, then restart.  The most recent AMD driver package I can install on these computers is Adrenaline from December 2018.  I just reinstall that after I've attempted updating to the newest release.  Frustrating.

If you have any suggestions on what the issue could be with the newer releases, let me know!


My System Specs:

GPU: AMD Radeon R9 390X

Driver: Radeon Software Adrenalin Edition Driver Version (Windows Driver Store Version 25.20.14011.10001)

Computer: Desktop, HP Phoenix Envy 860-170VR

Operating System: Windows 10 Home 64-bit (10.0, Build 17763) 

BIOS: A0.59 (type: UEFI)

Processor: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz (8 CPUs), ~4.0GHz

Memory: 8192MB RAM

DirectX Version: DirectX 12

15 Replies

I have a R9 390 and all 19. drivers install without a problem.

Usually when updating to a new Annual release driver (from previous Annual version) it is suggested/recommended to clean install to the new version.

Also possible windows is trying to override the install.

Download/save the current full driver pkg direct from AMD, disconnect from internet. start driver install and choose custom clean install, should go through two restarts, do not reconnect to internet until after this. 

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

Thanks for the suggestion but that doesn't work. I think I've literally tried everything that I as well as others can possibly think of over the past 4 months.  Internet/no internet, DDU in safe mode, changing system BIOS versions, changing other drivers, rolling back Windows 10 to previous versions, swapping memory, etc etc.  Also like I mentioned I can't even install 18.12.2 so its not an annual release issue.  The only thing disconnecting from the internet does different is the computer restarts a few times (instead of just screen flicker) but eventually it gets stuck in the same startup repair boot loop.  Then I'm back to my OP.  I've never had to disconnect from the internet for any GPU update in recent years at least, I get why doing that is the safest bet but that shouldn't ever be necessary these days.  Others are having this same problem too, but I'm not sure if its with the same driver package versions.  I was initially thinking AMD must've changed something between and 18.12.2.  There must be some other system device causing issues but I'm at a loss.  Only thing I do now when a new version releases is try installing and if it doesn't work I just end up reinstalling  If you have any other ideas please let me know.  Thanks


Have you tried any/all of the following,

Guess you've also tried checking if AV/firewall/ransomware settings are possible cause.

Have you tried a repair/replace install of Win 10.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

The only error I've been able to find is Error 99, can't remember what report that popped up but I think it was some startup repair error report.  The suggested fixes for error 99 are trying things like DDU in safe mode or disconnecting the internet for install or sfc or DISM because I think it references some corrupt file but there's no corruption.  Its been a while since I even bothered checking error reporting, sfc and DISM always come back good though.  Doing a repair with the disk or macrium reflect don't help.  Whatever else I could think of in CMD as well as different versions of windows PE and different startup repairs, different versions of Win 10.  AV and firewall stuff made no difference.  Tried some regedits.  Only thing I may not have done is a completely clean install of Win 10 but now that I think of it I may have because I remember reloading all software at some point on one of the computers.  I've tried a lot of ish.  This is occurring on 2 of the same model computers, both have different software, monitor, keyboard and mice.  I've tried removing all non essential USB stuff, etc etc.  IMO it has something to do with all of the new features AMD added in 18.12.2 since that's where my problem started.  Guru3D lists all the new features that weren't in here: 18.12.2 page, scroll down to new features

One of the big issues often overlooked is the caching of the old driver data that corrupts the driver being install. You have to disable Fast Startup for whatever reason to get the drivers to load on many of these R series cards. The prior advice you got was sound just needs another step. Please give it a try. 

Download the current driver.

Download DDU from Wagnardsoft_com. Read the instructions. 

Disable Fast Startup / Hibernation. (you can re-enable this later if you want)

Disconnect from the Internet. 

Run Safemode with no Internet and run DDU removing all GPU driver

Restart to normal and install the latest driver with the Internet disable.

Note many have reported high temps immediately after the black screens and boot loops. I fear that many chips are ruined by this hang. 

If this doesn't help, I would try that card in another machine to test if it is still working properly. If not you know the card has gone bad.  


pokester‌ I've already tried all that DDU stuff but tried again a few times in hopes something changed more recently, still a fail.  Also just an fyi, but the fast startup setting doesn't affect restarts, shouldn't have any bearing on this.  I never use hibernate either, always off.  Well, the most recent driver package I can install remains as  

goodplay‌ I misspoke on Error 99.  That's actually just an error regarding a driver without a digital sig.  In this case I think it happens because the install process hangs and the restart happens before the driver registers.  For example, if I try to install a newer driver package beyond, get the hang and restart into safe mode and try installing a different driver (without removing what's there via Device Manager or DDU), that's when Error 99 pops up.  I think that's pretty much irrelevant to what's actually causing the drivers to fail installing in the first place though.


Same here:

Harware: MSI GX 70 Destroyer, AMD-A10 5750M with HD 8650G & R9 M290X

Clean win10 1809 install, no internet connection (to prevent updates of manual drivers)

The only driver which works is amd-catalyst-15.7.1-win10-64bit.

I tried again with fresh, untouched win10 installation following the advice here to no avail:

Installing AMD Drivers On A10-5750M + HD 8970M ... | Community

I reinstalled a clean win10 again, this time installed all win10 updates. Then I retried installation of the latest drivers win10-64bit-radeon-software-adrenalin-2019-edition-19.4.1-apr3:

win10 seems to simply refuse it.

Now I give up. Lets hope AMD and MS will find a solution.


The solution is to use the correct drivers. Please read > Laptop graphics update...How to 

For laptops with AMD processors/APU's:

You do not update the discrete graphics update the APU. This updated driver serves both the integrated and discrete graphics. It is the only driver you install.

Your APU is considered Legacy...meaning no more updates. The newer graphics drivers do not support your laptop.

The last/latest drivers > A10-5750M with Radeon™ HD 8650G Drivers & Support | AMD 


Thank you for the informations.

Do I understand you right that I should only install the driver for my APU, which will then leave my R9 M290X discrete graphics card with an completely outdated driver from 2015?

In that case I am wondering, why I can have 2 separate drivers installed on Win7? The outdated 15.7.1 for my APU and the Win7-64Bit-Radeon-Software-Adrenalin-Edition-18.9.2-Sept19 for my R9 M290X?

Does this not prove that my problem is related to Win10 and the Win10 drivers, AMD provided?


I don't know what it proves...I do know that the laptop will not function correctly with any drivers past 16.2.1. There have been no drivers for three it's hardly a surprise. This is not confined to AMD APU's...people that have laptops with  Intel processors (with HD3000 integrated graphics and older) have the same issue. Google WDM requirements for Win10.

Laptops with switchable AMD/Intel graphics Windows 10 support 

Well, thanks kingfish!

I have wasted hours and hours to try get it working. Now I know that it really is Windows 10 which prevents me from using two different drivers for my two different graphic cards.

My only comfort is that Nvidia users are facing the same problems.

I resolved this issue by going back to Windows 7, which will be end of life in year 2020. I guess Microsoft is not interested in MY personal data, since they force me to continue using Windows 7.

I'm still on W7 myself....and will stay with it 'till the bitter end




I have this same issue with my iMac 27 late 2009 with ati Radeon 4670..

Upgrading from Windows 7 to Windows 10 in place helped. The Windows update installed driver worked..

However on a fresh install of Windows 10 gives this black screen problem..



Well i just managed to get the latest Adrenaline to work, after scouring for weeks to figure it out, so thought id share with you guys, since ive probably googled back to this page over and over

Adept I

If your GPU is from sub vendor HP, then we might have had the same issue. I came to the conclusion that there is an issue with the stock BIOS for HP's AMD R9 390X causing the driver install to fail and the system to hang.

I have created a custom BIOS for the AMD R9 390X HP OEM. I used an XFX BIOS (XFX.R9390X.8192.150612.rom) and updated fan and other settings to be equal to the original HP one.

I have flashed it and the GPU is working fine now. AMD drivers were updated to the latest version "Win10-Radeon-Software-Adrenalin-2020-Edition-20.5.1-June10", 27.20.1017.1011.

A link to the modified ROM below. Use at own risk.
HP AMD Radeon R9 390X 113-C67132-104 - fixed

Output from GPU-Z: