cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

pyoorkate
Journeyman III

Ubuntu Studio with Radeon RX580 / DKMS failure

Hi,

I'm wondering if anyone has a solution to getting the AMDGPU-Pro drivers (specifically, I believe I need the OpenCL bit of the drivers) to install on Ubuntu Studio (or CentOS Stream if I must). I'm wanting to run DaVinci Resolve, but any attempt to install the AMDPro drivers fails - with a DKMS error.

The previous suggested workaround for DKMS not building against any faintly current kernel:

./amdgpu-pro-install --opencl=pal,legacy --headless --no-dkms

no longer works - producing:

ERROR: using --no-dkms with a pro install is invalid.
Did you want to run the following instead?
amdgpu-install --no-dkms

The amdgpu-install, however, won't install OpenCL. Which is unhelpful.

I've also tried the tweak of editing /etc/osrelease (here: https://math.dartmouth.edu/~sarunas/amdgpu.html)

 

That at least allows the installer to run, but installing produces this output:

amdgpu-pro-install --opencl=legacy,pal
deb [ trusted=yes ] file:/var/opt/amdgpu-pro-local/ ./
Get:1 file:/var/opt/amdgpu-pro-local ./ InRelease
Ign:1 file:/var/opt/amdgpu-pro-local ./ InRelease
Get:2 file:/var/opt/amdgpu-pro-local ./ Release [816 B]
Get:2 file:/var/opt/amdgpu-pro-local ./ Release [816 B]
Get:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg             
Ign:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg        
Get:4 file:/var/opt/amdgpu-pro-local ./ Packages [114 kB]  
Hit:5 http://us.archive.ubuntu.com/ubuntu groovy InRelease        
Get:6 http://security.ubuntu.com/ubuntu groovy-security InRelease [110 kB]
Hit:7 http://us.archive.ubuntu.com/ubuntu groovy-updates InRelease
Get:8 http://us.archive.ubuntu.com/ubuntu groovy-backports InRelease [101 kB]
Fetched 211 kB in 1s (317 kB/s)                                      
Reading package lists... Done
WARNING: PAL OpenCL has been dropped in favour of ROCr.\nROCr OpenCL will be installed instead of PAL OpenCL.\nPlease advise that this option is deprecated and will be removed in \nfuture releases. Please use '--opencl=rocr' inst
ead.
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Selected version '20.45-1188099' (localhost [all]) for 'amdgpu-pro-pin'
The following packages were automatically installed and are no longer required:
 dkms libatomic1:i386 libbsd0:i386 libdrm-amdgpu1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libelf1:i386 libexpat1:i386 libffi8ubuntu1:i386 libjs-prototype libjs-scriptaculous libllvm11:i386
 libomxil-bellagio-bin libomxil-bellagio0 libstdc++6:i386 libva2:i386 libvdpau1:i386 libwayland-client0:i386 libwayland-egl1:i386 libwayland-server0:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386
 libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386 libxcb-sync1:i386 libxcb-xfixes0:i386 libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxshmfence1:i386 libxxf86vm1:i386
 mesa-vdpau-drivers:i386 vdpau-driver-all:i386
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
 amdgpu-pro-pin
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/6,284 B of archives.
After this operation, 38.9 kB of additional disk space will be used.
Get:1 file:/var/opt/amdgpu-pro-local ./ amdgpu-pro-pin 20.45-1188099 [6,284 B]
Selecting previously unselected package amdgpu-pro-pin.
(Reading database ... 423326 files and directories currently installed.)
Preparing to unpack .../amdgpu-pro-pin_20.45-1188099_all.deb ...
Unpacking amdgpu-pro-pin (20.45-1188099) ...
Setting up amdgpu-pro-pin (20.45-1188099) ...
Reading package lists... Done
Building dependency tree        
Reading state information... Done
The following packages were automatically installed and are no longer required:
 dkms libatomic1:i386 libbsd0:i386 libdrm-amdgpu1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libelf1:i386 libexpat1:i386 libffi8ubuntu1:i386 libjs-prototype libjs-scriptaculous libllvm11:i386
 libomxil-bellagio-bin libomxil-bellagio0 libstdc++6:i386 libva2:i386 libvdpau1:i386 libwayland-client0:i386 libwayland-egl1:i386 libwayland-server0:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386
 libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386 libxcb-sync1:i386 libxcb-xfixes0:i386 libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxshmfence1:i386 libxxf86vm1:i386
 mesa-vdpau-drivers:i386 vdpau-driver-all:i386
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
 amdgpu-pin
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/2,740 B of archives.
After this operation, 26.6 kB of additional disk space will be used.
Get:1 file:/var/opt/amdgpu-pro-local ./ amdgpu-pin 20.45-1188099 [2,740 B]
Selecting previously unselected package amdgpu-pin.
(Reading database ... 423345 files and directories currently installed.)
Preparing to unpack .../amdgpu-pin_20.45-1188099_all.deb ...
Unpacking amdgpu-pin (20.45-1188099) ...
Setting up amdgpu-pin (20.45-1188099) ...
Reading package lists... Done
Building dependency tree        
Reading state information... Done
The following packages were automatically installed and are no longer required:
 libjs-prototype libjs-scriptaculous
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
 amdgpu-core amdgpu-dkms-firmware amdgpu-lib amdgpu-pro-core comgr-amdgpu-pro gst-omx-amdgpu hip-rocr-amdgpu-pro hsa-runtime-rocr-amdgpu hsakmt-roct-amdgpu libdrm-amdgpu-amdgpu1 libdrm-amdgpu-amdgpu1:i386 libdrm-amdgpu-common
 libdrm-amdgpu-radeon1 libdrm-amdgpu-radeon1:i386 libdrm2-amdgpu libdrm2-amdgpu:i386 libegl1-amdgpu-mesa libegl1-amdgpu-mesa:i386 libegl1-amdgpu-mesa-drivers libegl1-amdgpu-mesa-drivers:i386 libegl1-amdgpu-pro
 libegl1-amdgpu-pro:i386 libgbm1-amdgpu libgbm1-amdgpu:i386 libgl1-amdgpu-mesa-dri libgl1-amdgpu-mesa-dri:i386 libgl1-amdgpu-mesa-glx libgl1-amdgpu-mesa-glx:i386 libgl1-amdgpu-pro-appprofiles libgl1-amdgpu-pro-dri
 libgl1-amdgpu-pro-dri:i386 libgl1-amdgpu-pro-ext libgl1-amdgpu-pro-glx libgl1-amdgpu-pro-glx:i386 libglapi-amdgpu-mesa libglapi-amdgpu-mesa:i386 libglapi1-amdgpu-pro libglapi1-amdgpu-pro:i386 libgles1-amdgpu-mesa
 libgles1-amdgpu-mesa:i386 libgles2-amdgpu-mesa libgles2-amdgpu-mesa:i386 libgles2-amdgpu-pro libgles2-amdgpu-pro:i386 libllvm10.0-amdgpu libllvm10.0-amdgpu:i386 libosmesa6-amdgpu libosmesa6-amdgpu:i386 libxatracker2-amdgpu
 libxatracker2-amdgpu:i386 mesa-amdgpu-omx-drivers mesa-amdgpu-va-drivers mesa-amdgpu-va-drivers:i386 mesa-amdgpu-vdpau-drivers mesa-amdgpu-vdpau-drivers:i386 ocl-icd-libopencl1-amdgpu-pro opencl-rocr-amdgpu-pro
 xserver-xorg-amdgpu-video-amdgpu
Suggested packages:
 libglide3 libglide3:i386
Recommended packages:
 libtxc-dxtn-s2tc0 | libtxc-dxtn0 libtxc-dxtn-s2tc0:i386 | libtxc-dxtn0:i386
The following NEW packages will be installed:
 amdgpu amdgpu-core amdgpu-dkms amdgpu-dkms-firmware amdgpu-lib amdgpu-lib32 amdgpu-pro amdgpu-pro-core amdgpu-pro-lib32 amdgpu-pro-rocr-opencl clinfo-amdgpu-pro comgr-amdgpu-pro gst-omx-amdgpu hip-rocr-amdgpu-pro
 hsa-runtime-rocr-amdgpu hsakmt-roct-amdgpu libdrm-amdgpu-amdgpu1 libdrm-amdgpu-amdgpu1:i386 libdrm-amdgpu-common libdrm-amdgpu-radeon1 libdrm-amdgpu-radeon1:i386 libdrm2-amdgpu libdrm2-amdgpu:i386 libegl1-amdgpu-mesa
 libegl1-amdgpu-mesa:i386 libegl1-amdgpu-mesa-drivers libegl1-amdgpu-mesa-drivers:i386 libegl1-amdgpu-pro libegl1-amdgpu-pro:i386 libgbm1-amdgpu libgbm1-amdgpu:i386 libgl1-amdgpu-mesa-dri libgl1-amdgpu-mesa-dri:i386
 libgl1-amdgpu-mesa-glx libgl1-amdgpu-mesa-glx:i386 libgl1-amdgpu-pro-appprofiles libgl1-amdgpu-pro-dri libgl1-amdgpu-pro-dri:i386 libgl1-amdgpu-pro-ext libgl1-amdgpu-pro-glx libgl1-amdgpu-pro-glx:i386 libglapi-amdgpu-mesa
 libglapi-amdgpu-mesa:i386 libglapi1-amdgpu-pro libglapi1-amdgpu-pro:i386 libgles1-amdgpu-mesa libgles1-amdgpu-mesa:i386 libgles2-amdgpu-mesa libgles2-amdgpu-mesa:i386 libgles2-amdgpu-pro libgles2-amdgpu-pro:i386
 libllvm10.0-amdgpu libllvm10.0-amdgpu:i386 libosmesa6-amdgpu libosmesa6-amdgpu:i386 libxatracker2-amdgpu libxatracker2-amdgpu:i386 mesa-amdgpu-omx-drivers mesa-amdgpu-va-drivers mesa-amdgpu-va-drivers:i386
 mesa-amdgpu-vdpau-drivers mesa-amdgpu-vdpau-drivers:i386 ocl-icd-libopencl1-amdgpu-pro opencl-orca-amdgpu-pro-icd opencl-rocr-amdgpu-pro vulkan-amdgpu-pro xserver-xorg-amdgpu-video-amdgpu
0 upgraded, 67 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/173 MB of archives.
After this operation, 1,210 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 file:/var/opt/amdgpu-pro-local ./ amdgpu-dkms-firmware 1:5.6.20.906316-1188099 [6,022 kB]
Get:2 file:/var/opt/amdgpu-pro-local ./ amdgpu-dkms 1:5.6.20.906316-1188099 [5,692 kB]
Get:3 file:/var/opt/amdgpu-pro-local ./ amdgpu-core 20.45-1188099 [2,220 B]
Get:4 [CUT FOR LENGTH]

Setting up libgles1-amdgpu-mesa:amd64 (1:20.1.6-1188099) ...
Setting up libgles1-amdgpu-mesa:i386 (1:20.1.6-1188099) ...
Setting up amdgpu-dkms (1:5.6.20.906316-1188099) ...
Loading new amdgpu-5.6.20.906316-1188099 DKMS files...
Building for 5.8.0-25-lowlatency 5.8.0-34-lowlatency
Building for architecture x86_64
Building initial module for 5.8.0-25-lowlatency
ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/amdgpu-dkms.0.crash'
Error! Bad return status for module build on kernel: 5.8.0-25-lowlatency (x86_64)
Consult /var/lib/dkms/amdgpu/5.6.20.906316-1188099/build/make.log for more information.
dpkg: error processing package amdgpu-dkms (--configure):
installed amdgpu-dkms package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of amdgpu:
amdgpu depends on amdgpu-dkms (= 1:5.6.20.906316-1188099); however:
 Package amdgpu-dkms is not configured yet.

dpkg: error processing package amdgpu (--configure):
dependency problems - leaving unconfigured
Setting up xserver-xorg-amdgpu-video-amdgpu (1:19.1.0-1188099) ...
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                         Setting up mesa-amdgpu-omx-drivers:amd64 (1:20.1.6-1188099) ...
Setting up libegl1-amdgpu-mesa:amd64 (1:20.1.6-1188099) ...
Setting up libegl1-amdgpu-mesa:i386 (1:20.1.6-1188099) ...
Setting up libgl1-amdgpu-mesa-glx:amd64 (1:20.1.6-1188099) ...
Setting up libgl1-amdgpu-mesa-glx:i386 (1:20.1.6-1188099) ...
Setting up amdgpu-pro-core (20.45-1188099) ...
Setting up libgles2-amdgpu-mesa:amd64 (1:20.1.6-1188099) ...
Setting up libgles2-amdgpu-mesa:i386 (1:20.1.6-1188099) ...
Setting up opencl-orca-amdgpu-pro-icd:amd64 (20.45-1188099) ...
Setting up libgl1-amdgpu-mesa-dri:amd64 (1:20.1.6-1188099) ...
Setting up libgl1-amdgpu-mesa-dri:i386 (1:20.1.6-1188099) ...
dpkg: dependency problems prevent configuration of amdgpu-pro-rocr-opencl:
amdgpu-pro-rocr-opencl depends on amdgpu-dkms (= 1:5.6.20.906316-1188099); however:
 Package amdgpu-dkms is not configured yet.

dpkg: error processing package amdgpu-pro-rocr-opencl (--configure):
dependency problems - leaving unconfigured
Setting up vulkan-amdgpu-pro:amd64 (20.45-1188099) ...
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                         Setting up libosmesa6-amdgpu:amd64 (1:20.1.6-1188099) ...
Setting up libosmesa6-amdgpu:i386 (1:20.1.6-1188099) ...
dpkg: dependency problems prevent configuration of amdgpu-pro:
amdgpu-pro depends on amdgpu (= 20.45-1188099); however:
 Package amdgpu is not configured yet.

dpkg: error processing package amdgpu-pro (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                             Setting up comgr-amdgpu-pro:amd64 (1.7.0-1188099) ...
Setting up hsa-runtime-rocr-amdgpu:amd64 (1.2.0-1188099) ...
Setting up ocl-icd-libopencl1-amdgpu-pro:amd64 (20.45-1188099) ...
Setting up clinfo-amdgpu-pro (20.45-1188099) ...
Setting up hip-rocr-amdgpu-pro (20.45-1188099) ...
dpkg: dependency problems prevent configuration of amdgpu-pro-lib32:
amdgpu-pro-lib32 depends on amdgpu (= 20.45-1188099) | amdgpu-hwe (= 20.45-1188099); however:
 Package amdgpu is not configured yet.
 Package amdgpu-hwe is not installed.
amdgpu-pro-lib32 depends on amdgpu-pro (= 20.45-1188099) | amdgpu-pro-hwe (= 20.45-1188099); however:
 Package amdgpu-pro is not configured yet.
 Package amdgpu-pro-hwe is not installed.

dpkg: error processing package amdgpu-pro-lib32 (--configure):
dependency problems - leaving unconfigured
Setting up libglapi1-amdgpu-pro:amd64 (20.45-1188099) ...
No apport report written because MaxReports is reached already
                                                             Setting up libglapi1-amdgpu-pro:i386 (20.45-1188099) ...
Setting up libgl1-amdgpu-pro-dri:amd64 (20.45-1188099) ...
Setting up libgl1-amdgpu-pro-dri:i386 (20.45-1188099) ...
Setting up libgl1-amdgpu-pro-appprofiles (20.45-1188099) ...
Setting up libegl1-amdgpu-pro:amd64 (20.45-1188099) ...
Setting up libegl1-amdgpu-pro:i386 (20.45-1188099) ...
Setting up libegl1-amdgpu-mesa-drivers:amd64 (1:20.1.6-1188099) ...
Setting up libegl1-amdgpu-mesa-drivers:i386 (1:20.1.6-1188099) ...
Setting up libgles2-amdgpu-pro:amd64 (20.45-1188099) ...
Setting up libgles2-amdgpu-pro:i386 (20.45-1188099) ...
Setting up libgl1-amdgpu-pro-glx:amd64 (20.45-1188099) ...
Setting up libgl1-amdgpu-pro-glx:i386 (20.45-1188099) ...
Setting up opencl-rocr-amdgpu-pro:amd64 (20.45-1188099) ...
Setting up libgl1-amdgpu-pro-ext:amd64 (20.45-1188099) ...
Setting up amdgpu-lib (20.45-1188099) ...
Setting up amdgpu-lib32 (20.45-1188099) ...
Processing triggers for libc-bin (2.32-0ubuntu3) ...
Errors were encountered while processing:
amdgpu-dkms
amdgpu
amdgpu-pro-rocr-opencl
amdgpu-pro
amdgpu-pro-lib32
E: Sub-process /usr/bin/dpkg returned an error code (1)

I'm currently running Ubuntu 20.10, but have tried to install it on Ubuntu 20.04, and CentOS stream - both of which failed with the same error (presumably because the kernel has been updated - I'm currently on 5.8.0-25-lowlatency, which I understand dkms can't build against).

Any help would be greatly appreciated. TIA!

0 Kudos