cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II
Adept II

Ubuntu linux amdgpu-pro 18.30 incomplete: '--px' install misses xserver modesetting package

Hello everybody,

trying to install the amdgpu-pro 18.30-641594 driver on Ubuntu linux 18.04.1

using the '--px' switch for switchable graphics results in an

"E: Unable to locate package xserver-xorg-video-modesetting-amdgpu-pro"

Would it be possible to make this package available, or alternatively,

updating the driver package so that it contains the missing package?

Regards,

qnerd

0 Kudos
5 Replies
Esteemed Contributor III

Re: Ubuntu linux amdgpu-pro 18.30 incomplete: '--px' install misses xserver modesetting package

This linux AMD Forum may help you find an answer if you can't find one from here: https://www.phoronix.com/forums/forum/linux-graphics-x-org-drivers/amd-linux

Don't know if this website on Mint Linux 18.3 may help or not. Installing AMDGPU-PRO in 18.3 breaks graphics - Linux Mint Forums

How to install latest AMD Drivers in Bionic Ubuntu: https://linuxconfig.org/how-to-install-the-latest-amd-radeon-drivers-on-ubuntu-18-04-bionic-beaver-l...

0 Kudos
Adept II
Adept II

Re: Ubuntu linux amdgpu-pro 18.30 incomplete: '--px' install misses xserver modesetting package

elstaci,

thanks for the links, they definitely make an interesting read!

According to what I have been able to find on the phoronix forums, the --px switch

worked until amdgpu-pro version 17.x. I checked the driver content, and indeed, the

xserver modesetting package does exist in there.

In the amdgpu-pro driver versions 18.20 / 18.30 for ubuntu 18.04 the package is missing, though.

Which then results in the installer error.

Thisis somewhat sad, as the switch is even better documented than before in

the new amdgpu-pro 18.30 documentation at:

Installing or Uninstalling AMDGPU — amdgpu graphics and compute stack 18.30 documentation

Regards,

qnerd

0 Kudos
Adept II
Adept II

Re: Ubuntu linux amdgpu-pro 18.30 incomplete: '--px' install misses xserver modesetting package

Does anybody have a switchable graphics system in production use

for OpenCl usage?

Is the missing package even necessary?

Regards,

qnerd

0 Kudos
Adept II
Adept II

Re: Ubuntu linux amdgpu-pro 18.30 incomplete: '--px' install misses xserver modesetting package

I wrote a bugreport for amdgpu-pro as suggested by the documentation

for amdgpu-pro on linux, version 18.30, at the bugzilla/freedesktop site.

In addition, I notified the AMD customer care about the missing file in the driver

archive. I am not sure about the reception, though... I do hope

they passed it on to the technical support.

Would there be something else I can do in order to make the issue known & fixed?

Regards,

qnerd

0 Kudos
Adept II
Adept II

Re: Ubuntu linux amdgpu-pro 18.30 incomplete: '--px' install misses xserver modesetting package

After searching some more, there is also a post here in the forum

displaying the content of a previous amdgpu-pro driver for linux, still containing

the package that is now missing from the driver:

In Sapphire Nitro Radeon RX 480 OC on Linux Mint 18.1

it is stated:

rogier@123456 ~/Downloads/amdgpu-pro-16.60-379184 $ l

amdgpu-pro_16.60-379184_amd64.deb

amdgpu-pro_16.60-379184_i386.deb

...

xserver-xorg-video-modesetting-amdgpu-pro_1.18.3-379184_amd64.deb

..

And this last one seems to be the package that is missing from the 18.x drivers.

Has somebody been able to get hold of one for the 18.x series of linux drivers?

Regards,

qnerd

0 Kudos